summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2004-06-23 21:36:39 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2004-06-23 21:36:39 +0000
commit7ef948fc07cc8149d5dbedb5f24a22eb68e4af23 (patch)
treef01da82d9ab1b2c1a722ac96acf358172f8c6c01 /media-plugins/swh-plugins
parentAdded to ~ppc (diff)
downloadhistorical-7ef948fc07cc8149d5dbedb5f24a22eb68e4af23.tar.gz
historical-7ef948fc07cc8149d5dbedb5f24a22eb68e4af23.tar.bz2
historical-7ef948fc07cc8149d5dbedb5f24a22eb68e4af23.zip
Patched to make code compatible with more strict GCC checking. Closes bug #54262.
Diffstat (limited to 'media-plugins/swh-plugins')
-rw-r--r--media-plugins/swh-plugins/ChangeLog9
-rw-r--r--media-plugins/swh-plugins/Manifest5
-rw-r--r--media-plugins/swh-plugins/files/digest-swh-plugins-0.4.3-r11
-rw-r--r--media-plugins/swh-plugins/files/swh-plugins-0.4.3-compile.patch56
-rw-r--r--media-plugins/swh-plugins/swh-plugins-0.4.3-r1.ebuild38
5 files changed, 107 insertions, 2 deletions
diff --git a/media-plugins/swh-plugins/ChangeLog b/media-plugins/swh-plugins/ChangeLog
index 125454b34814..0f322031a7d7 100644
--- a/media-plugins/swh-plugins/ChangeLog
+++ b/media-plugins/swh-plugins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/swh-plugins
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/ChangeLog,v 1.16 2004/06/20 05:52:20 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/ChangeLog,v 1.17 2004/06/23 21:36:38 fvdpol Exp $
+
+*swh-plugins-0.4.3-r1 (23 Jun 2004)
+
+ 23 Jun 2004; Frank van de Pol <fvdpol@gentoo.org>
+ +files/swh-plugins-0.4.3-compile.patch, +swh-plugins-0.4.3-r1.ebuild:
+ Patched to make code compatible with more strict GCC checking. Closes bug
+ #54262.
19 Jun 2004; Jeremy Huddleston <eradicator@gentoo.org>
swh-plugins-0.4.3.ebuild:
diff --git a/media-plugins/swh-plugins/Manifest b/media-plugins/swh-plugins/Manifest
index 87ebfb1e612d..6315d315624b 100644
--- a/media-plugins/swh-plugins/Manifest
+++ b/media-plugins/swh-plugins/Manifest
@@ -1,7 +1,10 @@
-MD5 a79649e327cada8e9ec595ff7e35c21c ChangeLog 3050
+MD5 e50703e22447a41e3bdbbd68ef0ec7ea ChangeLog 3294
MD5 3e2f858c02dcacae4c384052bef22bb0 swh-plugins-0.4.2.ebuild 1004
MD5 c79d618dbdf37d1081a47fc15e1f7ebc swh-plugins-0.4.3.ebuild 1017
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
+MD5 5667a8716fd8323af81910569ebf1945 swh-plugins-0.4.3-r1.ebuild 1059
MD5 a211072ae4a6f238780abf17493f29a4 files/digest-swh-plugins-0.4.2 69
MD5 32e3b0473a59b47fad48f53d2dd9e1b3 files/digest-swh-plugins-0.4.3 69
MD5 ba085fb52c6c98c80b1250bf14c3e49c files/swh-plugins-quickfixes.patch 1194
+MD5 f2e2e9a24cb7656a2b80410230a8d5bc files/swh-plugins-0.4.3-compile.patch 2201
+MD5 32e3b0473a59b47fad48f53d2dd9e1b3 files/digest-swh-plugins-0.4.3-r1 69
diff --git a/media-plugins/swh-plugins/files/digest-swh-plugins-0.4.3-r1 b/media-plugins/swh-plugins/files/digest-swh-plugins-0.4.3-r1
new file mode 100644
index 000000000000..3b99d3ca3661
--- /dev/null
+++ b/media-plugins/swh-plugins/files/digest-swh-plugins-0.4.3-r1
@@ -0,0 +1 @@
+MD5 b248491d770d3f3bdaa96b0431e4ecd3 swh-plugins-0.4.3.tar.gz 796358
diff --git a/media-plugins/swh-plugins/files/swh-plugins-0.4.3-compile.patch b/media-plugins/swh-plugins/files/swh-plugins-0.4.3-compile.patch
new file mode 100644
index 000000000000..787ee3c0404c
--- /dev/null
+++ b/media-plugins/swh-plugins/files/swh-plugins-0.4.3-compile.patch
@@ -0,0 +1,56 @@
+--- swh-plugins-0.4.3-orig/delay_1898.xml 2004-06-23 23:06:32.673601008 +0200
++++ swh-plugins-0.4.3/delay_1898.xml 2004-06-23 23:08:48.793907576 +0200
+@@ -81,7 +81,7 @@
+
+ for (i=0; i<to_process; i++) {
+ float read = *(readptr++);
+- *(writeptr++) = *(in++);
++ *(writeptr++) = in[i];
+ buffer_write(out[i], read);
+ }
+
+@@ -103,7 +103,7 @@
+ read_phase = write_phase - (long)delay_samples;
+
+ read = buffer[read_phase & buffer_mask];
+- buffer[write_phase & buffer_mask] = *(in++);
++ buffer[write_phase & buffer_mask] = in[i];
+ buffer_write(out[i], read);
+ }
+
+@@ -199,7 +199,7 @@
+ read = LIN_INTERP (frac,
+ buffer[(read_phase-1) & buffer_mask],
+ buffer[read_phase & buffer_mask]);
+- buffer[write_phase & buffer_mask] = *(in++);
++ buffer[write_phase & buffer_mask] = in[i];
+ buffer_write(out[i], read);
+ write_phase++;
+ }
+@@ -219,7 +219,7 @@
+ read = LIN_INTERP (frac,
+ buffer[(read_phase-1) & buffer_mask],
+ buffer[read_phase & buffer_mask]);
+- buffer[write_phase & buffer_mask] = *(in++);
++ buffer[write_phase & buffer_mask] = in[i];
+ buffer_write(out[i], read);
+ }
+
+@@ -316,7 +316,7 @@
+ buffer[read_phase & buffer_mask],
+ buffer[(read_phase+1) & buffer_mask],
+ buffer[(read_phase+2) & buffer_mask]);
+- buffer[write_phase++ & buffer_mask] = *(in++);
++ buffer[write_phase++ & buffer_mask] = in[i];
+ buffer_write(out[i], read);
+ }
+ } else {
+@@ -337,7 +337,7 @@
+ buffer[read_phase & buffer_mask],
+ buffer[(read_phase+1) & buffer_mask],
+ buffer[(read_phase+2) & buffer_mask]);
+- buffer[write_phase & buffer_mask] = *(in++);
++ buffer[write_phase & buffer_mask] = in[i];
+ buffer_write(out[i], read);
+ }
+
diff --git a/media-plugins/swh-plugins/swh-plugins-0.4.3-r1.ebuild b/media-plugins/swh-plugins/swh-plugins-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..819502bdd6f4
--- /dev/null
+++ b/media-plugins/swh-plugins/swh-plugins-0.4.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/swh-plugins-0.4.3-r1.ebuild,v 1.1 2004/06/23 21:36:38 fvdpol Exp $
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="Large collection of LADSPA audio plugins/effects"
+HOMEPAGE="http://plugin.org.uk"
+SRC_URI="http://plugin.org.uk/releases/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="media-libs/ladspa-sdk
+ dev-libs/fftw
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A} || die
+ epatch ${FILESDIR}/${P}-compile.patch
+
+ cd ${S}
+ sed -i '/MACHINE=/s/.*/MACHINE=""/' configure
+}
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING README TODO || die
+}
+
+pkg_postinst() {
+ ewarn "WARNING: You have to be careful when using the "
+ ewarn "swh plugins. Be sure to lower your sound volume "
+ ewarn "and then play around a bit with the plugins so "
+ ewarn "you get a feeling for it. Otherwise your speakers"
+ ewarn "won't like that. "
+}