summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-02-15 13:19:37 +0000
committerDavid Holm <dholm@gentoo.org>2004-02-15 13:19:37 +0000
commit85815f82d8d1ee0d0d6c600086c5359a58eee613 (patch)
tree14bc7583226915aeeca25c99be33a402cae72b3d /media-sound/fluidsynth
parentAdded to ~ppc (diff)
downloadhistorical-85815f82d8d1ee0d0d6c600086c5359a58eee613.tar.gz
historical-85815f82d8d1ee0d0d6c600086c5359a58eee613.tar.bz2
historical-85815f82d8d1ee0d0d6c600086c5359a58eee613.zip
Resolved bug #35817 thanks to Axxackall. Keyworded ~ppc.
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/ChangeLog7
-rw-r--r--media-sound/fluidsynth/Manifest5
-rw-r--r--media-sound/fluidsynth/files/1.0.3-nonx86.patch11
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.3.ebuild11
4 files changed, 28 insertions, 6 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index ee003b38faea..9eaa4730c4ba 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/fluidsynth
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.3 2003/12/06 23:09:42 lanius Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.4 2004/02/15 13:19:36 dholm Exp $
+
+ 15 Feb 2004; David Holm <dholm@gentoo.org> fluidsynth-1.0.3.ebuild:
+ Added fix for nonx86 archs submitted by Axxackall. Keyworded ~ppc.
07 Dec 2003; Heinrich Wendel <lanius@gentoo.org> fluidsynth-1.0.1.ebuild,
fluidsynth-1.0.3.ebuild:
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index d3d8b9fd3273..298bb1b51084 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,5 +1,6 @@
+MD5 825a385738e9fb60c275d9836abb934f ChangeLog 1018
MD5 50fb28ffd92db87de6e107563f1138f7 fluidsynth-1.0.1.ebuild 1335
-MD5 95e8521342a361a867a45cab2f3270a6 fluidsynth-1.0.3.ebuild 1400
-MD5 434afc85c400e4b45bebe903ff504e4f ChangeLog 879
+MD5 f9a917a601f8a88a5e52671122bcef91 fluidsynth-1.0.3.ebuild 1479
MD5 76597f227dd6266c408aab1d4f58da85 files/digest-fluidsynth-1.0.1 68
MD5 751ab7ab31fc6b9ccf266a683545b750 files/digest-fluidsynth-1.0.3 68
+MD5 c1870b0eef4d2331c692f1206a55ac6d files/1.0.3-nonx86.patch 215
diff --git a/media-sound/fluidsynth/files/1.0.3-nonx86.patch b/media-sound/fluidsynth/files/1.0.3-nonx86.patch
new file mode 100644
index 000000000000..e10a7381f565
--- /dev/null
+++ b/media-sound/fluidsynth/files/1.0.3-nonx86.patch
@@ -0,0 +1,11 @@
+--- fluidsynth-1.0.3.orig/src/fluid_sys.c
++++ fluidsynth-1.0.3/src/fluid_sys.c
+@@ -704,7 +704,7 @@
+ return (rdtsc() / fluid_cpu_frequency);
+ }
+
+-#if defined(DARWIN)
++#if !defined(__i386__)
+
+ double rdtsc(void)
+ {
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild
index b6c8c2f228c7..3cad72d0a4ff 100644
--- a/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild
+++ b/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild,v 1.2 2003/12/06 23:09:42 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild,v 1.3 2004/02/15 13:19:36 dholm Exp $
inherit flag-o-matic
@@ -20,6 +20,13 @@ DEPEND="ladcca? ( media-libs/ladcca ) \
media-libs/ladspa-sdk \
alsa? ( media-libs/alsa-lib )"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-nonx86.patch
+}
+
src_compile() {
local myconf
myconf="--enable-ladspa"