summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Eichert <viz@gentoo.org>2003-01-08 22:59:42 +0000
committerTobias Eichert <viz@gentoo.org>2003-01-08 22:59:42 +0000
commit032ed28ea554fbdfe58f3eaa5eda2ef86cd7eb70 (patch)
tree2a5f35d2ef7bb8099d5dc53fa2380653d73175fe /media-sound
parentunmask x86 (diff)
downloadhistorical-032ed28ea554fbdfe58f3eaa5eda2ef86cd7eb70.tar.gz
historical-032ed28ea554fbdfe58f3eaa5eda2ef86cd7eb70.tar.bz2
historical-032ed28ea554fbdfe58f3eaa5eda2ef86cd7eb70.zip
ecasound version bump
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ecasound/ChangeLog15
-rw-r--r--media-sound/ecasound/ecasound-2.2.0_rc1.ebuild92
-rw-r--r--media-sound/ecasound/files/digest-ecasound-2.2.0_rc11
3 files changed, 107 insertions, 1 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index 031e16a7a2f8..9cbb3428a562 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for media-sound/ecasound-2.0.4.ebuild
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.1 2002/08/05 04:50:56 naz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.2 2003/01/08 22:59:42 viz Exp $
+
+*ecasound-2.2.0_rc1 ( 8 Jan 2003)
+
+ 8 Jan 2003; Tobias Eichert <viz@gentoo.org> ecasound-2.2.0_rc1.ebuild
+ files/digest-ecasound-2.2.0_rc1
+
+ Version bump.
+ Added "media-sound/jack-audio-connection-kit" as a dependency.
+ Anyways, jack support is optional but we don't have a jack USE
+ flag (see bug #12527). If you really like to compile ecasound
+ with jack disabled, just remove this dependency.
+ Thanks to Paul Thompson <thompson@pobox.com> for contribution
+ and minor ebuild cleanups. Closes bug #12381.
*ecasound-2.0.4.ebuild (04 Aug 2002)
diff --git a/media-sound/ecasound/ecasound-2.2.0_rc1.ebuild b/media-sound/ecasound/ecasound-2.2.0_rc1.ebuild
new file mode 100644
index 000000000000..31dca247056b
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.2.0_rc1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.2.0_rc1.ebuild,v 1.1 2003/01/08 22:59:42 viz Exp $
+
+IUSE="ncurses arts alsa python oss libmikmod audiofile oggvorbis"
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A package for multitrack audio processing"
+SRC_URI="http://ecasound.seul.org/download/${MY_P}.tar.gz"
+HOMEPAGE="http://eca.cx/"
+LICENSE="GPL-2"
+
+SLOT="1"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ media-libs/ladspa-sdk
+ media-sound/jack-audio-connection-kit
+ alsa? ( media-libs/alsa-lib )
+ oggvorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )
+ audiofile? ( media-libs/audiofile )
+ libmikmod? ( media-libs/libmikmod )
+ python? ( dev-lang/python )
+ ncurses? ( sys-libs/ncurses )"
+
+# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
+# use flags for them.
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cp configure 1
+ sed -e 's:map.h:map:g' 1 > configure
+
+}
+
+src_compile () {
+ local myconf
+
+ use alsa || myconf="$myconf --disable-alsa"
+ use arts || myconf="$myconf --disable-arts"
+ use ncurses || myconf="$myconf --disable-ncurses"
+ use audiofile || myconf="$myconf --disable-audiofile"
+ use oss || myconf="$myconf --disable-oss"
+
+ if use python; then
+ #
+ # ecasound is braindead about finding python includes/libdirs and
+ # about where to install modules. Luckily, it allows us to specify
+ # all this.
+ #
+ local python_version python_prefix python_includes python_modules
+ python_version="`python -c 'import sys; print sys.version[:3]'`"
+ python_prefix="`python -c 'import sys; print sys.prefix'`"
+
+ python_includes="$python_prefix/include/python$python_version"
+ python_modules="$python_prefix/lib/python$python_version"
+
+ # ecasound configure assumes `disable' if you pass
+ # --(enable|disable)-pyecasound. *sigh*
+ #myconf="$myconf --enable-pyecasound"
+
+ myconf="$myconf --with-python-includes=$python_includes"
+ myconf="$myconf --with-python-modules=$python_modules"
+ else
+ myconf="$myconf --disable-pyecasound"
+ fi
+
+ einfo "configuring with ${myconf}"
+ econf ${myconf} || die "configure failed"
+ make || die "build failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ if use python; then
+ cd pyecasound || die
+ python -c "import compileall; compileall.compile_dir('.')" || die
+ python -O -c "import compileall; compileall.compile_dir('.')" || die
+ python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
+ install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
+ cd ..
+ fi
+
+ dodoc INSTALL FAQ BUGS COPYING NEWS README TODO
+ dohtml `find Documentation -name "*.html"`
+ dodoc Documentation/edi-list.txt
+}
diff --git a/media-sound/ecasound/files/digest-ecasound-2.2.0_rc1 b/media-sound/ecasound/files/digest-ecasound-2.2.0_rc1
new file mode 100644
index 000000000000..434c1024610a
--- /dev/null
+++ b/media-sound/ecasound/files/digest-ecasound-2.2.0_rc1
@@ -0,0 +1 @@
+MD5 5b830775c30e4cb58f0bda1365c69146 ecasound-2.2.0-rc1.tar.gz 890897