summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-02 18:15:02 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-02 18:15:02 +0000
commita68411ebbefe161db8b41867fb08f274d06b9dae (patch)
tree9243f805ce8785a78ec7a7312a1a003ddde92a4d /net-misc/dhcpcd
parentold (diff)
downloadhistorical-a68411ebbefe161db8b41867fb08f274d06b9dae.tar.gz
historical-a68411ebbefe161db8b41867fb08f274d06b9dae.tar.bz2
historical-a68411ebbefe161db8b41867fb08f274d06b9dae.zip
USE=static support #29207
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog9
-rw-r--r--net-misc/dhcpcd/dhcpcd-1.3.22_p4-r1.ebuild28
2 files changed, 21 insertions, 16 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 5a81938562fd..8aabd369fe66 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,12 +1,15 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.21 2003/09/17 09:12:18 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.22 2003/10/02 18:15:02 vapier Exp $
+
+*dhcpcd-1.3.22_p4-r1 (06 Sep 2003)
+
+ 02 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ USE=static support #29207.
17 Sep 2003; Tavis Ormandy <taviso@gentoo.org> dhcpcd-1.3.22_p4-r1.ebuild:
stable on alpha
-*dhcpcd-1.3.22_p4-r1 (06 Sep 2003)
-
06 Sep 2003; Daniel Robbins <drobbins@gentoo.org> dhcpcd-1.3.22_p4-r1.ebuild:
added bug 23428 patch from Alwyn Schoeman <alwyn@smart.com.ph>, which is a
great little patch. Also made dhcpcd FHS compliant using an LFS patch, which
diff --git a/net-misc/dhcpcd/dhcpcd-1.3.22_p4-r1.ebuild b/net-misc/dhcpcd/dhcpcd-1.3.22_p4-r1.ebuild
index bd15bf3211e2..3ae32c35e88e 100644
--- a/net-misc/dhcpcd/dhcpcd-1.3.22_p4-r1.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-1.3.22_p4-r1.ebuild
@@ -1,19 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-1.3.22_p4-r1.ebuild,v 1.5 2003/09/17 23:04:23 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-1.3.22_p4-r1.ebuild,v 1.6 2003/10/02 18:15:02 vapier Exp $
-inherit gnuconfig
+inherit gnuconfig flag-o-matic
-S=${WORKDIR}/${P/_p/-pl}
DESCRIPTION="A dhcp client only"
-SRC_URI="ftp://ftp.phystech.com/pub/${P/_p/-pl}.tar.gz http://dev.gentoo.org/~drobbins/${P}.diff.bz2 http://dev.gentoo.org/~drobbins/${P}-keepCacheAndResolv.diff.bz2"
HOMEPAGE="http://www.phystech.com/download/"
-DEPEND=""
+SRC_URI="ftp://ftp.phystech.com/pub/${P/_p/-pl}.tar.gz
+ http://dev.gentoo.org/~drobbins/${P}.diff.bz2
+ http://dev.gentoo.org/~drobbins/${P}-keepCacheAndResolv.diff.bz2"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha hppa arm mips amd64 ia64"
-LICENSE="GPL-2"
-IUSE="build"
+IUSE="build static"
+
+DEPEND=""
+S=${WORKDIR}/${P/_p/-pl}
src_unpack() {
unpack ${A} || die "unpack failed"
@@ -27,19 +31,17 @@ src_unpack() {
#discovered that LFS had an updated one. We're using a patch that is
#identical to theirs. It makes dhcpcd FHS-compliant. (drobbins, 06
#Sep 2003)
- cat ${DISTDIR}/${P}.diff.bz2 | bzip2 -d | patch -p1 || die
+ epatch ${DISTDIR}/${P}.diff.bz2
#This next patch from Alwyn Schoeman <alwyn@smart.com.ph> is great;
#it adds a -z (shutdown, keep cache) and various other little tweaks.
#See http://bugs.gentoo.org/show_bug.cgi?id=23428 for more info.
- cat ${DISTDIR}/${P}-keepCacheAndResolv.diff.bz2 | bzip2 -d | patch -p1 || die
+ epatch ${DISTDIR}/${P}-keepCacheAndResolv.diff.bz2
#remove hard-coded arch stuff (drobbins, 06 Sep 2003)
- local x
- x=configure
- cp ${x} ${x}.orig
- sed -e "s/ -march=i.86//g" ${x}.orig > ${x} || die
+ sed -i "s/ -march=i.86//g" configure
}
src_compile() {
+ use static && append-flags -static
./configure --prefix="" --sysconfdir=/var/lib --mandir=/usr/share/man || die
emake || die
}