summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2005-12-09 18:45:17 +0000
committerGustavo Felisberto <humpback@gentoo.org>2005-12-09 18:45:17 +0000
commit39a9e27ff708f4e727cbf0b176800e8d1ce0a35c (patch)
treebfe390206de66ed6755c9f76cf216b5e0b9be451 /net-misc/sobby/sobby-0.3.0.ebuild
parentIn replace-sparc64-cflags, we need local 'SPARC64_CPUS="ultrasparc3 ultraspar... (diff)
downloadhistorical-39a9e27ff708f4e727cbf0b176800e8d1ce0a35c.tar.gz
historical-39a9e27ff708f4e727cbf0b176800e8d1ce0a35c.tar.bz2
historical-39a9e27ff708f4e727cbf0b176800e8d1ce0a35c.zip
bump
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'net-misc/sobby/sobby-0.3.0.ebuild')
-rw-r--r--net-misc/sobby/sobby-0.3.0.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-misc/sobby/sobby-0.3.0.ebuild b/net-misc/sobby/sobby-0.3.0.ebuild
new file mode 100644
index 000000000000..017a476e601e
--- /dev/null
+++ b/net-misc/sobby/sobby-0.3.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sobby/sobby-0.3.0.ebuild,v 1.1 2005/12/09 18:45:17 humpback Exp $
+
+inherit eutils
+
+#MY_P=${P/_rc/rc}
+#S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Standalone Obby server"
+HOMEPAGE="http://darcs.0x539.de/gobby"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+
+DEPEND=">=dev-cpp/glibmm-2.6
+ >=dev-libs/libsigc++-2.0
+ >=dev-libs/gmp-4.1.4
+ >=net-libs/obby-0.3.0"
+
+RDEPEND=""
+
+src_compile() {
+ econf || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ insinto /etc/conf.d/
+ newins ${FILESDIR}/sobby-conf-0.2.0 sobby
+
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/sobby-init-0.2.0 sobby
+}
+
+pkg_postinst() {
+ if built_with_use net-libs/obby howl
+ then
+ einfo "Zeroconf support has been enabled for sobby"
+ else
+ einfo "net-libs/obby was not build with zeroconf support,"
+ einfo "thus zeroconf is not enabled for ${PN}."
+ einfo ""
+ einfo "To get zeroconf support, rebuild net-libs/obby"
+ einfo "with \"howl\" in your USE flags."
+ einfo "Try USE=\"howl\" emerge net-libs/obby net-misc/sobby,"
+ einfo "or add \"howl\" to your USE string in /etc/make.conf and"
+ einfo "emerge net-libs/obby"
+ fi
+
+ echo
+ einfo "To start sobby, you can use the init script:"
+ einfo " /etc/init.d/sobby start"
+ einfo ""
+ einfo "Please check the configuration in /etc/conf.d/sobby"
+ einfo "before you start sobby"
+}
+