summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2008-01-06 22:30:55 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2008-01-06 22:30:55 +0000
commit4d15caf8e79206ee62c3c64686d61e584efe01a7 (patch)
treeee97a2657d6ed34541c77eeda340a8854f73cfd3 /net-p2p/rtorrent/rtorrent-0.7.9.ebuild
parentAdd libXt dependency wrt bug #204674 (diff)
downloadhistorical-4d15caf8e79206ee62c3c64686d61e584efe01a7.tar.gz
historical-4d15caf8e79206ee62c3c64686d61e584efe01a7.tar.bz2
historical-4d15caf8e79206ee62c3c64686d61e584efe01a7.zip
Add xmlrpc use flag, please test and report.
Bug #182816 Package-Manager: portage-2.1.4_rc10
Diffstat (limited to 'net-p2p/rtorrent/rtorrent-0.7.9.ebuild')
-rw-r--r--net-p2p/rtorrent/rtorrent-0.7.9.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-p2p/rtorrent/rtorrent-0.7.9.ebuild b/net-p2p/rtorrent/rtorrent-0.7.9.ebuild
index dc7120edd4e4..b1d566b16627 100644
--- a/net-p2p/rtorrent/rtorrent-0.7.9.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.7.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.7.9.ebuild,v 1.2 2007/11/13 15:24:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.7.9.ebuild,v 1.3 2008/01/06 22:30:55 drizzt Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -11,12 +11,13 @@ SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug"
+IUSE="debug xmlrpc"
RDEPEND=">=net-libs/libtorrent-0.11.${PV##*.}
>=dev-libs/libsigc++-2.0
>=net-misc/curl-7.15
- sys-libs/ncurses"
+ sys-libs/ncurses
+ xmlrpc? ( dev-libs/xmlrpc-c )"
DEPEND="${RDEPEND}"
src_compile() {
@@ -29,10 +30,9 @@ src_compile() {
econf \
$(use_enable debug) \
- --disable-xmlrpc-c \
+ $(use_with xmlrpc xmlrpc-c) \
--disable-dependency-tracking \
|| die "econf failed"
- # --disable-xmlrpc-c: I want to keep it disabled while >=dev-libs/xmlrpc-c-1.07 is masked
emake || die "emake failed"
}