summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-09-03 14:28:16 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-09-03 14:28:16 +0000
commita007a74d3ba823e83e6806e7384453fd5d6c8b20 (patch)
tree3186103376e56e07d61ceacbc3bede691b89912c /net-wireless
parentstable on x86. (diff)
downloadhistorical-a007a74d3ba823e83e6806e7384453fd5d6c8b20.tar.gz
historical-a007a74d3ba823e83e6806e7384453fd5d6c8b20.tar.bz2
historical-a007a74d3ba823e83e6806e7384453fd5d6c8b20.zip
Version bump.
Package-Manager: portage-2.1.3.7
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/bluez-libs/ChangeLog8
-rw-r--r--net-wireless/bluez-libs/bluez-libs-3.18.ebuild44
-rw-r--r--net-wireless/bluez-libs/files/digest-bluez-libs-3.183
-rw-r--r--net-wireless/bluez-utils/ChangeLog8
-rw-r--r--net-wireless/bluez-utils/bluez-utils-3.18.ebuild151
-rw-r--r--net-wireless/bluez-utils/files/3.18-a2dp.patch32
-rw-r--r--net-wireless/bluez-utils/files/digest-bluez-utils-3.183
7 files changed, 247 insertions, 2 deletions
diff --git a/net-wireless/bluez-libs/ChangeLog b/net-wireless/bluez-libs/ChangeLog
index 26e3b4b6e8cf..409dcc998161 100644
--- a/net-wireless/bluez-libs/ChangeLog
+++ b/net-wireless/bluez-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/bluez-libs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-libs/ChangeLog,v 1.91 2007/08/29 11:52:51 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-libs/ChangeLog,v 1.92 2007/09/03 14:27:13 betelgeuse Exp $
+
+*bluez-libs-3.18 (03 Sep 2007)
+
+ 03 Sep 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +bluez-libs-3.18.ebuild:
+ Version bump.
29 Aug 2007; Petteri Räty <betelgeuse@gentoo.org>
-bluez-libs-3.10.ebuild, -bluez-libs-3.11.ebuild:
diff --git a/net-wireless/bluez-libs/bluez-libs-3.18.ebuild b/net-wireless/bluez-libs/bluez-libs-3.18.ebuild
new file mode 100644
index 000000000000..b3ddc5ecb301
--- /dev/null
+++ b/net-wireless/bluez-libs/bluez-libs-3.18.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-libs/bluez-libs-3.18.ebuild,v 1.1 2007/09/03 14:27:13 betelgeuse Exp $
+
+inherit libtool
+
+DESCRIPTION="Bluetooth Userspace Libraries"
+HOMEPAGE="http://bluez.sourceforge.net/"
+SRC_URI="http://bluez.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+
+IUSE="debug"
+DEPEND="!net-wireless/bluez-sdp"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ elibtoolize
+ econf $(use_enable debug) || die "econf failed"
+ if use debug ; then
+ echo "#define SDP_DEBUG 1" >> config.h
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README || die
+
+ # http://article.gmane.org/gmane.linux.bluez.announce/57
+ # Although library major number changed, API is compatible.
+ # Does not work with upgrades because ldconfig changes the symlink
+ # to point back to the old version.
+ #dosym libbluetooth.so.2 /usr/$(get_libdir)/libbluetooth.so.1
+}
+
+pkg_postinst() {
+ elog "If you are upgrading from =net-wireless/bluez-util-2*,"
+ elog "the ABI version of libbluetooth has changed."
+ elog "Please run:"
+ elog " revdep-rebuild --library libbluetooth.so.1"
+}
diff --git a/net-wireless/bluez-libs/files/digest-bluez-libs-3.18 b/net-wireless/bluez-libs/files/digest-bluez-libs-3.18
new file mode 100644
index 000000000000..b93f176e6ae7
--- /dev/null
+++ b/net-wireless/bluez-libs/files/digest-bluez-libs-3.18
@@ -0,0 +1,3 @@
+MD5 9e091f2ce00b906c4c456fff24e69e55 bluez-libs-3.18.tar.gz 309041
+RMD160 ea9284d7be3e940fdf66fb16caa763900195c745 bluez-libs-3.18.tar.gz 309041
+SHA256 fe6de9ccfab9e9fbdbe1a2cbe4a9ea771d1a2efc7f2122a2350214394587ff39 bluez-libs-3.18.tar.gz 309041
diff --git a/net-wireless/bluez-utils/ChangeLog b/net-wireless/bluez-utils/ChangeLog
index 602d0abf0013..4bb8fbda480e 100644
--- a/net-wireless/bluez-utils/ChangeLog
+++ b/net-wireless/bluez-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/bluez-utils
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/ChangeLog,v 1.105 2007/08/29 11:52:43 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/ChangeLog,v 1.106 2007/09/03 14:28:16 betelgeuse Exp $
+
+*bluez-utils-3.18 (03 Sep 2007)
+
+ 03 Sep 2007; Petteri Räty <betelgeuse@gentoo.org> +files/3.18-a2dp.patch,
+ +bluez-utils-3.18.ebuild:
+ Version bump.
29 Aug 2007; Petteri Räty <betelgeuse@gentoo.org>
-bluez-utils-3.10-r2.ebuild, -bluez-utils-3.10.1-r1.ebuild,
diff --git a/net-wireless/bluez-utils/bluez-utils-3.18.ebuild b/net-wireless/bluez-utils/bluez-utils-3.18.ebuild
new file mode 100644
index 000000000000..4fb8bb800e23
--- /dev/null
+++ b/net-wireless/bluez-utils/bluez-utils-3.18.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/bluez-utils-3.18.ebuild,v 1.1 2007/09/03 14:28:16 betelgeuse Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Bluetooth Tools and System Daemons for Linux"
+HOMEPAGE="http://bluez.sourceforge.net/"
+SRC_URI="http://bluez.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sh ~sparc ~x86"
+
+IUSE="alsa cups debug examples hal old-daemons test-programs usb"
+
+DEPEND="
+ >=net-wireless/bluez-libs-${PV}
+ alsa? ( media-libs/alsa-lib )
+ hal? ( sys-apps/hal )
+ usb? ( dev-libs/libusb )
+ cups? ( net-print/cups )
+ sys-fs/udev
+ dev-libs/glib
+ sys-apps/dbus"
+
+src_unpack() {
+ unpack ${A}
+ # bundled glib
+ cd "${S}"
+ epatch "${FILESDIR}/3.18-a2dp.patch"
+
+ rm -r eglib/{*.c,*.h} || die
+ if use cups; then
+ epatch "${FILESDIR}/3.11/cups-location.patch"
+ eautoreconf
+ fi
+}
+
+src_compile() {
+ # the order is the same as ./configure --help
+
+ # we don't need the other daemons either with the new
+ # service architechture
+ # hcid has in integrated sdpd now that we use
+
+ # These are currently under work and don't work properly:
+ # --enable-sync
+ # --enable-obex
+
+ econf \
+ $(use_enable debug) \
+ --enable-inotify \
+ $(use_enable hal) \
+ $(use_enable usb) \
+ $(use_enable alsa) \
+ --enable-glib \
+ --disable-obex \
+ --enable-network \
+ --enable-serial \
+ --enable-input \
+ --enable-audio \
+ --disable-sync \
+ $(use_enable examples echo) \
+ --enable-hcid \
+ $(use_enable test-programs test) \
+ $(use_enable old-daemons sdpd) \
+ $(use_enable old-daemons hidd) \
+ $(use_enable old-daemons pand) \
+ $(use_enable cups) \
+ --enable-configfiles \
+ --disable-initscripts \
+ --disable-pcmciarules \
+ --enable-bccmd \
+ --enable-avctrl \
+ --enable-hid2hci \
+ --enable-dfutool \
+ --localstatedir=/var \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog README || die
+
+ # a very simple example daemon
+ dobin daemon/passkey-agent || die
+
+ newinitd "${FILESDIR}/3.11/bluetooth-init.d" bluetooth || die
+ newconfd "${FILESDIR}/3.11/bluetooth-conf.d" bluetooth || die
+
+ if use old-daemons; then
+ sed -re 's/^(Autostart=)true/\1false/' \
+ -i "${D}/etc/bluetooth/input.service" || die
+ newconfd "${FILESDIR}/3.11/conf.d-hidd" hidd || die
+ newinitd "${FILESDIR}/3.11/init.d-hidd" hidd || die
+ fi
+
+ # bug #84431
+ insinto /etc/udev/rules.d/
+ newins "${FILESDIR}/${PN}-3.10.1-udev.rules" 70-bluetooth.rules || die
+ newins "${S}/scripts/bluetooth.rules" 70-bluetooth-pcmcia.rules || die
+
+ exeinto /lib/udev/
+ newexe "${FILESDIR}/${PN}-3.10.1-udev.script" bluetooth.sh || die
+ doexe "${S}/scripts/bluetooth_serial" || die
+}
+
+pkg_postinst() {
+ udevcontrol reload_rules && udevtrigger
+
+ elog
+ elog "To use dial up networking you must install net-dialup/ppp."
+ elog ""
+ elog "Since 3.0 bluez has changed the passkey handling to use a dbus based"
+ elog "API so please remember to update your /etc/bluetooth/hcid.conf."
+ elog "For a password agent, there is for example net-wireless/bluez-gnome"
+ elog "for gnome and net-wireless/kdebluetooth for kde."
+ elog ""
+ elog "Since 3.10.1 we don't install the old style daemons any more but rely"
+ elog "on the new service architechture:"
+ elog " http://wiki.bluez.org/wiki/Services"
+ elog ""
+ elog "3.15 adds support for the audio service. See"
+ elog "http://wiki.bluez.org/wiki/HOWTO/AudioDevices for configuration help."
+ elog ""
+ elog "Edit /etc/bluetooth/*.service to enable the services."
+ elog "Use the old-daemons use flag to get the old daemons like hidd"
+ elog "installed. Please note that the init script doesn't stop the old"
+ elog "daemons after you update it so it's recommended to run:"
+ elog " /etc/init.d/bluetooth stop"
+ elog "before updating your configuration files or you can manually kill"
+ elog "the extra daemons you previously enabled in /etc/conf.d/bluetooth."
+ elog ""
+ elog "If you want to use rfcomm as a normal user, you need to add the user"
+ elog "to the uucp group."
+ elog ""
+ if use old-daemons; then
+ elog "The hidd init script was installed because you have the old-daemons"
+ elog "use flag on. It is not started by default via udev so please add it"
+ elog "to the required runleves using rc-update <runlevel> add hidd. If"
+ elog "you need init scripts for the other daemons, please file requests"
+ elog "to https://bugs.gentoo.org."
+ else
+ elog "The bluetooth service should be started automatically by udev"
+ elog "when the required hardware is inserted next time."
+ fi
+}
diff --git a/net-wireless/bluez-utils/files/3.18-a2dp.patch b/net-wireless/bluez-utils/files/3.18-a2dp.patch
new file mode 100644
index 000000000000..166877129d3c
--- /dev/null
+++ b/net-wireless/bluez-utils/files/3.18-a2dp.patch
@@ -0,0 +1,32 @@
+Index: unix.c
+===================================================================
+RCS file: /cvsroot/bluez/utils/audio/unix.c,v
+retrieving revision 1.44
+diff -u -3 -p -u -r1.44 unix.c
+--- audio/unix.c 31 Aug 2007 11:51:43 -0000 1.44
++++ audio/unix.c 3 Sep 2007 13:21:12 -0000
+@@ -347,9 +347,23 @@ static void a2dp_setup_complete(struct a
+ cfg->fd_opt = CFG_FD_OPT_WRITE;
+
+ sbc_cap = (void *) codec_cap;
+- cfg->mode = sbc_cap->channel_mode;
+ cfg->sample_size = 2;
+
++ switch (sbc_cap->channel_mode) {
++ case A2DP_CHANNEL_MODE_MONO:
++ cfg->mode = CFG_MODE_MONO;
++ break;
++ case A2DP_CHANNEL_MODE_DUAL_CHANNEL:
++ cfg->mode = CFG_MODE_DUAL_CHANNEL;
++ break;
++ case A2DP_CHANNEL_MODE_STEREO:
++ cfg->mode = CFG_MODE_STEREO;
++ break;
++ case A2DP_CHANNEL_MODE_JOINT_STEREO:
++ cfg->mode = CFG_MODE_JOINT_STEREO;
++ break;
++ }
++
+ switch (sbc_cap->frequency) {
+ case A2DP_SAMPLING_FREQ_16000:
+ cfg->rate = 16000;
diff --git a/net-wireless/bluez-utils/files/digest-bluez-utils-3.18 b/net-wireless/bluez-utils/files/digest-bluez-utils-3.18
new file mode 100644
index 000000000000..99a541907c55
--- /dev/null
+++ b/net-wireless/bluez-utils/files/digest-bluez-utils-3.18
@@ -0,0 +1,3 @@
+MD5 2b6b4d519b8f75ef3990122934e660ba bluez-utils-3.18.tar.gz 887444
+RMD160 39da73962cfaa30dc1e3c0c5d636a2691b5659fb bluez-utils-3.18.tar.gz 887444
+SHA256 f8f242c6835ae826bf1f4eaee6c50d47d6208715e45450ba42c1769094c3f296 bluez-utils-3.18.tar.gz 887444