summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nall <nall@gentoo.org>2003-03-18 03:25:23 +0000
committerJon Nall <nall@gentoo.org>2003-03-18 03:25:23 +0000
commitfe798591160ab3f8a448f6e98475b02a376bf8f8 (patch)
treeca9d1b805540bf281b59a510280499d53ec1c3b2 /net-www/gplflash
parentAdded ~sparc to keywords. (diff)
downloadhistorical-fe798591160ab3f8a448f6e98475b02a376bf8f8.tar.gz
historical-fe798591160ab3f8a448f6e98475b02a376bf8f8.tar.bz2
historical-fe798591160ab3f8a448f6e98475b02a376bf8f8.zip
Fixed issues with static/shared libs; works on PPC now
Diffstat (limited to 'net-www/gplflash')
-rw-r--r--net-www/gplflash/ChangeLog8
-rw-r--r--net-www/gplflash/files/digest-gplflash-0.4.10-r21
-rw-r--r--net-www/gplflash/files/gplflash-0.4.10-ppc.diff56
-rw-r--r--net-www/gplflash/gplflash-0.4.10-r2.ebuild43
4 files changed, 107 insertions, 1 deletions
diff --git a/net-www/gplflash/ChangeLog b/net-www/gplflash/ChangeLog
index 5c6df69543ab..0fccdc8946dd 100644
--- a/net-www/gplflash/ChangeLog
+++ b/net-www/gplflash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/gplflash
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gplflash/ChangeLog,v 1.7 2003/02/12 08:47:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gplflash/ChangeLog,v 1.8 2003/03/18 03:25:23 nall Exp $
+
+*gplflash-0.4.10-r2 (17 Mar 2003)
+
+ 17 Mar 2003; root <root@gentoo.org> gplflash-0.4.10-r2.ebuild,
+ files/gplflash-0.4.10-ppc.diff:
+ Fixed issues with static/shared libs; works on PPC now
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-www/gplflash/files/digest-gplflash-0.4.10-r2 b/net-www/gplflash/files/digest-gplflash-0.4.10-r2
new file mode 100644
index 000000000000..559fd82f09cb
--- /dev/null
+++ b/net-www/gplflash/files/digest-gplflash-0.4.10-r2
@@ -0,0 +1 @@
+MD5 1473f085c599d8076fa866cd91e11598 flash-0.4.10.tgz 358995
diff --git a/net-www/gplflash/files/gplflash-0.4.10-ppc.diff b/net-www/gplflash/files/gplflash-0.4.10-ppc.diff
new file mode 100644
index 000000000000..18107471956b
--- /dev/null
+++ b/net-www/gplflash/files/gplflash-0.4.10-ppc.diff
@@ -0,0 +1,56 @@
+--- Jpeg/Makefile.orig 2003-03-17 21:02:31.000000000 -0600
++++ Jpeg/Makefile 2003-03-17 21:02:37.000000000 -0600
+@@ -20,7 +20,7 @@
+ mandir = $(prefix)/man/man$(manext)
+
+ # You may need to adjust these cc options:
+-CFLAGS= -O2 -I$(srcdir)
++CFLAGS= -O2 -I$(srcdir) -shared -fPIC
+ # Generally, we recommend defining any configuration symbols in jconfig.h,
+ # NOT via -D switches here.
+ # However, any special defines for ansi2knr.c may be included here:
+--- Lib/Makefile.orig 2003-03-17 21:03:38.000000000 -0600
++++ Lib/Makefile 2003-03-17 21:03:17.000000000 -0600
+@@ -1,6 +1,6 @@
+-CPPFLAGS=-I../Jpeg -I../Zlib
++CPPFLAGS=-I../Jpeg -I../Zlib
+ # Comment out the following line if you use egcs :
+-CXXFLAGS=-O3 -Wall -fno-rtti -fno-exceptions
++CXXFLAGS=-O3 -Wall -fno-rtti -fno-exceptions -shared -fPIC
+
+ INCLUDES= adpcm.h cxform.h graphic.h script.h sqrt.h\
+ bitmap.h displaylist.h matrix.h shape.h swf.h\
+--- Zlib/Makefile.orig 2003-03-17 21:03:50.000000000 -0600
++++ Zlib/Makefile 2003-03-17 21:04:07.000000000 -0600
+@@ -2,7 +2,7 @@
+ # Copyright (C) 1995-1998 Jean-loup Gailly.
+ # For conditions of distribution and use, see copyright notice in zlib.h
+
+-CFLAGS=-O3 -DHAVE_UNISTD_H -DUSE_MMAP
++CFLAGS=-O3 -DHAVE_UNISTD_H -DUSE_MMAP -shared -fPIC
+
+ CPP=$(CC) -E
+
+--- Plugin/Makefile.orig 2003-03-17 21:04:15.000000000 -0600
++++ Plugin/Makefile 2003-03-17 21:04:37.000000000 -0600
+@@ -33,9 +33,9 @@
+ # FreeBSD
+ #SHARED=-Bshareable
+ # Linux
+-SHARED=-shared
++SHARED=-shared -fPIC
+
+-CFLAGS= $(OPTIMIZER) $(PLUGIN_DEFINES) -I$(FLASH) -I/usr/X11R6/include
++CFLAGS= $(SHARED) $(OPTIMIZER) $(PLUGIN_DEFINES) -I$(FLASH) -I/usr/X11R6/include
+ LDFLAGS= $(FLASH)/libflash.a $(LIBCXX) ../Jpeg/libjpeg.a ../Zlib/libz.a
+
+ SRC= plugin.c npunix.c
+@@ -46,7 +46,7 @@
+ default all: $(SHAREDTARGET)
+
+ $(SHAREDTARGET): $(OBJ) $(FLASH)/libflash.a
+- $(LD) $(SHARED) -o $(SHAREDTARGET) $(OBJ) $(LDFLAGS)
++ $(CC) $(SHARED) -o $(SHAREDTARGET) $(OBJ) $(LDFLAGS)
+
+ plugin.o: $(FLASH)/flash.h
+
diff --git a/net-www/gplflash/gplflash-0.4.10-r2.ebuild b/net-www/gplflash/gplflash-0.4.10-r2.ebuild
new file mode 100644
index 000000000000..5a7b85f3be2f
--- /dev/null
+++ b/net-www/gplflash/gplflash-0.4.10-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Id: gplflash-0.4.10-r2.ebuild,v 1.1 2003/03/18 03:25:23 nall Exp $
+
+S=${WORKDIR}/flash-0.4.10
+DESCRIPTION="GPL Shockwave Flash Player/Plugin"
+SRC_URI="http://www.swift-tools.com/Flash/flash-0.4.10.tgz"
+HOMEPAGE="http://www.swift-tools.com/Flash"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc"
+
+DEPEND="media-libs/libflash"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack flash-0.4.10.tgz
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc3-gentoo.diff || die
+
+ if [ "${ARCH}" = "ppc" ]; then
+ epatch ${FILESDIR}/${P}-ppc.diff || die
+ fi
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ cd ${S}/Plugin
+ insinto /opt/netscape/plugins
+ doins npflash.so
+ cd ${S}
+ dodoc README COPYING
+
+ if [ "`use mozilla`" ] ; then
+ dodir /usr/lib/mozilla/plugins
+ dosym /opt/netscape/plugins/npflash.so \
+ /usr/lib/mozilla/plugins/npflash.so
+ fi
+}