summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-04-17 18:04:28 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-04-17 18:04:28 +0000
commit61f98e7c75a2a9c6a906168304246718cd19c586 (patch)
tree6190fb5bb9693cf438ac454b897669ba857b4d5f /sci-physics/geant
parentNew package (diff)
downloadhistorical-61f98e7c75a2a9c6a906168304246718cd19c586.tar.gz
historical-61f98e7c75a2a9c6a906168304246718cd19c586.tar.bz2
historical-61f98e7c75a2a9c6a906168304246718cd19c586.zip
Fixed some latex font generation and made ebuild consistent with other cernlib ebuilds
Package-Manager: portage-2.2_rc28/cvs/Linux x86_64
Diffstat (limited to 'sci-physics/geant')
-rw-r--r--sci-physics/geant/ChangeLog6
-rw-r--r--sci-physics/geant/geant-3.21.14-r2.ebuild20
2 files changed, 14 insertions, 12 deletions
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
index 68aea2039c1c..340851c64226 100644
--- a/sci-physics/geant/ChangeLog
+++ b/sci-physics/geant/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/geant
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.26 2009/03/23 18:45:43 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.27 2009/04/17 18:04:28 bicatali Exp $
+
+ 17 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> geant-3.21.14-r2:
+ Fixed some latex font generation and made ebuild consistent with other
+ cernlib ebuilds
23 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org>
geant-4.9.2-r2.ebuild:
diff --git a/sci-physics/geant/geant-3.21.14-r2.ebuild b/sci-physics/geant/geant-3.21.14-r2.ebuild
index d54eec14d439..f3e52833ac9e 100644
--- a/sci-physics/geant/geant-3.21.14-r2.ebuild
+++ b/sci-physics/geant/geant-3.21.14-r2.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-3.21.14-r2.ebuild,v 1.9 2009/03/22 21:41:50 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-3.21.14-r2.ebuild,v 1.10 2009/04/17 18:04:28 bicatali Exp $
+
+EAPI=2
+inherit eutils
DEB_PN=geant321
DEB_PV=${PV}.dfsg
DEB_PR=8
DEB_P=${DEB_PN}_${DEB_PV}
-inherit eutils fortran
-
DESCRIPTION="CERN's detector description and simulation Tool"
HOMEPAGE="http://wwwasd.web.cern.ch/wwwasd/geant/index.html"
@@ -32,15 +33,12 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
-FORTRAN="gfortran g77 ifc"
-
-src_unpack() {
- unpack ${A}
- epatch "${DEB_P}-${DEB_PR}".diff
- rm -f ${DEB_P}-${DEB_PR}.diff
+src_prepare() {
+ cd "${WORKDIR}"
+ epatch "${WORKDIR}/${DEB_P}-${DEB_PR}.diff"
cd "${S}"
cp debian/add-ons/Makefile .
- export DEB_BUILD_OPTIONS="${FORTRANC} nostrip nocheck"
+ export DEB_BUILD_OPTIONS="$(tc-getFC) nostrip nocheck"
sed -i \
-e 's:/usr/local:/usr:g' \
Makefile || die "sed'ing the Makefile failed"
@@ -54,7 +52,7 @@ src_unpack() {
src_compile() {
# create local LaTeX cache directory
- mkdir -p .texmf-var
+ VARTEXFONTS="${T}"/fonts
emake -j1 cernlib-indep cernlib-arch || die "emake failed"
}