summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-21 17:41:20 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-21 17:41:20 +0000
commit226ccc53223e2c7233f0a14515ddfd7fc3b0b46b (patch)
treee50347af28b6af88ca84e6cdd47633a583234cb8 /sys-apps/lsof
parentupdate KEYWORDS (diff)
downloadhistorical-226ccc53223e2c7233f0a14515ddfd7fc3b0b46b.tar.gz
historical-226ccc53223e2c7233f0a14515ddfd7fc3b0b46b.tar.bz2
historical-226ccc53223e2c7233f0a14515ddfd7fc3b0b46b.zip
static support #29270
Diffstat (limited to 'sys-apps/lsof')
-rw-r--r--sys-apps/lsof/ChangeLog9
-rw-r--r--sys-apps/lsof/lsof-4.68.ebuild13
2 files changed, 15 insertions, 7 deletions
diff --git a/sys-apps/lsof/ChangeLog b/sys-apps/lsof/ChangeLog
index 60748d4110d2..884b496dc7cb 100644
--- a/sys-apps/lsof/ChangeLog
+++ b/sys-apps/lsof/ChangeLog
@@ -1,12 +1,15 @@
# ChangeLog for sys-apps/lsof
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/ChangeLog,v 1.17 2003/08/15 13:23:06 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/ChangeLog,v 1.18 2003/09/21 17:41:20 vapier Exp $
+
+*lsof-4.68 (30 Jun 2003)
+
+ 21 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add static support #29270.
15 Aug 2003; Tavis Ormandy <taviso@gentoo.org> lsof-4.68.ebuild:
#26576 lsof 4.68 compile with -fstack-protector fails on Alpha
-*lsof-4.68 (30 Jun 2003)
-
03 Aug 2003; Joshua Kinard <kumba@gentoo.org> lsof-4.68.ebuild:
Changed ~sparc to sparc and added ~mips to KEYWORDS
diff --git a/sys-apps/lsof/lsof-4.68.ebuild b/sys-apps/lsof/lsof-4.68.ebuild
index 38630dcfe1ee..a83d2296f0bc 100644
--- a/sys-apps/lsof/lsof-4.68.ebuild
+++ b/sys-apps/lsof/lsof-4.68.ebuild
@@ -1,22 +1,22 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/lsof-4.68.ebuild,v 1.7 2003/09/21 17:40:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/lsof-4.68.ebuild,v 1.8 2003/09/21 17:41:20 vapier Exp $
inherit flag-o-matic
-IUSE=""
MY_P=${P/-/_}
S=${WORKDIR}/${MY_P}/${MY_P}_src
DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/README"
SRC_URI="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.gz
ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${MY_P}.tar.gz"
-HOMEPAGE="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/README"
DEPEND="virtual/glibc"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64 ppc sparc alpha hppa arm mips ia64"
+IUSE="static"
#This pkg appears to be highly kernel-dependent.
@@ -32,6 +32,8 @@ src_compile() {
# -taviso (15 Aug 03)
use alpha && filter-flags -fstack-protector
+ use static && LDFLAGS="${LDFLAGS} -static"
+
#interactive script: Enable HASSECURITY, WARNINGSTATE, and HASKERNIDCK
#is there a way to avoid the "echo to a file + file read"?
#Just piping in the results didn't seem to work.
@@ -40,7 +42,10 @@ src_compile() {
#simple Makefile hack to insert CFLAGS
cp Makefile Makefile.orig
- sed -e "s/-DLINUXV/${CFLAGS} -DLINUXV/" Makefile.orig > Makefile
+ sed \
+ -e "s/-DLINUXV/${CFLAGS} -DLINUXV/" \
+ -e "/^CFGL=/ s/\$/ ${LDFLAGS}/" \
+ Makefile.orig > Makefile
make all || die
}