summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-21 02:02:44 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-21 02:02:44 +0000
commite0b30bf6e72b46fce1d9b0183422a04f49552269 (patch)
tree6a8507e22f11cf05ea5e7bda0eb850d4e0ef2e8e /sys-apps/sed
parentAdd support for cell from lu_zero and push out accumulated fixes. (diff)
downloadhistorical-e0b30bf6e72b46fce1d9b0183422a04f49552269.tar.gz
historical-e0b30bf6e72b46fce1d9b0183422a04f49552269.tar.bz2
historical-e0b30bf6e72b46fce1d9b0183422a04f49552269.zip
cut pointless use of USE=build/bootstrap
Package-Manager: portage-2.1.1_pre5-r2
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/sed-4.1.5.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/sys-apps/sed/sed-4.1.5.ebuild b/sys-apps/sed/sed-4.1.5.ebuild
index 693a532e5bf3..63eb6054369a 100644
--- a/sys-apps/sed/sed-4.1.5.ebuild
+++ b/sys-apps/sed/sed-4.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.5.ebuild,v 1.3 2006/05/16 14:57:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.5.ebuild,v 1.4 2006/08/21 02:02:44 vapier Exp $
inherit flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/sed/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls static build bootstrap"
+IUSE="nls static"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
@@ -20,13 +20,11 @@ DEPEND="${RDEPEND}
src_bootstrap_sed() {
# make sure system-sed works #40786
export NO_SYS_SED=""
- if ! use bootstrap && ! use build ; then
- if ! type -p sed ; then
- NO_SYS_SED="!!!"
- ./bootstrap.sh || die "couldnt bootstrap"
- cp sed/sed ${T}/ || die "couldnt copy"
- export PATH="${PATH}:${T}"
- fi
+ if ! type -p sed ; then
+ NO_SYS_SED="!!!"
+ ./bootstrap.sh || die "couldnt bootstrap"
+ cp sed/sed ${T}/ || die "couldnt copy"
+ export PATH="${PATH}:${T}"
fi
}
src_bootstrap_cleanup() {