summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-05-12 20:03:31 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-05-12 20:03:31 +0000
commit083433f36fa589d8580aeeee351b9f2514fecf51 (patch)
tree5adb250b9f794fcb5d2366247990737578da81ca /sys-apps
parentChanging DEPEND to allow for either kudzu-knoppix or kudzu and cleaning up ol... (diff)
downloadhistorical-083433f36fa589d8580aeeee351b9f2514fecf51.tar.gz
historical-083433f36fa589d8580aeeee351b9f2514fecf51.tar.bz2
historical-083433f36fa589d8580aeeee351b9f2514fecf51.zip
Added coreutils-darwin-5.3.0.
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils-darwin/ChangeLog8
-rw-r--r--sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild131
-rw-r--r--sys-apps/coreutils-darwin/files/digest-coreutils-darwin-5.3.01
3 files changed, 139 insertions, 1 deletions
diff --git a/sys-apps/coreutils-darwin/ChangeLog b/sys-apps/coreutils-darwin/ChangeLog
index aa0f188bbc37..2dc4f9cb41ef 100644
--- a/sys-apps/coreutils-darwin/ChangeLog
+++ b/sys-apps/coreutils-darwin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/coreutils-darwin
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/ChangeLog,v 1.1 2005/05/12 06:03:21 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/ChangeLog,v 1.2 2005/05/12 20:03:31 josejx Exp $
+
+*coreutils-darwin-5.3.0 (12 May 2005)
+
+ 12 May 2005; Joseph Jezak <josejx@gentoo.org>
+ +coreutils-darwin-5.3.0.ebuild:
+ Added coreutils-5.3.0.
*coreutils-darwin-5.0 (12 May 2005)
diff --git a/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild b/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild
new file mode 100644
index 000000000000..3d8b3b1aab65
--- /dev/null
+++ b/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild,v 1.1 2005/05/12 20:03:31 josejx Exp $
+
+DESCRIPTION="Standard GNU file utilities, text utilities, and shell utilities missing from Darwin."
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="mirror://gentoo/coreutils-5.3.0.tar.bz2
+ http://meyering.free.fr/coreutils/coreutils-5.3.0.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc-macos"
+IUSE="nls build static"
+PROVIDES="virtual/coreutils"
+
+DEPEND=">=sys-apps/portage-2.0.49
+ sys-devel/automake
+ sys-devel/autoconf
+ sys-apps/help2man
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/coreutils-${PV}
+
+# Existing utils
+
+EXISTINGUSR="basename chgrp cksum comm cut dirname \
+ du env expand false fmt fold head install id join \
+ logname mkfifo nice nohup od paste pr printenv \
+ printf sort split stat sum tail tee touch tr true \
+ tsort tty uname unexpand uniq users wc who whoami yes"
+EXISTINGBIN="cat chmod cp date dd df echo expr ln ls mkdir mv pwd rm rmdir sleep stty sync test"
+EXISTINGUSBIN="chown chroot"
+EXISTINGSBIN="mknod"
+DONTLINK="[ kill hostname"
+
+src_compile() {
+ cd ${S}
+
+ econf \
+ --bindir=/bin \
+ `use_enable nls` || die
+
+ if use static
+ then
+ emake LDFLAGS="${LDFLAGS} -static" || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+
+ # Install the utils
+ cd ${S}
+ make install infodir=${D}usr/share/info mandir=${D}usr/share/man bindir=${D}bin || die
+
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+
+ cd bin
+ rm ${EXISTINGBIN} ${EXISTINGUSR} ${EXISTINGUSBIN} ${EXISTINGSBIN} ${DONTLINK}
+
+ # Move the non-critical pacakges to /usr/bin
+ mv csplit factor md5sum nl ${D}usr/bin
+ mv pathchk pinky sha1sum tac ${D}usr/bin
+
+ # Link binaries
+ cd ${D}/usr/bin
+ for BINS in `ls ${D}/bin` ; do
+ dosym ../../bin/${BINS} /usr/bin/${BINS}
+ done
+
+ for BINS in ${EXISTINGUSR} ; do
+ dosym /usr/bin/${BINS} /bin/${BINS}
+ done
+
+ for BINS in ${EXISTINGBIN} ; do
+ dosym /bin/${BINS} /usr/bin/${BINS}
+ done
+
+ for BINS in ${EXISTINGUSBIN} ; do
+ dosym /usr/sbin/${BINS} /bin/${BINS}
+ dosym /usr/sbin/${BINS} /usr/bin/${BINS}
+ done
+
+ for BINS in ${EXISTINGSBIN} ; do
+ dosym /sbin/${BINS} /bin/${BINS}
+ dosym /sbin/${BINS} /usr/bin/${BINS}
+ done
+
+ # Remove the redundant man pages
+ cd ${D}/usr/share/man/man1
+ rm basename.1 cat.1 chroot.1 cksum.1 comm.1 \
+ cut.1 date.1 dirname.1 echo.1 env.1 expand.1 expr.1 \
+ false.1 fmt.1 fold.1 head.1 id.1 join.1 \
+ logname.1 nice.1 nohup.1 od.1 paste.1 pr.1 printenv.1 \
+ printf.1 pwd.1 readlink.1 sleep.1 sort.1 split.1 stat.1 \
+ stty.1 sum.1 sync.1 tail.1 tee.1 test.1 tr.1 true.1 tsort.1 \
+ tty.1 uname.1 unexpand.1 uniq.1 users.1 wc.1 who.1 whoami.1 \
+ yes.1
+
+ if ! use build
+ then
+ cd ${S}
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postrm() {
+ # Unlink binaries
+ for BINS in ${EXISTINGUSR} ; do
+ rm /bin/${BINS}
+ done
+
+ for BINS in ${EXISTINGBIN} ; do
+ rm /usr/bin/${BINS}
+ done
+
+ for BINS in ${EXISTINGUSBIN} ; do
+ rm /bin/${BINS}
+ rm /usr/bin/${BINS}
+ done
+
+ for BINS in ${EXISTINGSBIN} ; do
+ rm /bin/${BINS}
+ rm /usr/bin/${BINS}
+ done
+}
diff --git a/sys-apps/coreutils-darwin/files/digest-coreutils-darwin-5.3.0 b/sys-apps/coreutils-darwin/files/digest-coreutils-darwin-5.3.0
new file mode 100644
index 000000000000..ed89785aea13
--- /dev/null
+++ b/sys-apps/coreutils-darwin/files/digest-coreutils-darwin-5.3.0
@@ -0,0 +1 @@
+MD5 903890208248639ac723d2c4988e04bd coreutils-5.3.0.tar.bz2 4473010