summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-07-03 17:54:09 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-07-03 17:54:09 +0000
commit255feb00aac57bc92e6978d9088789e2e18e79a2 (patch)
tree652278a9217d1423d6e8e24ba1e9298aacd683c8 /sys-apps
parentVersion bump mercurial to 1.9. (diff)
downloadhistorical-255feb00aac57bc92e6978d9088789e2e18e79a2.tar.gz
historical-255feb00aac57bc92e6978d9088789e2e18e79a2.tar.bz2
historical-255feb00aac57bc92e6978d9088789e2e18e79a2.zip
Version bump.
Package-Manager: portage-2.2.0_alpha43/cvs/Linux x86_64
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog8
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.7.4.ebuild86
2 files changed, 93 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 1c31202f6ac4..7534eac6be50 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.112 2011/04/13 17:51:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.113 2011/07/03 17:54:09 flameeyes Exp $
+
+*pcsc-lite-1.7.4 (03 Jul 2011)
+
+ 03 Jul 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +pcsc-lite-1.7.4.ebuild:
+ Version bump.
*pcsc-lite-1.7.2-r1 (13 Apr 2011)
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.7.4.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.7.4.ebuild
new file mode 100644
index 000000000000..25be6580ece0
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.7.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.7.4.ebuild,v 1.1 2011/07/03 17:54:09 flameeyes Exp $
+
+EAPI="4"
+
+inherit multilib eutils
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://pcsclite.alioth.debian.org/"
+
+STUPID_NUM="3598"
+MY_P="${PN}-${PV/_/-}"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="usb kernel_linux"
+
+RDEPEND="!kernel_linux? ( usb? ( virtual/libusb:1 ) )
+ kernel_linux? ( sys-fs/udev )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ !<app-crypt/ccid-1.4.1-r1"
+
+pkg_setup() {
+ enewgroup openct # make sure it exists
+ enewgroup pcscd
+ enewuser pcscd -1 -1 /var/run/pcscd pcscd,openct
+}
+
+src_configure() {
+ local myconf=
+
+ if use kernel_linux; then
+ myconf="${myconf} --enable-libudev --disable-libusb"
+ else
+ myconf="${myconf} --disable-libudev $(use_enable usb libusb)"
+ fi
+
+ econf \
+ --disable-maintainer-mode \
+ --disable-dependency-tracking \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-usbdropdir="/usr/$(get_libdir)/readers/usb" \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ find "${D}" -name '*.la' -delete
+
+ dodoc AUTHORS DRIVERS HELP README SECURITY ChangeLog
+
+ newinitd "${FILESDIR}/pcscd-init.4" pcscd
+
+ if use kernel_linux; then
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}"/99-pcscd-hotplug.rules
+ fi
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog ""
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog ""
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog ""
+ if use kernel_linux; then
+ elog "HAL support has been dropped by the ebuild; if you want hotplug"
+ elog "support, that's provided already by UDEV rules; you only need to"
+ elog "tell the init system to hotplug it, by setting this variable in"
+ elog "/etc/rc.conf:"
+ elog ""
+ elog " rc_hotplug=\"pcscd\""
+ fi
+}