summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2005-04-24 08:11:20 +0000
committerBrian Harring <ferringb@gentoo.org>2005-04-24 08:11:20 +0000
commit5b804e3c86a7aaa4a6ec1b915b7ef31164314eec (patch)
tree3244ee5d3e122e34a00827803ddf1a21acc6dcf4 /sys-apps
parentremoved restriction (diff)
downloadhistorical-5b804e3c86a7aaa4a6ec1b915b7ef31164314eec.tar.gz
historical-5b804e3c86a7aaa4a6ec1b915b7ef31164314eec.tar.bz2
historical-5b804e3c86a7aaa4a6ec1b915b7ef31164314eec.zip
closing 90135, bad makefile relying on a screwy var just for amd64...
Package-Manager: portage-1.585-cvs
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sandbox/ChangeLog6
-rw-r--r--sys-apps/sandbox/Manifest16
-rw-r--r--sys-apps/sandbox/files/digest-sandbox-1.2.1-r20
-rw-r--r--sys-apps/sandbox/sandbox-1.2.1-r2.ebuild88
4 files changed, 97 insertions, 13 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 19663e92967a..6b1920e2ec8f 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.4 2005/04/24 03:34:21 jstubbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.5 2005/04/24 08:11:20 ferringb Exp $
+
+*sandbox-1.2.1 (24 Apr 2005)
+ 24 Apr 2005; Brian Harring <ferringb@gentoo.org> +sandbox-1.2.1-r2.ebuild:
+ Amd64 fix for 90135.
*sandbox-1.2.1 (24 Apr 2005)
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index 744116a260fa..5a4c334a5edc 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,18 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 4bab34965656f5f0266f2d26cd1b8e6c ChangeLog 671
MD5 968e2965b0b6f620634dae6d28d8b4c4 metadata.xml 455
MD5 fa4e917c828593f1c202fe11f019e2d3 sandbox-1.2.ebuild 1711
+MD5 ff83893e146a467c718131e5f68ff52e sandbox-1.2.1-r2.ebuild 2110
MD5 47438c0ad7e347064cdaf223d6a5f042 sandbox-1.2.1.ebuild 1747
+MD5 c2f3644981790e85c45988e336433fc2 ChangeLog 802
MD5 23e070ffbbc6123cc5082bab1b9de240 sandbox-1.2.1-r1.ebuild 2131
-MD5 06ad9881ad2610487c66565ee5b39389 files/digest-sandbox-1.2 64
MD5 9b60e9e6d1e45533a0e719fdf023ec07 files/digest-sandbox-1.2.1 66
+MD5 06ad9881ad2610487c66565ee5b39389 files/digest-sandbox-1.2 64
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-sandbox-1.2.1-r2 0
MD5 9b60e9e6d1e45533a0e719fdf023ec07 files/digest-sandbox-1.2.1-r1 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCaxPGxvWNPsk/ZP4RAiJtAKCoFLLtW0u8Jx5RWqP/MTZAi9Z03QCeOG+B
-ctNBFxAMldZd/WYInRZYtwQ=
-=SURy
------END PGP SIGNATURE-----
diff --git a/sys-apps/sandbox/files/digest-sandbox-1.2.1-r2 b/sys-apps/sandbox/files/digest-sandbox-1.2.1-r2
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-apps/sandbox/files/digest-sandbox-1.2.1-r2
diff --git a/sys-apps/sandbox/sandbox-1.2.1-r2.ebuild b/sys-apps/sandbox/sandbox-1.2.1-r2.ebuild
new file mode 100644
index 000000000000..3782cfb34eb3
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.2.1-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.1-r2.ebuild,v 1.1 2005/04/24 08:11:20 ferringb Exp $
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+IUSE=""
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~azarah/sandbox/${P}.tar.bz2"
+DEPEND=""
+LICENSE="GPL-2"
+SLOT='0'
+
+#KEYWORDS=" alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+check_multilib() {
+ has_m32
+ if [ "$?" == 0 ]; then
+ einfo "Found valid multilib environment."
+ einfo "Building with multilib support."
+ export MULTILIB="1"
+ else
+ ewarn "No valid multilib environment found!"
+ ewarn "Building without multilib support. If"
+ ewarn "you want to have multilib support,"
+ ewarn "emerge gcc with \"multilib\" in your"
+ ewarn "useflags."
+ fi
+}
+
+src_unpack() {
+ if has_multilib_profile; then
+ for TA in $(get_install_abis); do
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+ epunt_cxx
+ cd ..
+ mv ${S} ${S%/}-${TA} || die "failed mving \$S to $TA"
+ done
+ else
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+ epunt_cxx
+ fi
+}
+
+src_compile() {
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ export CFLAGS="${CFLAGS} -DSB_HAVE_64BIT_ARCH"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ econf || die "econf failed for $ABI"
+ emake || die "emake failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ if useq amd64; then
+ check_multilib
+ export HAVE_64BIT_ARCH="${MULTILIB}"
+ fi
+ cd ${S}
+ econf || die "econf failed"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ einstall || die "einstall failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ cd ${S}
+ einstall || die "einstalled failed"
+ fi
+}