summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-11-01 12:42:29 +0000
committerMichael Imhof <tantive@gentoo.org>2003-11-01 12:42:29 +0000
commitfa723dce9282e05278f536916a2fc930034a37fd (patch)
treef5945f4535a30b4354749fbdd61dbf501a2baea5 /sys-apps
parentVersion bumped. (diff)
downloadhistorical-fa723dce9282e05278f536916a2fc930034a37fd.tar.gz
historical-fa723dce9282e05278f536916a2fc930034a37fd.tar.bz2
historical-fa723dce9282e05278f536916a2fc930034a37fd.zip
Version bumped.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/apcupsd/Manifest4
-rw-r--r--sys-apps/apcupsd/apcupsd-3.10.6.ebuild89
-rw-r--r--sys-apps/apcupsd/files/digest-apcupsd-3.10.62
3 files changed, 93 insertions, 2 deletions
diff --git a/sys-apps/apcupsd/Manifest b/sys-apps/apcupsd/Manifest
index 71367924fa34..1c74edeee38f 100644
--- a/sys-apps/apcupsd/Manifest
+++ b/sys-apps/apcupsd/Manifest
@@ -1,8 +1,8 @@
MD5 37a17ef92e0fa96f32d68b794be5e396 apcupsd-3.10.5-r2.ebuild 1896
MD5 51d33fa0d6b6fec4502f239d89f112b1 apcupsd-3.10.5-r3.ebuild 1993
-MD5 5c40410d67af71417acb626a6d866aec ChangeLog 3296
+MD5 37da4191880751ab19a0bf2e051361ca ChangeLog 3421
MD5 95fbe0b2c22a6ac60e34a6449c2a90d6 apcupsd-3.10.5-r4.ebuild 2180
-MD5 95fbe0b2c22a6ac60e34a6449c2a90d6 apcupsd-3.10.6.ebuild 2180
+MD5 2a2f7e1fc9a26b7a4f770c756cbb4c7a apcupsd-3.10.6.ebuild 2179
MD5 f7092406e32869eb0535d85b4c09be0d files/digest-apcupsd-3.10.5-r4 123
MD5 f66859d42d0af37659622f78b276a8bc files/digest-apcupsd-3.10.6 123
MD5 f7092406e32869eb0535d85b4c09be0d files/digest-apcupsd-3.10.5-r3 123
diff --git a/sys-apps/apcupsd/apcupsd-3.10.6.ebuild b/sys-apps/apcupsd/apcupsd-3.10.6.ebuild
new file mode 100644
index 000000000000..cf411e6002af
--- /dev/null
+++ b/sys-apps/apcupsd/apcupsd-3.10.6.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/apcupsd/apcupsd-3.10.6.ebuild,v 1.1 2003/11/01 12:42:04 tantive Exp $
+
+IUSE="doc snmp usb"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="APC UPS daemon with integrated tcp/ip remote shutdown"
+SRC_URI="mirror://sourceforge/apcupsd/${P}.tar.gz
+ ftp://ftp.apcupsd.com/pub/apcupsd/contrib/gd1.2.tar.gz"
+HOMEPAGE="http://www.sibbald.com/apcupsd/"
+KEYWORDS="~x86 ~amd64 ~ppc ~arm ~sparc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND=">=sys-apps/baselayout-1.8.4
+ virtual/glibc
+ virtual/mta
+ snmp? ( net-analyzer/ucd-snmp )
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ usb? ( sys-apps/hotplug )"
+
+XPIDDIR=/var/run
+XLOGDIR=/var/log
+XLOCKDIR=/var/lock
+XSYSCONFDIR=/etc/apcupsd
+XPWRFAILDIR=${XSYSCONFDIR}
+
+src_unpack() {
+ unpack ${A}
+ cp -a ${WORKDIR}/gd1.2 ${S}/src/
+}
+
+src_compile() {
+ local myconf
+ use snmp && myconf="--enable-snmp"
+ APCUPSD_MAIL=/usr/sbin/sendmail ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/sbin \
+ --sysconfdir=${XSYSCONFDIR} \
+ --with-pwrfail-dir=${XPWRFAILDIR} \
+ --with-lock-dir=${XLOCKDIR} \
+ --with-pid-dir=${XPIDDIR} \
+ --with-log-dir=${XLOGDIR} \
+ --with-upstype=usb \
+ --with-upscable=usb \
+ --with-serial-dev=/dev/usb/hid/hiddev[0-9] \
+ --with-net-port=6666 \
+ --with-nis-port=3551 \
+ --enable-usb \
+ --enable-net \
+ --enable-oldnet \
+ --enable-master-slave \
+ --enable-powerflute \
+ --enable-pthreads \
+ --with-css-dir=/home/httpd/apcupsd \
+ --with-cgi-bin=/home/httpd/apcupsd \
+ --enable-cgi \
+ ${myconf} \
+ || die
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "installed failed"
+
+ insinto /etc/apache/conf/addon-modules
+ newins ${FILESDIR}/${PV}/apache.conf apcupsd.conf
+ insinto /etc/apcupsd
+ newins examples/safe.apccontrol safe.apccontrol
+
+ if [ "`use doc`x" != "x" ]
+ then
+ einfo "Installing full documentation into /usr/share/doc/${P}..."
+ cd ${S}/doc
+ dodoc README.*
+ docinto developers_manual
+ dodoc developers_manual/*
+ docinto logo
+ dodoc logo/*
+ docinto manual
+ dodoc manual/*
+ docinto old_documents
+ dodoc old_documents/*
+ docinto vim
+ dodoc vim/*
+ fi
+}
diff --git a/sys-apps/apcupsd/files/digest-apcupsd-3.10.6 b/sys-apps/apcupsd/files/digest-apcupsd-3.10.6
new file mode 100644
index 000000000000..6a67ac9bd84f
--- /dev/null
+++ b/sys-apps/apcupsd/files/digest-apcupsd-3.10.6
@@ -0,0 +1,2 @@
+MD5 a015d65ebeae9ee08aacbc8e6e7ac217 apcupsd-3.10.6.tar.gz 3679437
+MD5 d9a0ddf7918c93ca28fa5832a4af54d8 gd1.2.tar.gz 64595