summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-12 01:31:19 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-12 01:31:19 +0000
commit41deb2ca3e78f3ae19d0686856cf62fcd75852cc (patch)
tree494367d627d6c3ae7158d9ef4f99823c9f32c579 /sys-boot
parentRemove old. (diff)
downloadhistorical-41deb2ca3e78f3ae19d0686856cf62fcd75852cc.tar.gz
historical-41deb2ca3e78f3ae19d0686856cf62fcd75852cc.tar.bz2
historical-41deb2ca3e78f3ae19d0686856cf62fcd75852cc.zip
fix tests # 71811
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/Manifest3
-rw-r--r--sys-boot/grub/files/grub-0.96-bounced-checks.patch19
-rw-r--r--sys-boot/grub/grub-0.96-r1.ebuild13
3 files changed, 30 insertions, 5 deletions
diff --git a/sys-boot/grub/Manifest b/sys-boot/grub/Manifest
index 04bc104f79b2..6a2e63dfea83 100644
--- a/sys-boot/grub/Manifest
+++ b/sys-boot/grub/Manifest
@@ -6,7 +6,7 @@ MD5 809624c41057bbc7d8d6917d1104edf8 grub-0.94-r1.ebuild 3564
MD5 e1561dae9a23012a8960909af3cffb29 grub-0.94-r2.ebuild 3680
MD5 548d207b20beedd265fda7bb126c22de grub-0.95.20040823.ebuild 4155
MD5 9cf2ac1a1d69d1a44917c87aa4dd49a3 grub-0.96.ebuild 4072
-MD5 eed25fdc921b68415d5cc0c3235e1f89 grub-0.96-r1.ebuild 4806
+MD5 00462412cd4f8fef548ec60cb311f9aa grub-0.96-r1.ebuild 5011
MD5 16039704cf1e6b6f46b4413532af082c files/digest-grub-0.92-r1 133
MD5 5d1c8e582496db9d7a9b77e76f09f7d8 files/digest-grub-0.93.20030118 139
MD5 8d898cd9d1928916596cc3f9883eac67 files/grub-0.93-gcc3.3.diff 639
@@ -22,3 +22,4 @@ MD5 904c3dec402e5c7f0e62ab970dcdf5b2 files/grub-0.96-PIC.patch 1925
MD5 2170f54e53dea24426369c0154d46fc0 files/digest-grub-0.96-r1 140
MD5 3f3995353a0995c56d996d2218570160 files/grub-0.96-i2o-raid.patch 1597
MD5 8082c035a4ba98d0935b6b045827fb2c files/grub-0.96-nxstack.patch 18920
+MD5 e5978f58eb732289c47b1e0093db4e73 files/grub-0.96-bounced-checks.patch 505
diff --git a/sys-boot/grub/files/grub-0.96-bounced-checks.patch b/sys-boot/grub/files/grub-0.96-bounced-checks.patch
new file mode 100644
index 000000000000..6ad2c82ee0f4
--- /dev/null
+++ b/sys-boot/grub/files/grub-0.96-bounced-checks.patch
@@ -0,0 +1,19 @@
+Remove tests that the grub maintainers say can be ignored.
+
+http://lists.gnu.org/archive/html/bug-grub/2004-05/msg00076.html
+
+--- grub-0.96/stage2/size_test
++++ grub-0.96/stage2/size_test
+@@ -36,9 +36,9 @@
+ }
+
+ # The bootloader area of a FFS partition is 14 sectors.
+-check ffs_stage1_5 7168
+-
+-check ufs2_stage1_5 7168
++#check ffs_stage1_5 7168
++#
++#check ufs2_stage1_5 7168
+
+ # Stage 1.5 can be installed in the sectors immediately after MBR in the
+ # first cylinder, so the size is (63 - 1) sectors.
diff --git a/sys-boot/grub/grub-0.96-r1.ebuild b/sys-boot/grub/grub-0.96-r1.ebuild
index 6411aae65201..485b9135b22d 100644
--- a/sys-boot/grub/grub-0.96-r1.ebuild
+++ b/sys-boot/grub/grub-0.96-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.2 2005/03/11 14:04:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.3 2005/03/12 01:31:19 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -43,6 +43,9 @@ src_unpack() {
# PIC patch by psm & kevin f. quinn #80693
epatch "${FILESDIR}"/${P}-PIC.patch
+ # disable testing of FFS and UFS2 images that always fail (bug #71811)
+ epatch "${FILESDIR}"/${P}-bounced-checks.patch
+
# i2o RAID support #76143
epatch "${FILESDIR}"/${P}-i2o-raid.patch
@@ -65,7 +68,6 @@ src_compile() {
### i686-specific code in the boot loader is a bad idea; disabling to ensure
### at least some compatibility if the hard drive is moved to an older or
### incompatible system.
- unset CFLAGS
# grub-0.95 added -fno-stack-protector detection, to disable ssp for stage2,
# but the objcopy's (faulty) test fails if -fstack-protector is default.
@@ -76,7 +78,6 @@ src_compile() {
# STAGE2_CFLAGS is not allowed to be used on emake command-line, it overwrites
# -fno-stack-protector detected by configure, removed from netboot's emake.
- append-flags -DNDEBUG
export grub_cv_prog_objcopy_absolute=yes #79734
use static && append-ldflags -static
@@ -104,7 +105,7 @@ src_compile() {
# Now build the regular grub
# Note that FFS and UFS2 support are broken for now - stage1_5 files too big
- CFLAGS="${CFLAGS}" \
+ CFLAGS="" \
econf \
--libdir=/lib \
--datadir=/usr/lib/grub \
@@ -153,6 +154,10 @@ pkg_postinst() {
[[ -f ${x} ]] && cp -p ${x} /boot/grub
done
+ # hardened voodoo
+ [[ -x /sbin/chpax ]] && /sbin/chpax -spme /sbin/grub
+ [[ -x /sbin/paxctl ]] && /sbin/paxctl -spme /sbin/grub
+
[[ -e /boot/grub/grub.conf ]] \
&& /sbin/grub \
--batch \