summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-10 00:32:49 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-10 00:32:49 +0000
commitd21ffa4316f04e0f479bc76a08a1526acb3cb9cc (patch)
treedefe20793e861c871df0e02de29cb88acf9f21a6 /sys-boot
parentold (diff)
downloadhistorical-d21ffa4316f04e0f479bc76a08a1526acb3cb9cc.tar.gz
historical-d21ffa4316f04e0f479bc76a08a1526acb3cb9cc.tar.bz2
historical-d21ffa4316f04e0f479bc76a08a1526acb3cb9cc.zip
Version bump.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog7
-rw-r--r--sys-boot/syslinux/Manifest10
-rw-r--r--sys-boot/syslinux/files/digest-syslinux-2.131
-rw-r--r--sys-boot/syslinux/syslinux-2.13.ebuild33
4 files changed, 46 insertions, 5 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 13afbf688179..81717492cc67 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/syslinux
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.11 2005/01/10 00:26:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.12 2005/01/10 00:32:49 vapier Exp $
+
+*syslinux-2.13 (09 Jan 2005)
+
+ 09 Jan 2005; Mike Frysinger <vapier@gentoo.org> +syslinux-2.13.ebuild:
+ Version bump.
*syslinux-1.76 (09 Jan 2005)
diff --git a/sys-boot/syslinux/Manifest b/sys-boot/syslinux/Manifest
index 90750c6a4d46..e5f723f0adc0 100644
--- a/sys-boot/syslinux/Manifest
+++ b/sys-boot/syslinux/Manifest
@@ -1,16 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 0bf1a1696767cc23af51074e00a02601 ChangeLog 3140
+MD5 93eb2e823d64b6f469c9ef5d93a2c73d ChangeLog 3260
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 53ae1668c8fc16cc1e0093f28b1511a2 syslinux-2.13.ebuild 963
MD5 be91e91e8fbb5560f3cbd9adc6a38677 syslinux-2.11.ebuild 959
MD5 fad406869474fc3a7cfde4203eb896fe syslinux-1.76.ebuild 760
MD5 26489361fe682baf353e4b7cef7bba16 files/digest-syslinux-1.76 65
+MD5 d44d8f9a65b91ec75463ccc8dd60cee3 files/digest-syslinux-2.13 66
MD5 437dcea1ca8e2c9469874b045a9e76cb files/digest-syslinux-2.11 66
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.14 (GNU/Linux)
-iD8DBQFB4cyVroRuSHgZdywRAn9IAJ9u8vCEyIVRV4SHdsJsApRgNpmaNwCdHiUa
-Fl+DwLVotK46Fh8084Cd64Y=
-=smUM
+iD8DBQFB4c1GroRuSHgZdywRAi6zAJ4x4P/c+nzOHChi9WVFdGskQorACACeOPnj
+T3ei3wLKTBAqxKduL3v4mY8=
+=WOef
-----END PGP SIGNATURE-----
diff --git a/sys-boot/syslinux/files/digest-syslinux-2.13 b/sys-boot/syslinux/files/digest-syslinux-2.13
new file mode 100644
index 000000000000..e2a48eaa8280
--- /dev/null
+++ b/sys-boot/syslinux/files/digest-syslinux-2.13
@@ -0,0 +1 @@
+MD5 d04fad58d78acfe4d0143d16067053f7 syslinux-2.13.tar.bz2 421753
diff --git a/sys-boot/syslinux/syslinux-2.13.ebuild b/sys-boot/syslinux/syslinux-2.13.ebuild
new file mode 100644
index 000000000000..faa252ea3a8f
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-2.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-2.13.ebuild,v 1.1 2005/01/10 00:32:49 vapier Exp $
+
+inherit eutils gcc
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/Old/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ make INSTALLROOT="${D}" install || die
+ dodoc README NEWS TODO *.doc memdisk/memdisk.doc
+}