summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-21 15:01:34 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-21 15:01:34 +0000
commit9422b1de54d599256347b0552397d25267a37154 (patch)
tree17453b74450ff70cd9be891b2d9739dd8944d368 /x11-misc/xoo/xoo-0.7.ebuild
parentfix metadata.xml, stabilize, old (diff)
downloadhistorical-9422b1de54d599256347b0552397d25267a37154.tar.gz
historical-9422b1de54d599256347b0552397d25267a37154.tar.bz2
historical-9422b1de54d599256347b0552397d25267a37154.zip
fix repoman issues, clean up
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'x11-misc/xoo/xoo-0.7.ebuild')
-rw-r--r--x11-misc/xoo/xoo-0.7.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/x11-misc/xoo/xoo-0.7.ebuild b/x11-misc/xoo/xoo-0.7.ebuild
index d5de88e6c352..b2cbb06d7f78 100644
--- a/x11-misc/xoo/xoo-0.7.ebuild
+++ b/x11-misc/xoo/xoo-0.7.ebuild
@@ -1,13 +1,13 @@
-# Copyright 2006-2007 Gentoo Foundation
+# Copyright 2006-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xoo/xoo-0.7.ebuild,v 1.3 2007/07/22 03:58:23 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xoo/xoo-0.7.ebuild,v 1.4 2010/07/21 15:01:34 ssuominen Exp $
-DESCRIPTION="Xoo is a graphical wrapper around xnest. You can make Xnest look like a particular device's display and set up buttons on that device."
+DESCRIPTION="A graphical wrapper around xnest"
HOMEPAGE="http://projects.o-hand.com/xoo"
SRC_URI="http://projects.o-hand.com/sources/xoo/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~x86"
IUSE="gnome"
@@ -18,21 +18,18 @@ DEPEND="gnome? ( gnome-base/gconf )
src_unpack() {
unpack ${A}
- cd ${S}
-
+ cd "${S}"
# Fix default Xnest binary path.
- sed -e "s:/usr/X11R6/bin/Xnest:$(type -P Xnest):" -i src/main.c || die "sed failed."
+ sed -e "s:/usr/X11R6/bin/Xnest:$(type -P Xnest):" -i src/main.c || die
}
src_compile() {
- econf $(use_enable gnome gconf) \
- || die "Configuration failed"
-
- emake || die "Compilation failed"
+ econf \
+ $(use_enable gnome gconf)
+ emake || die
}
src_install() {
- make DESTDIR=${D} install || die "Installation failed"
-
- dodoc AUTHORS Changelog INSTALL NEWS README TODO
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog NEWS README TODO
}