summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/XWine')
-rw-r--r--app-emulation/XWine/ChangeLog11
-rw-r--r--app-emulation/XWine/XWine-0.3.ebuild64
-rw-r--r--app-emulation/XWine/files/digest-XWine-0.31
3 files changed, 73 insertions, 3 deletions
diff --git a/app-emulation/XWine/ChangeLog b/app-emulation/XWine/ChangeLog
index bf41dcfd211b..f3bb8b89880a 100644
--- a/app-emulation/XWine/ChangeLog
+++ b/app-emulation/XWine/ChangeLog
@@ -1,9 +1,16 @@
# ChangeLog for app-emulation/XWine
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/ChangeLog,v 1.5 2003/02/12 03:58:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/ChangeLog,v 1.6 2003/03/13 11:52:37 phoenix Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*XWine-0.3.ebuild (13 Mar 2002)
+
+ 13 Mar 2002; phoen][x <phoenix@gentoo.org> XWine-0.3.ebuild :
+ Verison bump. This ebuild fixes problems with the interactive configure
+ and ends the gnome dependency trouble: XWine depends on gnome, there's no
+ way to compile it without gnome-libs being installed.
+
*XWine-0.2.2.ebuild (17 Aug 2002)
03 Sep 2002; Nick Hadaway <raker@gentoo.org> XWine-0.2.2.ebuild :
@@ -18,5 +25,3 @@
17 Aug 2002; Brad Cowan <bradlyatc@cowancomputers.com>
XWine-0.2.2.ebuild, files/digest-XWine-0.2.2 :
Ebuild submitted by Brad Cowan bradlyatc@cowancomputers.com
-
-
diff --git a/app-emulation/XWine/XWine-0.3.ebuild b/app-emulation/XWine/XWine-0.3.ebuild
new file mode 100644
index 000000000000..ba867e24c3df
--- /dev/null
+++ b/app-emulation/XWine/XWine-0.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.3.ebuild,v 1.1 2003/03/13 11:52:37 phoenix Exp $
+
+DESCRIPTION="GTK frontend for Wine"
+HOMEPAGE="http://darken.tuxfamily.org/pages/xwine_en.html"
+SRC_URI="http://darken.tuxfamily.org/projets/${P}_en.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc "
+IUSE="nls"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r8
+ >=net-www/mozilla-1.0-r2
+ >=app-emulation/wine-20020710-r1
+ sys-devel/bison
+ >=gnome-base/gnome-libs-1.4.2
+ >=gnome-base/ORBit-0.5.17
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}
+ >=app-emulation/winesetuptk-0.6.0b-r2"
+
+S="${WORKDIR}/${P}_en"
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+
+ MOZ="`which mozilla`"
+
+ if [ -f ${MOZ} ] ; then
+ einfo "Setting up src/donnees.h to use mozilla as help browser."
+ cp -f ${S}/configure.d ${S}/configure
+ cp -f ${S}/src/donnees.h.in ${S}/src/donnees.h
+ echo "#define NAVIGATEUR \"${MOZ} -f\"" >> ${S}/src/donnees.h
+ else
+ ewarn "Mozilla not found in current PATH."
+ ewarn "PATH = ${PATH}"
+ die "Mozilla not found."
+ fi
+
+ econf ${myconf}
+
+ emake || die
+}
+
+src_install() {
+ einstall
+
+ # Don't need to install docs twice
+ rm -rf ${D}/usr/share/doc/xwine
+
+ dodoc doc/Manual* FAQ* BUGS COPYING AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo "${PN} requires a setup Wine to start....It is recommended"
+ einfo "that you run winesetuptk prior to running ${PN} to setup"
+ einfo "a base Wine install"
+}
diff --git a/app-emulation/XWine/files/digest-XWine-0.3 b/app-emulation/XWine/files/digest-XWine-0.3
new file mode 100644
index 000000000000..ee22c386876f
--- /dev/null
+++ b/app-emulation/XWine/files/digest-XWine-0.3
@@ -0,0 +1 @@
+MD5 e7b31440f95ff06e2ab4f0893d48bef4 XWine-0.3_en.tar.gz 347894