summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdfsandwich')
-rw-r--r--app-text/pdfsandwich/ChangeLog11
-rw-r--r--app-text/pdfsandwich/Manifest14
-rw-r--r--app-text/pdfsandwich/metadata.xml23
-rw-r--r--app-text/pdfsandwich/pdfsandwich-0.0.2.ebuild29
4 files changed, 77 insertions, 0 deletions
diff --git a/app-text/pdfsandwich/ChangeLog b/app-text/pdfsandwich/ChangeLog
new file mode 100644
index 000000000000..56fd61d758f2
--- /dev/null
+++ b/app-text/pdfsandwich/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/pdfsandwich
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdfsandwich/ChangeLog,v 1.1 2010/10/22 15:11:40 tomka Exp $
+
+*pdfsandwich-0.0.2 (22 Oct 2010)
+
+ 22 Oct 2010; Thomas Kahle <tomka@gentoo.org> +pdfsandwich-0.0.2.ebuild,
+ +metadata.xml:
+ New ebuild: app-text/pdfsandwich, fixes bug 321885, original ebuild
+ by Tobias Elze.
+
diff --git a/app-text/pdfsandwich/Manifest b/app-text/pdfsandwich/Manifest
new file mode 100644
index 000000000000..0b6a1b73d72a
--- /dev/null
+++ b/app-text/pdfsandwich/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST pdfsandwich-0.0.2.tar.bz2 10239 RMD160 a4d7c00cfec9db16f52bccd9ecf4b7691bb29aea SHA1 6e9fea89fa9c81f15e177d23ddb4a3e88e59ca0b SHA256 b0bbbd3aa648d0e89cb5f4647f875de6959aacea27fe6a06ba33141f9b87301f
+EBUILD pdfsandwich-0.0.2.ebuild 798 RMD160 b892e9590be11c08e3b67d47468b93c36b43bf7f SHA1 b7faef4ee1518dca5e43517741581984b2399ae9 SHA256 8218dd3a66d797cb007825eaafccae8d98493eb951a06e2569848cc672058670
+MISC ChangeLog 427 RMD160 ff1fdecdc39fa2b15f9b8667d7546f99c9429b28 SHA1 2649eb021585489d64563c251b2176080cb51e7f SHA256 2c1f72be45db56f0fa3253fc937f66600bb0ff990008268b8d149dfb57ff848c
+MISC metadata.xml 909 RMD160 8e220a5199ebfcd32f65982b0bee8fe7af4cb2d4 SHA1 59c9751743385bdaba9f551dcb1e448843d28929 SHA256 32530d001bfced183f85fa426d8c67f2fd702e069cbe2fe2bcbcd2980ec4f9cc
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iEYEARECAAYFAkzBqboACgkQnZsgo/h8kNa8GACeJ6JgcKkmthjUhFcy6bOuBXfg
+3tMAoKeIOl1Pf7Mq6+SKNqWV9F67juLY
+=U4LN
+-----END PGP SIGNATURE-----
diff --git a/app-text/pdfsandwich/metadata.xml b/app-text/pdfsandwich/metadata.xml
new file mode 100644
index 000000000000..35ca8c3c458c
--- /dev/null
+++ b/app-text/pdfsandwich/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>tomka@gentoo.org</email>
+</maintainer>
+<herd>no-herd</herd>
+<longdescription>
+pdfsandwich generates "sandwich" OCR pdf files, i.e. pdf files which
+contain only images (no text) will be processed by optical character
+recognition (OCR) and the text will be added to each page invisibly
+"behind" the images.
+
+pdfsandwich is a command line tool which is supposed to be useful to
+OCR scanned books or journals. It is able to recognize the page layout
+even for multicolumn text.
+
+Essentially, pdfsandwich is a wrapper script which calls the following
+binaries: convert, cuneiform, gs, and hocr2pdf. It is known to run on
+Unix systems and has been tested on Linux and MacOS X. It supports
+parallel processing on multiprocessor systems.
+</longdescription>
+</pkgmetadata>
diff --git a/app-text/pdfsandwich/pdfsandwich-0.0.2.ebuild b/app-text/pdfsandwich/pdfsandwich-0.0.2.ebuild
new file mode 100644
index 000000000000..6d7d17ee1e30
--- /dev/null
+++ b/app-text/pdfsandwich/pdfsandwich-0.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdfsandwich/pdfsandwich-0.0.2.ebuild,v 1.1 2010/10/22 15:11:40 tomka Exp $
+
+EAPI="2"
+
+DESCRIPTION="generator of sandwich OCR pdf files"
+HOMEPAGE="http://pdfsandwich.origo.ethz.ch/wiki/pdfsandwich"
+SRC_URI="http://download.origo.ethz.ch/pdfsandwich/1809/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="<app-text/cuneiform-0.9.0[imagemagick]
+ media-gfx/exact-image
+ app-text/ghostscript-gpl"
+
+DEPEND="sys-apps/gawk
+ >=dev-lang/ocaml-3.08[ocamlopt]"
+
+src_prepare() {
+ sed -i "/^OCAMLOPTFLAGS/s/$/ -ccopt \"\$(CFLAGS) \$(LDFLAGS)\"/" Makefile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}