summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/atk/atk-2.2.0.ebuild')
-rw-r--r--dev-libs/atk/atk-2.2.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/atk/atk-2.2.0.ebuild b/dev-libs/atk/atk-2.2.0.ebuild
new file mode 100644
index 000000000000..b6347a6d1234
--- /dev/null
+++ b/dev-libs/atk/atk-2.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-2.2.0.ebuild,v 1.1 2011/10/19 02:19:06 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="http://projects.gnome.org/accessibility/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="doc +introspection nls"
+
+RDEPEND="dev-libs/glib:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.13 )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable introspection)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests (bug #226353)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ # Remove DEPRECATED flags
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i atk/Makefile.am atk/Makefile.in \
+ tests/Makefile.am tests/Makefile.in || die "sed 2 failed"
+}