summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/snack/snack-2.2.10-r4.ebuild')
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r4.ebuild27
1 files changed, 23 insertions, 4 deletions
diff --git a/dev-tcltk/snack/snack-2.2.10-r4.ebuild b/dev-tcltk/snack/snack-2.2.10-r4.ebuild
index fa34fcb4f03e..9a7a5514f135 100644
--- a/dev-tcltk/snack/snack-2.2.10-r4.ebuild
+++ b/dev-tcltk/snack/snack-2.2.10-r4.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10-r4.ebuild,v 1.9 2010/06/09 11:55:25 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10-r4.ebuild,v 1.10 2011/04/12 18:13:12 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
-PYTHON_MODNAME="tkSnack.py"
+RESTRICT_PYTHON_ABIS="3.*"
inherit eutils distutils multilib
@@ -27,10 +27,17 @@ DEPEND="
alsa? ( media-libs/alsa-lib )
vorbis? ( media-libs/libvorbis )"
RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${PN}${PV}/unix"
+PYTHON_MODNAME="tkSnack.py"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
src_prepare() {
# bug 226137 - snack depends on alsa private symbol _snd_pcm_mmap_hw_ptr
epatch "${FILESDIR}"/alsa-undef-sym.patch
@@ -84,3 +91,15 @@ src_install() {
fi
fi
}
+
+pkg_postinst() {
+ if use python; then
+ distutils_pkg_postinst
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ distutils_pkg_postrm
+ fi
+}