summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dcoppython/dcoppython-3.5.8.ebuild')
-rw-r--r--kde-base/dcoppython/dcoppython-3.5.8.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/dcoppython/dcoppython-3.5.8.ebuild b/kde-base/dcoppython/dcoppython-3.5.8.ebuild
new file mode 100644
index 000000000000..1a501ea6f5a3
--- /dev/null
+++ b/kde-base/dcoppython/dcoppython-3.5.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dcoppython/dcoppython-3.5.8.ebuild,v 1.1 2007/10/19 21:51:11 philantrop Exp $
+
+KMNAME=kdebindings
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE: Python bindings for DCOP"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/python"
+
+# Because this installs into /usr/lib/python2.3/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely
+SLOT="0"
+
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}