summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kalgebra/kalgebra-4.9.4.ebuild')
-rw-r--r--kde-base/kalgebra/kalgebra-4.9.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-base/kalgebra/kalgebra-4.9.4.ebuild b/kde-base/kalgebra/kalgebra-4.9.4.ebuild
new file mode 100644
index 000000000000..b9c7991a1d84
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.9.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.9.4.ebuild,v 1.1 2012/12/05 16:57:40 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma readline"
+
+DEPEND="
+ $(add_kdebase_dep analitza)
+ $(add_kdebase_dep libkdeedu)
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with readline)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-base_src_configure
+}