summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild')
-rw-r--r--media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild b/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild
index 9a693f2a2f4f..6ec9f7a85748 100644
--- a/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild
+++ b/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild,v 1.1 2012/07/15 22:40:09 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild,v 1.2 2012/07/23 16:31:26 floppym Exp $
EAPI=4
@@ -262,14 +262,16 @@ src_install() {
newins "${FILESDIR}"/xinitrc-r1 .xinitrc
fi
- # Make Python files executable and ensure they are executed by Python 2
+ # Make Python files executable
find "${ED}/usr/share/mythtv" -type f -name '*.py' | while read file; do
if [[ ! "${file##*/}" = "__init__.py" ]]; then
chmod a+x "${file}"
- python_convert_shebangs -q 2 "${file}"
fi
done
+ # Ensure that Python scripts are executed by Python 2
+ python_convert_shebangs -q -r 2 "${ED}/usr/share/mythtv"
+
# Make shell & perl scripts executable
find "${ED}" -type f -name '*.sh' -o -type f -name '*.pl' | \
while read file; do