summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog5
-rw-r--r--net-analyzer/nmap/Manifest22
-rw-r--r--net-analyzer/nmap/nmap-3.81.ebuild14
3 files changed, 27 insertions, 14 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index dd4aaebb9461..98629a02dc5d 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.84 2005/02/19 04:35:01 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.85 2005/02/20 12:38:24 spock Exp $
+
+ 20 Feb 2005; Michał Januszewski <spock@gentoo.org> nmap-3.81.ebuild:
+ Cleaned the ebuild up a little - included fixes from bug #81881.
18 Feb 2005; Lina Pezzella <j4rg0n@gentoo.org> nmap-3.75.ebuild:
Stable ppc-macos
diff --git a/net-analyzer/nmap/Manifest b/net-analyzer/nmap/Manifest
index eec8c7f2ea2f..820f6052e1ef 100644
--- a/net-analyzer/nmap/Manifest
+++ b/net-analyzer/nmap/Manifest
@@ -1,12 +1,22 @@
-MD5 f3a0be03ae9cc9398637301620a72f0e ChangeLog 10520
-MD5 cfe1b5f88cc51ac6ffc42809178d2a06 metadata.xml 221
-MD5 244b0212bfdb7736fc34385b7235a340 nmap-3.50-r1.ebuild 1007
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 b1105b21c7e1e9be00c8b54d48dcc71a nmap-3.80.ebuild 896
+MD5 244b0212bfdb7736fc34385b7235a340 nmap-3.50-r1.ebuild 1007
MD5 88ad040e0cf7515b3403431704294942 nmap-3.55.ebuild 1049
-MD5 b7e66642422f6e9b07fdaec56818ca08 nmap-3.81.ebuild 896
MD5 868c3ad8d49b090ad39f857a2bd69029 nmap-3.75.ebuild 891
+MD5 6077c93f3a4ac152b212b8542d9cd658 nmap-3.81.ebuild 883
+MD5 605ea7a245efbfffc026a9e47607b860 ChangeLog 10659
+MD5 cfe1b5f88cc51ac6ffc42809178d2a06 metadata.xml 221
+MD5 1037b8fc75e77ab2c1e2687d5d3a88cc files/digest-nmap-3.55 133
+MD5 e81c708c7cfa2c876d8cbfa622144d39 files/digest-nmap-3.75 63
MD5 7e325a4f6e38e7e0c351cc0c294ee222 files/digest-nmap-3.80 63
MD5 a9321c7613a34f902b2bcf53af008bc3 files/digest-nmap-3.81 63
MD5 3df9d80cb8c3933dffd20af89a82957b files/digest-nmap-3.50-r1 133
-MD5 1037b8fc75e77ab2c1e2687d5d3a88cc files/digest-nmap-3.55 133
-MD5 e81c708c7cfa2c876d8cbfa622144d39 files/digest-nmap-3.75 63
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCGITUchej4aZK9/cRAkG5AJ4sjodDCIY44rRr34ulHeiG4NMhPgCdHB4a
+ysS0iczmP4U/9bAOMFGMkUY=
+=2szJ
+-----END PGP SIGNATURE-----
diff --git a/net-analyzer/nmap/nmap-3.81.ebuild b/net-analyzer/nmap/nmap-3.81.ebuild
index a2c27a848e87..9a946e76513e 100644
--- a/net-analyzer/nmap/nmap-3.81.ebuild
+++ b/net-analyzer/nmap/nmap-3.81.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.81.ebuild,v 1.1 2005/02/08 17:08:02 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.81.ebuild,v 1.2 2005/02/20 12:38:24 spock Exp $
inherit eutils
@@ -11,22 +11,22 @@ SRC_URI="http://www.insecure.org/nmap/dist/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64 ~ppc64 ~s390 ~ia64 ~ppc-macos"
-IUSE="gtk gnome ipv6"
+IUSE="gtk ssl"
DEPEND="virtual/libc
dev-libs/libpcre
- gtk? ( =x11-libs/gtk+-1.2* )"
+ gtk? ( =x11-libs/gtk+-1.2* )
+ ssl? ( dev-libs/openssl )"
src_compile() {
- econf `use_with gtk nmapfe` \
- `use_enable ipv6` || die
+ econf \
+ $(use_with gtk nmapfe) \
+ $(use_with ssl openssl) || die
emake -j1 || die
}
src_install() {
einstall -j1 nmapdatadir=${D}/usr/share/nmap install || die
- use gnome || rm -rf ${D}/usr/share/gnome/
-
dodoc CHANGELOG HACKING INSTALL docs/README docs/*.txt
dohtml docs/*.html
}