summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/pptpclient/pptpclient-1.2.0.ebuild')
-rw-r--r--net-dialup/pptpclient/pptpclient-1.2.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-dialup/pptpclient/pptpclient-1.2.0.ebuild b/net-dialup/pptpclient/pptpclient-1.2.0.ebuild
new file mode 100644
index 000000000000..359da8b72da6
--- /dev/null
+++ b/net-dialup/pptpclient/pptpclient-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/pptpclient-1.2.0.ebuild,v 1.1 2003/02/26 23:31:46 agriffis Exp $
+
+MY_P=pptp-linux-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Linux client for PPTP"
+HOMEPAGE="http://pptpclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pptpclient/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="tcltk"
+
+DEPEND="net-dialup/ppp
+ sys-devel/perl
+ tcltk? ( dev-perl/perl-tk )"
+
+src_compile() {
+ make || die "make failed"
+}
+
+src_install() {
+ dosbin pptp
+ dodoc AUTHORS COPYING ChangeLog DEVELOPERS NEWS README TODO USING
+ dodoc Documentation/*
+ dodoc Reference/*
+ dodir /etc/pptp.d
+
+ # The current version of pptp-linux doesn't include the
+ # RH-specific portions, so include them ourselves.
+ cd ${FILESDIR}
+ insinto /etc/ppp
+ doins options.pptp
+ dosbin pptp-command pptp_fe.pl
+ use tcltk && dosbin xpptp_fe.pl
+}