summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libetpan/libetpan-0.46-r1.ebuild')
-rw-r--r--net-libs/libetpan/libetpan-0.46-r1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/net-libs/libetpan/libetpan-0.46-r1.ebuild b/net-libs/libetpan/libetpan-0.46-r1.ebuild
deleted file mode 100644
index 0b7f26041782..000000000000
--- a/net-libs/libetpan/libetpan-0.46-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.46-r1.ebuild,v 1.1 2006/09/21 23:46:22 ticho Exp $
-
-DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
-HOMEPAGE="http://libetpan.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="berkdb debug gnutls sasl ssl"
-
-DEPEND="virtual/libc
- berkdb? ( sys-libs/db )
- gnutls? ( net-libs/gnutls )
- !gnutls? ( ssl? ( dev-libs/openssl ) )
- sasl? ( dev-libs/cyrus-sasl )"
-
-src_compile() {
- local sslconf
-
- if use ssl; then
- if use gnutls; then
- sslconf="--with-gnutls --without-openssl"
- else
- sslconf="--without-gnutls --with-openssl"
- fi
- else
- if use gnutls; then
- sslconf="--with-gnutls --without-openssl"
- else
- sslconf="--without-gnutls --without-openssl"
- fi
- fi
-
- econf \
- `use_enable debug` \
- `use_enable berkdb db` \
- `use_with sasl` \
- ${sslconf} \
- || die "econf failed"
-
- # build system is broken, we need -j1 (bug #126848) - Ticho, 2006-05-02
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "make install failed"
- dodoc NEWS TODO ChangeLog
-}
-
-pkg_postinst() {
- ewarn "The soname for libetpan has changed after libetpan-0.45."
- ewarn "If you have upgraded from that or earlier version, it is recommended to run"
- ewarn "revdep-rebuild to fix any linking errors caused by this change."
-}