summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/vmd/vmd-1.8.7.ebuild')
-rw-r--r--sci-chemistry/vmd/vmd-1.8.7.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/sci-chemistry/vmd/vmd-1.8.7.ebuild b/sci-chemistry/vmd/vmd-1.8.7.ebuild
index 2b20f6714aba..4123b59229c4 100644
--- a/sci-chemistry/vmd/vmd-1.8.7.ebuild
+++ b/sci-chemistry/vmd/vmd-1.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.7.ebuild,v 1.2 2009/08/06 15:18:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.7.ebuild,v 1.3 2009/08/07 13:29:11 markusle Exp $
EAPI="2"
@@ -21,7 +21,7 @@ DEPEND="x11-libs/libXft
virtual/opengl
x11-libs/fltk:1.1
>=dev-lang/tcl-8.4
- >=dev-lang/tk-8.4[-truetype]
+ >=dev-lang/tk-8.4
=dev-lang/python-2*
dev-lang/perl
dev-python/numpy
@@ -43,6 +43,16 @@ pkg_nofetch() {
}
src_prepare() {
+ # currently, tk-8.5* with USE=truetype breaks some
+ # tk apps such as Sequence Viewer or Timeline.
+ if has_version =dev-lang/tcl-8.5* && built_with_use dev-lang/tk truetype; then
+ echo
+ eerror "Error: Your tk was build with USE=\"truetype\" which"
+ eerror "will cause some of VMD's tk apps to not work properly"
+ eerror "(Sequence Viewer, Timeline, ..)."
+ die "Please emerge tk with USE=\"-truetype\"".
+ fi
+
# apply LINUX-arch patches to vmd configure
epatch "${FILESDIR}/${P}-config.patch"
epatch "${FILESDIR}/${P}-use-bash-startup.patch"