summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild')
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild b/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild
index 1fc0083f0e47..4e8fd214f228 100644
--- a/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild
+++ b/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild,v 1.1 2007/04/18 10:10:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild,v 1.2 2007/07/10 03:35:55 nerdboy Exp $
-inherit eutils autotools wxwidgets
+inherit eutils autotools wxwidgets fdo-mime
MYP=wxMaxima-${PV}
@@ -50,11 +50,19 @@ src_compile () {
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"
- insinto /usr/share/pixmaps/
- newins maxima-new.png wxmaxima.png
- make_desktop_entry wxmaxima wxMaxima wxmaxima
+ newicon maxima-new.png wxmaxima.png
+ make_desktop_entry wxmaxima "wxMaxima ${PV}" wxmaxima \
+ "Science;Math;Education"
dosym ${PORTDIR}/licenses/${LICENSE} /usr/share/${PN}/COPYING
dodir /usr/share/doc/${PF}
dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}