summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/extrema/ChangeLog10
-rw-r--r--sci-visualization/extrema/Manifest4
-rw-r--r--sci-visualization/extrema/extrema-4.3.5.ebuild55
-rw-r--r--sci-visualization/extrema/metadata.xml10
4 files changed, 79 insertions, 0 deletions
diff --git a/sci-visualization/extrema/ChangeLog b/sci-visualization/extrema/ChangeLog
new file mode 100644
index 000000000000..7f3b4f010b95
--- /dev/null
+++ b/sci-visualization/extrema/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-visualization/extrema
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/extrema/ChangeLog,v 1.1 2008/05/03 18:08:28 grozin Exp $
+
+*extrema-4.3.5 (04 May 2008)
+
+ 04 May 2008; Andrey Grozin <grozin@gentoo.org> +metadata.xml,
+ +extrema-4.3.5.ebuild:
+ Initial import.
+
diff --git a/sci-visualization/extrema/Manifest b/sci-visualization/extrema/Manifest
new file mode 100644
index 000000000000..4c30f57b4e54
--- /dev/null
+++ b/sci-visualization/extrema/Manifest
@@ -0,0 +1,4 @@
+DIST extrema-4.3.5.tar.gz 6267856 RMD160 1a226a9e442f7c8007e7f9b7f8ec63e3919d2529 SHA1 ef1986293d530fc4372b32be3250e1538c2509ca SHA256 70a8db93e12c571724899f48abec5ecaf577fb039e7cb6360db0a93b7d64f433
+EBUILD extrema-4.3.5.ebuild 1497 RMD160 86e796cdeafba2d2556d71cc4ba8b5a57d0220bc SHA1 cd37d91e3d7ed93f3cfc5277bf0ad0f4157021c2 SHA256 d2864355f0d8658001a24f07eea4e49167b45991b7bdeb1d5d02da19412e5a82
+MISC ChangeLog 361 RMD160 41774c2920e49253f4be03bec321c8cb189c0b58 SHA1 af5a651f072be78ef1208a4767c3c187e67c2a18 SHA256 57a241ef0bcf11d6771a9c94285522db9124eeaa12cc330d032a19fe3b9b25d6
+MISC metadata.xml 575 RMD160 5caa41391cb1bc18964be1137955dfa8f78bcbc6 SHA1 4f26d103d5de06c43cf07cf2378830811d19437f SHA256 c32b9b72b2e710e3b6a23b15fd74ab5e9f2611762057425cd28ee5e4f1cc823e
diff --git a/sci-visualization/extrema/extrema-4.3.5.ebuild b/sci-visualization/extrema/extrema-4.3.5.ebuild
new file mode 100644
index 000000000000..6287eed28e26
--- /dev/null
+++ b/sci-visualization/extrema/extrema-4.3.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/extrema/extrema-4.3.5.ebuild,v 1.1 2008/05/03 18:08:28 grozin Exp $
+
+WX_GTK_VER="2.8"
+inherit eutils fdo-mime wxwidgets
+
+DESCRIPTION="Interactive data analysis and visualization tool"
+HOMEPAGE="http://exsitewebware.com/extrema/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="doc examples"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DEPEND=">=x11-libs/wxGTK-2.8.7
+ dev-util/desktop-file-utils"
+
+src_compile() {
+ # extrema cannot be compiled with versions of minuit
+ # available in portage
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ # The upstream Makefile is mostly OK, but for a few files
+ # cp to a hard-coded directory is used, ignoring $(DESTDIR)
+ # This problem is solved by einstall
+ einstall || die "einstall failed"
+
+ make_desktop_entry ${PN}
+ dodir /usr/share/icons/hicolor
+ tar xjf extrema_icons.tar.bz2 -C "${D}usr/share/icons/hicolor"
+ dosym /usr/share/icons/hicolor/48x48/apps/extrema.png /usr/share/pixmaps/extrema.png
+
+ dodoc AUTHORS ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/*
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins Scripts/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-visualization/extrema/metadata.xml b/sci-visualization/extrema/metadata.xml
new file mode 100644
index 000000000000..e8eff4831cce
--- /dev/null
+++ b/sci-visualization/extrema/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Extrema is a powerful visualization and data analysis tool that enables researchers to quickly distill their large, complex data sets into meaningful information. Its flexibility, sophistication, and power allow you to easily develop your own commands and create highly customized graphs.</longdescription>
+</pkgmetadata>