summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/parted/parted-1.6.10.ebuild')
-rw-r--r--sys-apps/parted/parted-1.6.10.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/parted/parted-1.6.10.ebuild b/sys-apps/parted/parted-1.6.10.ebuild
new file mode 100644
index 000000000000..44f1542a2222
--- /dev/null
+++ b/sys-apps/parted/parted-1.6.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.10.ebuild,v 1.1 2004/04/24 03:33:52 npmccallum Exp $
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="http://www.gnu.org/software/parted"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz
+ mirror://gentoo/${PF}-gentoo.tar.bz2
+ http://dev.gentoo.org/~npmccallum/distfiles/${PF}-gentoo.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -*"
+IUSE="nls static readline debug noreiserfs"
+
+DEPEND=">=sys-fs/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ readline? ( >=sys-libs/readline-4.1-r4 )"
+
+RDEPEND="${DEPEND}
+ !noreiserfs? ( =sys-fs/progsreiserfs-0.3.0* )"
+
+PATCHDIR=${WORKDIR}/patches
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
+}
+
+src_compile() {
+ econf \
+ `use_with readline` \
+ `use_enable nls` \
+ `use_enable debug` \
+ `use_enable static all-static` \
+ --target=${CHOST} ${myconf} || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog \
+ INSTALL NEWS README THANKS TODO
+ docinto doc; cd doc
+ dodoc API COPYING.DOC FAQ FAT USER USER.jp
+}