summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/parted')
-rw-r--r--sys-apps/parted/ChangeLog9
-rw-r--r--sys-apps/parted/Manifest4
-rw-r--r--sys-apps/parted/files/digest-parted-1.6.102
-rw-r--r--sys-apps/parted/parted-1.6.10.ebuild49
4 files changed, 62 insertions, 2 deletions
diff --git a/sys-apps/parted/ChangeLog b/sys-apps/parted/ChangeLog
index ea8354a16d4b..7718ebb5074b 100644
--- a/sys-apps/parted/ChangeLog
+++ b/sys-apps/parted/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/parted
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.37 2004/04/23 05:02:11 npmccallum Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.38 2004/04/24 03:33:52 npmccallum Exp $
+
+*parted-1.6.10 (23 Apr 2004)
+
+ 23 Apr 2004; Nathaniel McCallum <npmccallum@gentoo.org>
+ +parted-1.6.10.ebuild:
+ added parted-1.6.10
+ fixed hfs patch so it will apply to parted-1.6.10
*parted-1.6.9 (23 Apr 2004)
diff --git a/sys-apps/parted/Manifest b/sys-apps/parted/Manifest
index 11972a67838d..2d63b2dfb9b6 100644
--- a/sys-apps/parted/Manifest
+++ b/sys-apps/parted/Manifest
@@ -4,7 +4,8 @@ MD5 b5099293a41249b9a76f881cc58a1f87 parted-1.6.8-r1.ebuild 1344
MD5 05ee578d687ea1d4bb666b46f0a1b659 parted-1.6.6.ebuild 1404
MD5 443a08ec2107ac3b612ac1742b5dec8c parted-1.6.8.ebuild 1349
MD5 3b20af798e42548466f842edfcb0d09d parted-1.6.6-r1.ebuild 1341
-MD5 9853300e344ed70c9ebafe86fe8121ee ChangeLog 6033
+MD5 e52bb2ffd6d3009cc77ab70d00455e2a ChangeLog 6221
+MD5 96f4651e32383f7e486d09c72870ee51 parted-1.6.10.ebuild 1344
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 6f43c57a0726ccc02e6c72f846b38b4d files/digest-parted-1.6.5-r1 136
MD5 5d070cbf01c5069caea1fca614e23fda files/digest-parted-1.6.6-r1 139
@@ -12,3 +13,4 @@ MD5 af973b06c5b39b76eaacf28c941b7817 files/digest-parted-1.6.8-r1 139
MD5 b020ac3a8080ad690bb3ce376e5273bb files/digest-parted-1.6.6 136
MD5 91cce0be883593275637a9af75eaf2ed files/digest-parted-1.6.8 136
MD5 a66a486a8ad13f83788c674d3f386c28 files/digest-parted-1.6.9 136
+MD5 7b6a2363681167aa5bd67790f7d7a43e files/digest-parted-1.6.10 138
diff --git a/sys-apps/parted/files/digest-parted-1.6.10 b/sys-apps/parted/files/digest-parted-1.6.10
new file mode 100644
index 000000000000..1e003bd3a2be
--- /dev/null
+++ b/sys-apps/parted/files/digest-parted-1.6.10
@@ -0,0 +1,2 @@
+MD5 470a0cc59dd9eb1205335bfc1faa538f parted-1.6.10.tar.gz 1448837
+MD5 a8cf344f5fc3a1af2fe5312a610b680f parted-1.6.10-gentoo.tar.bz2 20013
diff --git a/sys-apps/parted/parted-1.6.10.ebuild b/sys-apps/parted/parted-1.6.10.ebuild
new file mode 100644
index 000000000000..44f1542a2222
--- /dev/null
+++ b/sys-apps/parted/parted-1.6.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.10.ebuild,v 1.1 2004/04/24 03:33:52 npmccallum Exp $
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="http://www.gnu.org/software/parted"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz
+ mirror://gentoo/${PF}-gentoo.tar.bz2
+ http://dev.gentoo.org/~npmccallum/distfiles/${PF}-gentoo.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -*"
+IUSE="nls static readline debug noreiserfs"
+
+DEPEND=">=sys-fs/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ readline? ( >=sys-libs/readline-4.1-r4 )"
+
+RDEPEND="${DEPEND}
+ !noreiserfs? ( =sys-fs/progsreiserfs-0.3.0* )"
+
+PATCHDIR=${WORKDIR}/patches
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
+}
+
+src_compile() {
+ econf \
+ `use_with readline` \
+ `use_enable nls` \
+ `use_enable debug` \
+ `use_enable static all-static` \
+ --target=${CHOST} ${myconf} || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog \
+ INSTALL NEWS README THANKS TODO
+ docinto doc; cd doc
+ dodoc API COPYING.DOC FAQ FAT USER USER.jp
+}