summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/unieject/unieject-4.ebuild')
-rw-r--r--sys-block/unieject/unieject-4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-block/unieject/unieject-4.ebuild b/sys-block/unieject/unieject-4.ebuild
new file mode 100644
index 000000000000..388bb78156ed
--- /dev/null
+++ b/sys-block/unieject/unieject-4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/unieject-4.ebuild,v 1.1 2005/08/30 22:07:35 flameeyes Exp $
+
+DESCRIPTION="Multiplatform command to eject and load CD-Rom drives"
+HOMEPAGE="http://dev.gentoo.org/~flameeyes/projects.xhtml"
+SRC_URI="http://digilander.libero.it/dgp85/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/libcdio-0.75-r1
+ dev-libs/popt
+ >=dev-libs/confuse-2.5
+ nls? ( sys-devel/gettext )
+ !virtual/eject"
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ sys-devel/gettext
+ app-text/txt2man"
+
+PROVIDE="virtual/eject"
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc README ChangeLog NEWS AUTHORS unieject.conf.sample
+
+ # Symlink to eject to provide a good virtual/eject
+ dosym unieject.1.gz /usr/share/man/man1/eject.1.gz
+ dosym unieject /usr/bin/eject
+}