summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmDownload/wmDownload-0.1.2a.ebuild')
-rw-r--r--x11-plugins/wmDownload/wmDownload-0.1.2a.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/x11-plugins/wmDownload/wmDownload-0.1.2a.ebuild b/x11-plugins/wmDownload/wmDownload-0.1.2a.ebuild
index 28cc99d93498..6d28f45b444b 100644
--- a/x11-plugins/wmDownload/wmDownload-0.1.2a.ebuild
+++ b/x11-plugins/wmDownload/wmDownload-0.1.2a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmDownload/wmDownload-0.1.2a.ebuild,v 1.6 2003/10/16 16:10:23 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmDownload/wmDownload-0.1.2a.ebuild,v 1.7 2004/01/04 18:36:48 aliz Exp $
S=${WORKDIR}/wmDownload
@@ -14,21 +14,17 @@ KEYWORDS="x86 amd64"
DEPEND="virtual/glibc x11-base/xfree x11-libs/docklib"
-src_compile() {
-
- cd ${S}
-
- cp Makefile Makefile.orig
- sed -e "s:-O2:$CFLAGS:" Makefile.orig > Makefile
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ sed -i -e "s:-O2:$CFLAGS:" Makefile
+}
+src_compile() {
emake || die
-
}
src_install () {
-
strip wmDownload
dodir /usr/bin/
dobin wmDownload
-
}