From 77ce7c75923ec8cb5f93f32b27746bbc4e704106 Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Mon, 15 May 2006 20:50:24 +0000
Subject: Version bump to solve bugs #132555 (gcc4) and #86871 (interactive doc
 building. Package-Manager: portage-2.1_pre10-r5

---
 net-analyzer/ns/ChangeLog            |   7 +-
 net-analyzer/ns/files/digest-ns-2.29 |   3 +
 net-analyzer/ns/ns-2.29.ebuild       | 132 +++++++++++++++++++++++++++++++++++
 3 files changed, 141 insertions(+), 1 deletion(-)
 create mode 100644 net-analyzer/ns/files/digest-ns-2.29
 create mode 100644 net-analyzer/ns/ns-2.29.ebuild

(limited to 'net-analyzer')

diff --git a/net-analyzer/ns/ChangeLog b/net-analyzer/ns/ChangeLog
index ce7245d97c3c..c07dc1fc7783 100644
--- a/net-analyzer/ns/ChangeLog
+++ b/net-analyzer/ns/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for net-analyzer/ns
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ChangeLog,v 1.21 2006/03/29 13:18:32 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ChangeLog,v 1.22 2006/05/15 20:50:24 robbat2 Exp $
+
+*ns-2.29 (15 May 2006)
+
+  15 May 2006; Robin H. Johnson <robbat2@gentoo.org> +ns-2.29.ebuild:
+  Version bump to solve bugs #132555 (gcc4) and #86871 (interactive doc building.
 
   29 Mar 2006; Emanuele Giaquinta <exg@gentoo.org>
   +files/ns-2.28-gcc41.patch, ns-2.28.ebuild:
diff --git a/net-analyzer/ns/files/digest-ns-2.29 b/net-analyzer/ns/files/digest-ns-2.29
new file mode 100644
index 000000000000..43c50c33faea
--- /dev/null
+++ b/net-analyzer/ns/files/digest-ns-2.29
@@ -0,0 +1,3 @@
+MD5 4942fbdbc0179cdf2774778857c49ff0 ns-src-2.29.tar.gz 55291146
+RMD160 ff7b0b0cca62eb4f9657f913f56991f22fdfb5ce ns-src-2.29.tar.gz 55291146
+SHA256 cd78c0eafb4f6f170c3ff9a3e3eace5ff43d1f2abbcb5b18cac67bfe3624bcad ns-src-2.29.tar.gz 55291146
diff --git a/net-analyzer/ns/ns-2.29.ebuild b/net-analyzer/ns/ns-2.29.ebuild
new file mode 100644
index 000000000000..e513cb10a1a8
--- /dev/null
+++ b/net-analyzer/ns/ns-2.29.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ns-2.29.ebuild,v 1.1 2006/05/15 20:50:24 robbat2 Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Network Simulator"
+HOMEPAGE="http://www.isi.edu/nsnam/ns/"
+SRC_URI="http://www.isi.edu/nsnam/dist/${PN}-src-${PV}.tar.gz"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86 ~amd64"
+IUSE="doc debug"
+
+RDEPEND=">=dev-lang/tcl-8.4.5
+		>=dev-lang/tk-8.4.5
+		>=dev-tcltk/otcl-1.11
+		>=dev-tcltk/tclcl-1.17
+		virtual/libpcap
+		debug? ( 	=dev-lang/perl-5*
+					>=sci-visualization/xgraph-12.1
+					>=dev-libs/dmalloc-4.8.2
+					>=dev-tcltk/tcl-debug-2.0 )"
+DEPEND="${RDEPEND}
+		doc? ( 	virtual/tetex
+				virtual/ghostscript
+				dev-tex/latex2html )"
+
+src_unpack() {
+	unpack ${A}
+	cd ${S}
+#	epatch ${FILESDIR}/${P}-gentoo.diff
+#	epatch ${FILESDIR}/${P}-gcc41.patch
+	sed '/$(CC)/s!-g!$(CFLAGS)!g' ${S}/indep-utils/model-gen/Makefile
+}
+
+src_compile() {
+	local myconf
+	local mytclver=""
+	local i
+
+	tc-export CC CXX
+
+	# correctness is more important than speed
+	replace-flags -Os -O2
+	replace-flags -O3 -O2
+
+	use debug \
+		&& myconf="${myconf} --with-tcldebug=/usr/lib/tcldbg2.0" \
+		|| myconf="${myconf} --with-tcldebug=no"
+	myconf="${myconf} $(use_with debug dmalloc)"
+
+	for i in 8.4 ; do
+		einfo "Testing TCL ${i}"
+		has_version "=dev-lang/tcl-${i}*" && mytclver=${i}
+		[ "${#mytclver}" -gt 2 ] && break
+	done
+	einfo "Using TCL ${mytclver}"
+	myconf="${myconf} --with-tcl-ver=${mytclver} --with-tk-ver=${mytclver}"
+
+	econf \
+		${myconf} \
+		--mandir=/usr/share/man \
+		--enable-stl \
+		--enable-release || die "./configure failed"
+	emake CCOPT="${CFLAGS}" || die
+
+	cd ${S}/indep-utils/dosdbell
+	emake DFLAGS="${CFLAGS}" || die
+	cd ${S}/indep-utils/dosreduce
+	${CC} ${CFLAGS} dosreduce.c -o dosreduce
+	cd ${S}/indep-utils/propagation
+	${CXX} ${CXXFLAGS} threshold.cc -o threshold
+	cd ${S}/indep-utils/model-gen
+	emake CFLAGS="${CFLAGS}" || die
+
+	if useq doc; then
+		einfo "Generating extra docs"
+		cd ${S}/doc
+		yes '' | emake all
+	fi
+}
+
+src_install() {
+	dodir /usr/bin /usr/share/man/man1 /usr/share/doc/${PF} /usr/share/ns
+	make DESTDIR="${D}" MANDEST=/usr/share/man install \
+		|| die "make install failed"
+	dobin nse
+
+	dodoc BASE-VERSION COPYRIGHTS FILES HOWTO-CONTRIBUTE README VERSION
+	dohtml CHANGES.html TODO.html
+
+	cd "${S}"
+	insinto /usr/share/doc/${PF}
+	doins -r ns-tutorial
+	insinto /usr/share/ns
+	doins -r tcl
+
+	cd "${S}/indep-utils/dosdbell"
+	dobin dosdbell dosdbellasim
+	newdoc README README.dosdbell
+	cd "${S}/indep-utils/dosreduce"
+	dobin dosreduce
+	newdoc README README.dosreduce
+	cd "${S}/indep-utils/cmu-scen-gen"
+	dobin cbrgen.tcl
+	newdoc README README.cbrgen
+	cd "${S}/indep-utils/propagation"
+	dobin threshold
+	cd "${S}/indep-utils/model-gen"
+	dobin http_connect http_active
+
+	if use doc; then
+		cd ${S}/doc
+		docinto doc
+		dodoc everything.dvi everything.ps.gz everything.html everything.pdf
+		docinto model-gen
+		cd ${S}/indep-utils/model-gen
+		dodoc *
+	fi
+}
+
+src_test() {
+	einfo "Warning, these tests will take upwards of 45 minutes."
+	einfo "Additionally, as shipped, a number of tests may fail."
+	einfo "We log to 'validate.run', which you should compare against"
+	einfo "the shipped 'validate.out' to evaluate success."
+	einfo "At the time of assembling this ebuild, these test suites failed:"
+	einfo "all-smac-multihop all-red all-plm all-wireless-tdma"
+	./validate 2>&1 | tee ${S}/validate.run
+}
-- 
cgit v1.2.3-65-gdbad