summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-02-05 01:48:44 +0100
committerPeter Alfredsen <loki_val@gentoo.org>2009-02-05 01:48:44 +0100
commita844c738c5f912b41f3ad49e885efa0f45f9d836 (patch)
tree1d747d0d2f9deb1963cb3a127cfee78adbd068ec
parentTemporarily drop tracing patch to make it build. (diff)
downloaddotnet-a844c738c5f912b41f3ad49e885efa0f45f9d836.tar.gz
dotnet-a844c738c5f912b41f3ad49e885efa0f45f9d836.tar.bz2
dotnet-a844c738c5f912b41f3ad49e885efa0f45f9d836.zip
Monsoon, MonoTorrent, Mono.Nat and NLog
-rw-r--r--dev-dotnet/mono-nat/Manifest5
-rw-r--r--dev-dotnet/mono-nat/files/mono-nat.pc.in8
-rw-r--r--dev-dotnet/mono-nat/files/mono.snkbin0 -> 596 bytes
-rw-r--r--dev-dotnet/mono-nat/metadata.xml5
-rw-r--r--dev-dotnet/mono-nat/mono-nat-1.0.ebuild40
-rw-r--r--dev-dotnet/monotorrent/Manifest5
-rw-r--r--dev-dotnet/monotorrent/files/mono.snkbin0 -> 596 bytes
-rw-r--r--dev-dotnet/monotorrent/files/monotorrent.pc.in8
-rw-r--r--dev-dotnet/monotorrent/metadata.xml5
-rw-r--r--dev-dotnet/monotorrent/monotorrent-0.70.ebuild47
-rw-r--r--dev-dotnet/nlog/Manifest5
-rw-r--r--dev-dotnet/nlog/files/nlog-1.0-build.patch29
-rw-r--r--dev-dotnet/nlog/files/nlog.pc.in8
-rw-r--r--dev-dotnet/nlog/metadata.xml5
-rw-r--r--dev-dotnet/nlog/nlog-1.0.ebuild53
-rw-r--r--net-p2p/monsoon/Manifest4
-rw-r--r--net-p2p/monsoon/files/monsoon-0.20-build.patch126
-rw-r--r--net-p2p/monsoon/metadata.xml5
-rw-r--r--net-p2p/monsoon/monsoon-0.20.ebuild39
19 files changed, 397 insertions, 0 deletions
diff --git a/dev-dotnet/mono-nat/Manifest b/dev-dotnet/mono-nat/Manifest
new file mode 100644
index 0000000..5a2e525
--- /dev/null
+++ b/dev-dotnet/mono-nat/Manifest
@@ -0,0 +1,5 @@
+AUX mono-nat.pc.in 159 RMD160 de5efebeeb059bdd1b7101a53f84e20e5af66d20 SHA1 e87063b2f5e09dd95900bcd1ae83820745c64fc6 SHA256 5a8a911bd21e5a79b5b5ba8e4ef0e2f5276e1d8200cf3f8fb57be6c1f2bb17ea
+AUX mono.snk 596 RMD160 bf19be5a57a300f1f54c8ab0466ec0b8532565f1 SHA1 9667c92d7c9009a6b7baf5815483ea8783d12581 SHA256 44a83944d57c37da4e7872967f1fd4b445af18cdcbe8d17a0e3f5e5ce553c78a
+DIST mono-nat-1.0.tar.gz 77772 RMD160 c525e652338462cc3232aa7590ce357921d3483e SHA1 9c4353becd1f4cc1cba104292d90058f10f67ba2 SHA256 dfb857450e14a7312c6ecd309e2b3d60c002fe41fe8cba7b1c0137057d76027e
+EBUILD mono-nat-1.0.ebuild 1126 RMD160 f3c0f1fb521d46ec73c01b5c5da586898c26a7d3 SHA1 1efd245bf88b66e4c79547c53c13c5ce746c916d SHA256 fa5174aabee514ce68275134b636a335bbb01598b8a35267f8899a79301e605f
+MISC metadata.xml 160 RMD160 cc10b170ad63a746d8bdfbe5bf1bd9f7065922b8 SHA1 49eaf4246f7502850064d3806cce65d3a404ce1b SHA256 1bc3e313a948415fff0dfa63a5610943327146bfe16bfeca603379bf9706a687
diff --git a/dev-dotnet/mono-nat/files/mono-nat.pc.in b/dev-dotnet/mono-nat/files/mono-nat.pc.in
new file mode 100644
index 0000000..33d48a8
--- /dev/null
+++ b/dev-dotnet/mono-nat/files/mono-nat.pc.in
@@ -0,0 +1,8 @@
+prefix=${pcfiledir}/../..
+exec_prefix=${prefix}
+libdir=${exec_prefix}/@LIBDIR@
+
+Name: @PACKAGENAME@
+Description: @DESCRIPTION@
+Version: @VERSION@
+Libs: @LIBS@
diff --git a/dev-dotnet/mono-nat/files/mono.snk b/dev-dotnet/mono-nat/files/mono.snk
new file mode 100644
index 0000000..380116c
--- /dev/null
+++ b/dev-dotnet/mono-nat/files/mono.snk
Binary files differ
diff --git a/dev-dotnet/mono-nat/metadata.xml b/dev-dotnet/mono-nat/metadata.xml
new file mode 100644
index 0000000..e01adbb
--- /dev/null
+++ b/dev-dotnet/mono-nat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/mono-nat/mono-nat-1.0.ebuild b/dev-dotnet/mono-nat/mono-nat-1.0.ebuild
new file mode 100644
index 0000000..7350862
--- /dev/null
+++ b/dev-dotnet/mono-nat/mono-nat-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit mono multilib
+
+MY_PN=Mono.Nat
+
+DESCRIPTION="Mono.Nat is a C# library used for automatic port forwarding, using either uPnP or nat-pmp."
+HOMEPAGE="http://www.monotorrent.com/"
+SRC_URI="http://monotorrent.com/Files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=""
+DEPEND=">=dev-util/pkgconfig-0.23"
+
+src_compile() {
+ emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs -keyfile:${FILESDIR}/mono.snk"
+}
+
+src_install() {
+ egacinstall $(find . -name "Mono.Nat.dll")
+ dodir /usr/$(get_libdir)/pkgconfig
+ ebegin "Installing .pc file"
+ sed \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PACKAGENAME@:${MY_PN}:" \
+ -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
+ -e "s:@VERSION@:${PV}:" \
+ -e 's;@LIBS@;-r:${libdir}/mono/mono-nat/Mono.Nat.dll;' \
+ "${FILESDIR}"/${PN}.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/mono.nat.pc \
+ || die "sed failed"
+ PKG_CONFIG_PATH="${D}/usr/lib64/pkgconfig/" pkg-config --exists monotorrent || die ".pc file failed to validate."
+ eend $?
+}
diff --git a/dev-dotnet/monotorrent/Manifest b/dev-dotnet/monotorrent/Manifest
new file mode 100644
index 0000000..29a5e36
--- /dev/null
+++ b/dev-dotnet/monotorrent/Manifest
@@ -0,0 +1,5 @@
+AUX mono.snk 596 RMD160 bf19be5a57a300f1f54c8ab0466ec0b8532565f1 SHA1 9667c92d7c9009a6b7baf5815483ea8783d12581 SHA256 44a83944d57c37da4e7872967f1fd4b445af18cdcbe8d17a0e3f5e5ce553c78a
+AUX monotorrent.pc.in 159 RMD160 de5efebeeb059bdd1b7101a53f84e20e5af66d20 SHA1 e87063b2f5e09dd95900bcd1ae83820745c64fc6 SHA256 5a8a911bd21e5a79b5b5ba8e4ef0e2f5276e1d8200cf3f8fb57be6c1f2bb17ea
+DIST monotorrent-0.70.tar.gz 268345 RMD160 d81d09585ba57c7d3d54b4d7e28cfe548bce1d96 SHA1 137b0391137ee4d592f2c9f3adb1311d77032486 SHA256 1d80f86afd1e8670d08bd8c4cad8c4b7b2c23bdc0e87efdae04c731e98f129ff
+EBUILD monotorrent-0.70.ebuild 1250 RMD160 211224a1a51ceabc3e1e4ff586181795303eb062 SHA1 0a5bed8441833a0c156e372e42ae626e69efa63c SHA256 90001b01f00b5f08b192091479acaebb25cecbc2390c065cb29f2a11c3e2648b
+MISC metadata.xml 160 RMD160 cc10b170ad63a746d8bdfbe5bf1bd9f7065922b8 SHA1 49eaf4246f7502850064d3806cce65d3a404ce1b SHA256 1bc3e313a948415fff0dfa63a5610943327146bfe16bfeca603379bf9706a687
diff --git a/dev-dotnet/monotorrent/files/mono.snk b/dev-dotnet/monotorrent/files/mono.snk
new file mode 100644
index 0000000..380116c
--- /dev/null
+++ b/dev-dotnet/monotorrent/files/mono.snk
Binary files differ
diff --git a/dev-dotnet/monotorrent/files/monotorrent.pc.in b/dev-dotnet/monotorrent/files/monotorrent.pc.in
new file mode 100644
index 0000000..33d48a8
--- /dev/null
+++ b/dev-dotnet/monotorrent/files/monotorrent.pc.in
@@ -0,0 +1,8 @@
+prefix=${pcfiledir}/../..
+exec_prefix=${prefix}
+libdir=${exec_prefix}/@LIBDIR@
+
+Name: @PACKAGENAME@
+Description: @DESCRIPTION@
+Version: @VERSION@
+Libs: @LIBS@
diff --git a/dev-dotnet/monotorrent/metadata.xml b/dev-dotnet/monotorrent/metadata.xml
new file mode 100644
index 0000000..e01adbb
--- /dev/null
+++ b/dev-dotnet/monotorrent/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/monotorrent/monotorrent-0.70.ebuild b/dev-dotnet/monotorrent/monotorrent-0.70.ebuild
new file mode 100644
index 0000000..fe469d8
--- /dev/null
+++ b/dev-dotnet/monotorrent/monotorrent-0.70.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="Monotorrent is an open source C# bittorrent library"
+HOMEPAGE="http://www.monotorrent.com/"
+SRC_URI="http://monotorrent.com/Files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=""
+DEPEND=">=dev-util/pkgconfig-0.23"
+
+# The hack we do to get the dll installed in the GAC makes the unit-tests
+# defunct.
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e "/InternalsVisibleTo/d" \
+ MonoTorrent/AssemblyInfo.cs* || die
+}
+
+src_compile() {
+ emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs -keyfile:${FILESDIR}/mono.snk"
+}
+
+src_install() {
+ egacinstall $(find . -name "MonoTorrent.dll")
+ dodir /usr/$(get_libdir)/pkgconfig
+ ebegin "Installing .pc file"
+ sed \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PACKAGENAME@:${PN}:" \
+ -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
+ -e "s:@VERSION@:${PV}:" \
+ -e 's;@LIBS@;-r:${libdir}/mono/monotorrent/MonoTorrent.dll;' \
+ "${FILESDIR}"/${PN}.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${PN}.pc
+ PKG_CONFIG_PATH="${D}/usr/lib64/pkgconfig/" pkg-config --exists monotorrent || die ".pc file failed to validate."
+ eend $?
+}
diff --git a/dev-dotnet/nlog/Manifest b/dev-dotnet/nlog/Manifest
new file mode 100644
index 0000000..f86165e
--- /dev/null
+++ b/dev-dotnet/nlog/Manifest
@@ -0,0 +1,5 @@
+AUX nlog-1.0-build.patch 1768 RMD160 fc326888c61cddd4f64ea372a6f6255453c6ef6c SHA1 9ed51e38507bcb07aefa7b9a0219b4e475f1733f SHA256 6594cd8cad7c05e97811a5f66bb384c11bf35447242562c65b463d09ace76170
+AUX nlog.pc.in 159 RMD160 de5efebeeb059bdd1b7101a53f84e20e5af66d20 SHA1 e87063b2f5e09dd95900bcd1ae83820745c64fc6 SHA256 5a8a911bd21e5a79b5b5ba8e4ef0e2f5276e1d8200cf3f8fb57be6c1f2bb17ea
+DIST nlog-1.0-src.zip 1516261 RMD160 9c492a9595c8417fbee88bd18bfa7d04fbacd531 SHA1 e4d9e425061a2fd216fc0fee3037f0b552fa612b SHA256 e8a27e1bbac86d65a1ec3fe6cdcbf478df34865aa412d4cc5d951ed1e78d0957
+EBUILD nlog-1.0.ebuild 1323 RMD160 f49b61523942995d05b413ac6ee600777d51dda6 SHA1 28f305105e10496e50701a6b1f0d49c9d164340f SHA256 f7e38b510678439d2cad84af1fbcb39c8112ca73ffbc3dad89ef123b7af049a9
+MISC metadata.xml 160 RMD160 cc10b170ad63a746d8bdfbe5bf1bd9f7065922b8 SHA1 49eaf4246f7502850064d3806cce65d3a404ce1b SHA256 1bc3e313a948415fff0dfa63a5610943327146bfe16bfeca603379bf9706a687
diff --git a/dev-dotnet/nlog/files/nlog-1.0-build.patch b/dev-dotnet/nlog/files/nlog-1.0-build.patch
new file mode 100644
index 0000000..bbfdd87
--- /dev/null
+++ b/dev-dotnet/nlog/files/nlog-1.0-build.patch
@@ -0,0 +1,29 @@
+diff -NrU5 NLog-1.0.orig/NLog.build NLog-1.0/NLog.build
+--- NLog-1.0.orig/NLog.build 2009-02-04 22:22:45.000000000 +0100
++++ NLog-1.0/NLog.build 2009-02-04 22:25:03.000000000 +0100
+@@ -148,11 +148,11 @@
+
+ <property name="nlog.version" value="${nlog.version.major}.${nlog.version.minor}.${nlog.version.revision}.${nlog.version.build}" />
+ </target>
+
+ <target name="NLog" depends="configure, update-build-number">
+- <csc target="library" output="${nlog.dir}/NLog.dll" doc="${nlog.dir}/NLog.xml" define="${nlog.define}" debug="${nlog.debug}" optimize="${nlog.optimize}" warninglevel="${csc.warninglevel}" warnaserror="true">
++ <csc target="library" output="${nlog.dir}/NLog.dll" doc="${nlog.dir}/NLog.xml" define="${nlog.define}" debug="${nlog.debug}" optimize="${nlog.optimize}" warninglevel="${csc.warninglevel}" warnaserror="false">
+ <sources basedir="src">
+ <include name="NLog/**/*.cs" />
+ </sources>
+ <references>
+ <include name="mscorlib.dll" />
+@@ -719,11 +719,11 @@
+ <namespaces>
+ <namespace prefix="ms" uri="urn:schemas-microsoft-com:asm.v1" />
+ </namespaces>
+ </xmlpoke>
+
+- <exec program="${path::combine(framework::get-framework-directory(framework::get-target-framework()),'al')}"
++ <exec program="/usr/bin/al"
+ commandline="/nologo /link:Policy.${nlog.version.major}.${nlog.version.minor}.NLog.xml /out:Policy.${nlog.version.major}.${nlog.version.minor}.NLog.dll /keyfile:${path::combine(project::get-base-directory(),'src/NLog.snk')} /version:1.0.0.0"
+ workingdir="${nlog.dir}" />
+ </if>
+ </target>
+
diff --git a/dev-dotnet/nlog/files/nlog.pc.in b/dev-dotnet/nlog/files/nlog.pc.in
new file mode 100644
index 0000000..33d48a8
--- /dev/null
+++ b/dev-dotnet/nlog/files/nlog.pc.in
@@ -0,0 +1,8 @@
+prefix=${pcfiledir}/../..
+exec_prefix=${prefix}
+libdir=${exec_prefix}/@LIBDIR@
+
+Name: @PACKAGENAME@
+Description: @DESCRIPTION@
+Version: @VERSION@
+Libs: @LIBS@
diff --git a/dev-dotnet/nlog/metadata.xml b/dev-dotnet/nlog/metadata.xml
new file mode 100644
index 0000000..e01adbb
--- /dev/null
+++ b/dev-dotnet/nlog/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/nlog/nlog-1.0.ebuild b/dev-dotnet/nlog/nlog-1.0.ebuild
new file mode 100644
index 0000000..6b957db
--- /dev/null
+++ b/dev-dotnet/nlog/nlog-1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+MY_PN=NLog
+MY_P=${MY_PN}-${PV}
+
+inherit mono multilib eutils
+
+DESCRIPTION="NLog is a .NET logging library designed with simplicity and flexibility in mind."
+HOMEPAGE="http://www.nlog-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=""
+DEPEND=">=dev-util/pkgconfig-0.23
+ app-arch/unzip
+ dev-dotnet/nant"
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+}
+
+src_compile() {
+ nant -t:mono-2.0 -D:warnaserror=false || die "Nant build failed"
+}
+
+src_install() {
+ for dll in $(find build -name "*.dll")
+ do
+ pushd $(dirname ${dll}) &> /dev/null
+ egacinstall ${dll##*/}
+ popd &> /dev/null
+ done
+ dodir /usr/$(get_libdir)/pkgconfig
+ ebegin "Installing .pc file"
+ sed \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PACKAGENAME@:${MY_PN}:" \
+ -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
+ -e "s:@VERSION@:${PV}:" \
+ -e 's;@LIBS@;-r:${libdir}/mono/nlog/NLog.dll;' \
+ "${FILESDIR}"/${PN}.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${PN}.pc
+ PKG_CONFIG_PATH="${D}/usr/lib64/pkgconfig/" pkg-config --exists ${PN} || die ".pc file failed to validate."
+ eend $?
+ dodoc README.txt || die "dodoc failed"
+}
diff --git a/net-p2p/monsoon/Manifest b/net-p2p/monsoon/Manifest
new file mode 100644
index 0000000..f61ccf3
--- /dev/null
+++ b/net-p2p/monsoon/Manifest
@@ -0,0 +1,4 @@
+AUX monsoon-0.20-build.patch 4266 RMD160 ff18adc7e8ac1bc4aed24a8fc03a7efd8a7a0eff SHA1 9c3171f3d57d4e26261f7190fb23cf69ed35f04c SHA256 c39559fdd82b14757b5932fb2f44fc8ec945cdcba96b0225f4895247c879003e
+DIST monsoon-0.20.tar.gz 540409 RMD160 e9068436d5afe4231ad8adc75a179bbf7080de53 SHA1 dc89d0539a91ec43524efd812a07b21e2b1130fc SHA256 ef113daf0e0238868c2c0c6de50060f003b339624930da48e3c4dd597e622641
+EBUILD monsoon-0.20.ebuild 899 RMD160 dfeaed7b9094485a076eae9c6a3edcb9acb85841 SHA1 b4eeb1063cbdfeecc2dc59a4a5ce8db45f9bc564 SHA256 9d27476d715961e5afb31de9a1bb391b2a2eec2cb6268db39b70bde2d13707c4
+MISC metadata.xml 160 RMD160 cc10b170ad63a746d8bdfbe5bf1bd9f7065922b8 SHA1 49eaf4246f7502850064d3806cce65d3a404ce1b SHA256 1bc3e313a948415fff0dfa63a5610943327146bfe16bfeca603379bf9706a687
diff --git a/net-p2p/monsoon/files/monsoon-0.20-build.patch b/net-p2p/monsoon/files/monsoon-0.20-build.patch
new file mode 100644
index 0000000..b58a93f
--- /dev/null
+++ b/net-p2p/monsoon/files/monsoon-0.20-build.patch
@@ -0,0 +1,126 @@
+diff -NrU5 monsoon-0.20.orig/Monsoon/Makefile.am monsoon-0.20/Monsoon/Makefile.am
+--- monsoon-0.20.orig/Monsoon/Makefile.am 2009-02-05 00:41:06.000000000 +0100
++++ monsoon-0.20/Monsoon/Makefile.am 2009-02-05 00:53:41.000000000 +0100
+@@ -1,7 +1,6 @@
+-
+-EXTRA_DIST = $(NLOG_DLL_SOURCE)
++EXTRA_DIST =
+
+ # Warning: This is an automatically generated file, do not edit!
+
+ if ENABLE_DEBUG
+ ASSEMBLY_COMPILER_COMMAND = gmcs
+@@ -19,11 +18,10 @@
+ RSS_PNG_SOURCE=icons/rss.png
+ LOWEST_PNG_SOURCE=icons/lowest.png
+ MONSOON_DESKTOP_SOURCE=monsoon.desktop
+ DONOTDOWNLOAD_PNG_SOURCE=icons/donotdownload.png
+ NORMAL_PNG_SOURCE=icons/normal.png
+-NLOG_DLL_SOURCE=NLog.dll
+ LOW_PNG_SOURCE=icons/low.png
+
+ endif
+
+ if ENABLE_RELEASE
+@@ -42,25 +40,19 @@
+ RSS_PNG_SOURCE=icons/rss.png
+ LOWEST_PNG_SOURCE=icons/lowest.png
+ MONSOON_DESKTOP_SOURCE=monsoon.desktop
+ DONOTDOWNLOAD_PNG_SOURCE=icons/donotdownload.png
+ NORMAL_PNG_SOURCE=icons/normal.png
+-NLOG_DLL_SOURCE=NLog.dll
+ LOW_PNG_SOURCE=icons/low.png
+
+ endif
+
+ AL=al2
+ SATELLITE_ASSEMBLY_NAME=.resources.dll
+
+-UNSTABLE_LIBS = ./libs/MonoTorrent.dll \
+- ./libs/Mono.Nat.dll
+-
+ PROGRAMFILES = \
+- $(MONSOON_EXE_CONFIG) \
+- $(NLOG_DLL) \
+- $(UNSTABLE_LIBS)
++ $(MONSOON_EXE_CONFIG)
+
+ LINUX_DESKTOPAPPLICATIONS = \
+ $(MONSOON_DESKTOP)
+
+ PROGRAMFILES_ICONS = \
+@@ -76,22 +68,11 @@
+ BINARIES = \
+ $(MONSOON)
+
+
+
+-all: update-libs $(ASSEMBLY) $(PROGRAMFILES) $(LINUX_DESKTOPAPPLICATIONS) $(PROGRAMFILES_ICONS) $(BINARIES)
+- cp ./libs/MonoTorrent.dll ./bin/Release/MonoTorrent.dll
+- cp ./libs/Mono.Nat.dll ./bin/Release/Mono.Nat.dll
+-
+-./libs/Mono.Nat.dll: update-libs
+-./libs/MonoTorrent.dll: update-libs
+-
+-update-libs:
+- mkdir -p ./libs
+- cp `pkg-config --variable=Libraries monotorrent` ./libs/MonoTorrent.dll
+- cp `pkg-config --variable=Libraries mono.nat` ./libs/Mono.Nat.dll
+-
++all: $(ASSEMBLY) $(PROGRAMFILES) $(LINUX_DESKTOPAPPLICATIONS) $(PROGRAMFILES_ICONS) $(BINARIES)
+
+ FILES = \
+ AboutDialog.cs \
+ AssemblyInfo.cs \
+ ByteConverter.cs \
+@@ -184,16 +165,11 @@
+ Mono.Posix \
+ $(GCONF_SHARP_20_LIBS) \
+ $(GTK_SHARP_20_LIBS) \
+ $(GLIB_SHARP_20_LIBS)
+
+-DLL_REFERENCES = \
+- $(NLOG_DLL) \
+- ./libs/Mono.Nat.dll \
+- ./libs/MonoTorrent.dll
+-
+-CLEANFILES = $(PROGRAMFILES) $(LINUX_DESKTOPAPPLICATIONS) $(PROGRAMFILES_ICONS) $(BINARIES) $(UNSTABLE_LIBS)
++CLEANFILES = $(PROGRAMFILES) $(LINUX_DESKTOPAPPLICATIONS) $(PROGRAMFILES_ICONS) $(BINARIES)
+
+ include $(top_srcdir)/Makefile.include
+
+ MONSOON_EXE_CONFIG = $(BUILD_DIR)/Monsoon.exe.config
+ HIGH_PNG = $(BUILD_DIR)/icons/high.png
+@@ -203,11 +179,10 @@
+ LOWEST_PNG = $(BUILD_DIR)/icons/lowest.png
+ MONSOON_DESKTOP = $(BUILD_DIR)/monsoon.desktop
+ DONOTDOWNLOAD_PNG = $(BUILD_DIR)/icons/donotdownload.png
+ MONSOON = $(BUILD_DIR)/monsoon
+ NORMAL_PNG = $(BUILD_DIR)/icons/normal.png
+-NLOG_DLL = $(BUILD_DIR)/NLog.dll
+ LOW_PNG = $(BUILD_DIR)/icons/low.png
+
+ $(eval $(call emit-deploy-target,MONSOON_EXE_CONFIG))
+ $(eval $(call emit-deploy-target,HIGH_PNG))
+ $(eval $(call emit-deploy-target,HIGHEST_PNG))
+@@ -216,18 +191,17 @@
+ $(eval $(call emit-deploy-target,LOWEST_PNG))
+ $(eval $(call emit-deploy-target,MONSOON_DESKTOP))
+ $(eval $(call emit-deploy-target,DONOTDOWNLOAD_PNG))
+ $(eval $(call emit-deploy-wrapper,MONSOON,monsoon,x))
+ $(eval $(call emit-deploy-target,NORMAL_PNG))
+-$(eval $(call emit-deploy-target,NLOG_DLL))
+ $(eval $(call emit-deploy-target,LOW_PNG))
+
+
+ $(build_xamlg_list): %.xaml.g.cs: %.xaml
+ xamlg '$<'
+
+ $(build_resx_resources) : %.resources: %.resx
+ resgen2 '$<' '$@'
+
+-$(ASSEMBLY) $(ASSEMBLY_MDB): $(build_sources) $(build_resources) $(build_datafiles) $(DLL_REFERENCES) $(PROJECT_REFERENCES) $(build_xamlg_list) $(build_satellite_assembly_list)
++$(ASSEMBLY) $(ASSEMBLY_MDB): $(build_sources) $(build_resources) $(build_datafiles) $(PROJECT_REFERENCES) $(build_xamlg_list) $(build_satellite_assembly_list)
+ mkdir -p $(dir $(ASSEMBLY))
+- $(ASSEMBLY_COMPILER_COMMAND) $(ASSEMBLY_COMPILER_FLAGS) -out:$(ASSEMBLY) -target:$(COMPILE_TARGET) $(build_sources_embed) $(build_resources_embed) $(build_references_ref)
++ $(ASSEMBLY_COMPILER_COMMAND) $(ASSEMBLY_COMPILER_FLAGS) -out:$(ASSEMBLY) -target:$(COMPILE_TARGET) $(build_sources_embed) $(build_resources_embed) $(build_references_ref) -pkg:mono.nat -pkg:monotorrent -pkg:nlog
diff --git a/net-p2p/monsoon/metadata.xml b/net-p2p/monsoon/metadata.xml
new file mode 100644
index 0000000..e01adbb
--- /dev/null
+++ b/net-p2p/monsoon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/net-p2p/monsoon/monsoon-0.20.ebuild b/net-p2p/monsoon/monsoon-0.20.ebuild
new file mode 100644
index 0000000..cc6f894
--- /dev/null
+++ b/net-p2p/monsoon/monsoon-0.20.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit mono multilib autotools
+
+DESCRIPTION="Monosoon is an open source Gtk# bittorrent client"
+HOMEPAGE="http://www.monsoon-project.org/"
+SRC_URI="http://monotorrent.com/Files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=">=dev-dotnet/monotorrent-0.70
+ >=dev-dotnet/mono-nat-1.0
+ >=dev-dotnet/nlog-1.0"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+
+#This sucks, but the install process is screwed up if it's set.
+unset LINGUAS
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+ eautoreconf
+}
+
+src_compile() {
+ emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ sed -i -e "s;@expanded_libdir@;/usr/$(get_libdir);" \
+ "${D}/usr/bin/monsoon" || die "Fixing monsoon failed."
+}