aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-03-17 11:48:09 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-03-17 11:48:09 +0100
commit71febc0ec7dbd8c32c8a0425f30b37d583f98cc6 (patch)
treef9405944ee188ca229c42a4e60e43fca92aaafaf /media-gfx
parentgames-engines/luxtorpeda: cleanup old version (diff)
downloadguru-71febc0ec7dbd8c32c8a0425f30b37d583f98cc6.tar.gz
guru-71febc0ec7dbd8c32c8a0425f30b37d583f98cc6.tar.bz2
guru-71febc0ec7dbd8c32c8a0425f30b37d583f98cc6.zip
media-gfx/glimpse: Fix configure error with autoconf-2.70.
Closes: https://bugs.gentoo.org/776679 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/glimpse/files/glimpse-0.2.0_fix_autoconf-2.70.patch58
-rw-r--r--media-gfx/glimpse/glimpse-0.2.0.ebuild4
2 files changed, 60 insertions, 2 deletions
diff --git a/media-gfx/glimpse/files/glimpse-0.2.0_fix_autoconf-2.70.patch b/media-gfx/glimpse/files/glimpse-0.2.0_fix_autoconf-2.70.patch
new file mode 100644
index 000000000..732cd9381
--- /dev/null
+++ b/media-gfx/glimpse/files/glimpse-0.2.0_fix_autoconf-2.70.patch
@@ -0,0 +1,58 @@
+From cebeb90a87105cd6e35bcb357d53cc04c828ca21 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sun, 25 Oct 2020 18:09:21 +0000
+Subject: [PATCH] configure.ac: fix `--with-linux-input` handling with upcoming
+ autoconf-2.70
+
+Upcoming autoconf-2.70 exposes deficiency in configure.ac:
+
+```
+$ autoconf-2.70_beta2 && ./configure --host=x86_64-pc-linux-gnu
+./configure: line 1430: 5: Bad file descriptor
+checking whether is declared... ./configure: line 1432: ${+y}: bad
+```
+
+It happens because macros are called with parameters using insufficient quoting.
+
+More details at https://lists.gnu.org/archive/html/bug-autoconf/2020-10/msg00027.html
+
+The fix only amends `--with-linux-input`. Other cases of underquoting
+will need to be handled separately.
+
+Fix-by: Zack Weinberg
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ configure.ac | 17 ++++++++---------
+ 1 file changed, 8 insertions(+), 9 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 96312f706e..63b85be07a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2135,15 +2135,14 @@ fi
+ AC_ARG_WITH(linux-input, [ --without-linux-input don't build linux input event controller module])
+
+ have_linux_input="no (linux input support disabled)"
+-if test "x$with_linux_input" != "xno"; then
+- AC_CHECK_HEADER(linux/input.h,
+- AC_CHECK_DECL(KEY_OK,
+- have_linux_input=yes,
+- have_linux_input="no (needs Linux 2.6)",
+- [#include <linux/input.h>]))
+-fi
+-
+-AM_CONDITIONAL(HAVE_LINUX_INPUT, test "x$have_linux_input" = xyes)
++AS_IF([test "x$with_linux_input" != "xno"],
++ [AC_CHECK_HEADER([linux/input.h],
++ [AC_CHECK_DECL([KEY_OK],
++ [have_linux_input=yes],
++ [have_linux_input="no (needs Linux 2.6)"],
++ [#include <linux/input.h>])])])
++
++AM_CONDITIONAL([HAVE_LINUX_INPUT], [test "x$have_linux_input" = xyes])
+
+
+ ###############################
+--
+GitLab
+
diff --git a/media-gfx/glimpse/glimpse-0.2.0.ebuild b/media-gfx/glimpse/glimpse-0.2.0.ebuild
index 0057314ee..47f619d2e 100644
--- a/media-gfx/glimpse/glimpse-0.2.0.ebuild
+++ b/media-gfx/glimpse/glimpse-0.2.0.ebuild
@@ -91,9 +91,9 @@ BDEPEND="
DOCS=( "AUTHORS" "HACKING.md" "NEWS" "README.md" )
-# Bug 685210 (and duplicate bug #691070)
PATCHES=(
- "${FILESDIR}/${PN}-0.2_fix_test-appdata.patch"
+ "${FILESDIR}/${PN}-0.2_fix_test-appdata.patch" # Bug 685210, bug #691070
+ "${FILESDIR}/${PN}-0.2.0_fix_autoconf-2.70.patch" # Bug #776679
)
src_prepare() {