From b73034e322f59b6838f6d8f47b0b3c5812946679 Mon Sep 17 00:00:00 2001
From: Sergey Torokhov <torokhov-s-a@yandex.ru>
Date: Mon, 15 Mar 2021 00:43:31 +0300
Subject: dev-vcs/lazygit: 0.26.1 version bump

Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
---
 dev-vcs/lazygit/Manifest              |  1 +
 dev-vcs/lazygit/lazygit-0.26.1.ebuild | 36 +++++++++++++++++++++++++++++++++++
 2 files changed, 37 insertions(+)
 create mode 100644 dev-vcs/lazygit/lazygit-0.26.1.ebuild

(limited to 'dev-vcs/lazygit')

diff --git a/dev-vcs/lazygit/Manifest b/dev-vcs/lazygit/Manifest
index b65fea96a..585d0afe7 100644
--- a/dev-vcs/lazygit/Manifest
+++ b/dev-vcs/lazygit/Manifest
@@ -1,3 +1,4 @@
 DIST lazygit-0.23.7.tar.gz 2144614 BLAKE2B d18aaa19212ec9e6ed7d3b406d3e1f6413f6c15bf6a8c7c99cb8a2b01b9388db3f1ad04c485782e0823415cec3c6b461cf942583ef0ac744cb18270c8fc943b1 SHA512 ffc827a08a3ba99afa339cee48b9e10267bc4aa27592d43ec1e4be80a7b4f9e628f286b50a1940a59a5cfa96121de6ce4247ec91642a8798dba8ca42232596b9
 DIST lazygit-0.24.2.tar.gz 2155627 BLAKE2B 6ed6c44590f0585935ebdb8374ba7649df84092cf752b17f3ab0791f55eb8516de9530fbc18891aeb9acfb1b743804df87c679f8cebabcbd353d563e23cacd5a SHA512 f380dec647384f0084c4c13b8ca43a8d97411c83c4c66ef02645c785054b3a7e2210d5a1ce98676c6d190beccf51f21ecd38851598f7652ff087ac73addbd097
 DIST lazygit-0.25.1.tar.gz 2192584 BLAKE2B e2254ea3998f8be17f0c75d328975b30af21e1eddc070e6e1c2711b54e8a7e1a4f24d91a0eb80451480547d26c9b01ac23e43ea73d59cc4a6bcc158992c73987 SHA512 281a0e67b75c6dc69baf64bbcaeb20844874528564093ae2c64159d1c92eaaaebf73a176730fb80db9a2055cfcdd2c8ba77a12566ef94c182eb5ef16e2d677b9
+DIST lazygit-0.26.1.tar.gz 2192018 BLAKE2B 9c48e6d0ee176ed1a49a684c4ad65ba139329c690af654508e866b6213ab3572d7f47915d849a0e65242f57b552568e1a34825a8050cd42e864d6b25f2e36559 SHA512 abdc8cfc509c77e4b7a249a32a000f3f80e9e5c11d26b48c3882fc49e9da1e477573590a16fa9c03ccb81d6342173f4abfa16031392d8180e7ca70071d503b3a
diff --git a/dev-vcs/lazygit/lazygit-0.26.1.ebuild b/dev-vcs/lazygit/lazygit-0.26.1.ebuild
new file mode 100644
index 000000000..233a104b0
--- /dev/null
+++ b/dev-vcs/lazygit/lazygit-0.26.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/jesseduffield/lazygit"
+
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Lazygit, a simple terminal UI for git commands"
+HOMEPAGE="https://github.com/jesseduffield/lazygit"
+SRC_URI="https://github.com/jesseduffield/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=( sys-libs/glibc )
+RDEPEND=(
+	${DEPEND}
+	dev-vcs/git
+)
+
+DOCS=( src/${EGO_PN}/{CONTRIBUTING,README}.md )
+
+src_compile() {
+	GOPATH="${S}" go build -v -o bin/lazygit src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+	dobin bin/lazygit
+
+	use doc && dodoc -r "src/${EGO_PN}/docs/."
+	einstalldocs
+}
-- 
cgit v1.2.3-65-gdbad