aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-21 23:20:23 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-21 23:20:23 +0100
commite40e5c14b3e7ecdabd4e33b42c800a0ab17369c3 (patch)
tree528e344c9ee79b97182e37a14bfa8c612f2c18b9 /dev-perl
parentnet-libs/nodejs: drop to EAPI=5 (diff)
downloadlibressl-e40e5c14b3e7ecdabd4e33b42c800a0ab17369c3.tar.gz
libressl-e40e5c14b3e7ecdabd4e33b42c800a0ab17369c3.tar.bz2
libressl-e40e5c14b3e7ecdabd4e33b42c800a0ab17369c3.zip
dev-perl/Crypt-SSLeay: Equivalent ebuild added to main tree
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild47
-rw-r--r--dev-perl/Crypt-SSLeay/Manifest1
-rw-r--r--dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch40
-rw-r--r--dev-perl/Crypt-SSLeay/metadata.xml19
4 files changed, 0 insertions, 107 deletions
diff --git a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild
deleted file mode 100644
index d95d588..0000000
--- a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-MODULE_AUTHOR=NANIS
-MODULE_VERSION=0.72
-inherit eutils perl-module
-
-DESCRIPTION="OpenSSL support for LWP"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="libressl test"
-
-RDEPEND="
- !libressl? ( >=dev-libs/openssl-0.9.7c:0 )
- libressl? ( dev-libs/libressl )
- virtual/perl-MIME-Base64
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- >=virtual/perl-ExtUtils-CBuilder-0.280.205
- virtual/perl-Getopt-Long
- >=dev-perl/Path-Class-0.260.0
- >=dev-perl/Try-Tiny-0.190.0
- test? (
- >=virtual/perl-Test-Simple-0.190.0
- )
-"
-# PDEPEND: circular dependencies bug #144761
-PDEPEND="
- dev-perl/libwww-perl
- >=dev-perl/LWP-Protocol-https-6.20.0
-"
-
-src_prepare() {
- # Fix for LibreSSL >= 2.3.0
- epatch "${FILESDIR}"/${PN}-0.720.0-no-ssl3.patch
-}
-
-export OPTIMIZE="${CFLAGS}"
-#myconf="--lib=${EPREFIX}/usr"
-
-SRC_TEST=do
diff --git a/dev-perl/Crypt-SSLeay/Manifest b/dev-perl/Crypt-SSLeay/Manifest
deleted file mode 100644
index 4d1dfcc..0000000
--- a/dev-perl/Crypt-SSLeay/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Crypt-SSLeay-0.72.tar.gz 129575 SHA256 f5d34f813677829857cf8a0458623db45b4d9c2311daaebe446f9e01afa9ffe8 SHA512 af7a2878df94e116e9aad9a0f028f2e4f89074aaf31672915162f86e55211632d65c1cb00f3ebd25644d77adf8eecdd244dba6a004d93ab90289ab34fe4caaf4 WHIRLPOOL 9a6adb48d3c54b9242473a3c0585f7cf29ec5ef518e5826477778e3b0a2ce96785afc490af3bcb1b7499fc00f4fc6c032c73c3baa72aff37ce0cf18c51c1250a
diff --git a/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch b/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch
deleted file mode 100644
index 75c5e21..0000000
--- a/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- SSLeay.xs.orig 2014-04-24 07:36:24.000000000 +0000
-+++ SSLeay.xs 2015-12-27 13:39:05.695422091 +0000
-@@ -45,13 +45,6 @@
- }
- #endif
-
--
--#if SSLEAY_VERSION_NUMBER >= 0x0900
--#define CRYPT_SSL_CLIENT_METHOD SSLv3_client_method()
--#else
--#define CRYPT_SSL_CLIENT_METHOD SSLv2_client_method()
--#endif
--
- static void InfoCallback(const SSL *s,int where,int ret)
- {
- const char *str;
-@@ -145,22 +138,7 @@
- RAND_seed(buf, CRYPT_SSLEAY_RAND_BUFSIZE);
- }
-
-- if(ssl_version == 23) {
-- ctx = SSL_CTX_new(SSLv23_client_method());
-- }
-- else if(ssl_version == 3) {
-- ctx = SSL_CTX_new(SSLv3_client_method());
-- }
-- else {
--#ifndef OPENSSL_NO_SSL2
-- /* v2 is the default */
-- ctx = SSL_CTX_new(SSLv2_client_method());
--#else
-- /* v3 is the default */
-- ctx = SSL_CTX_new(SSLv3_client_method());
--#endif
-- }
--
-+ ctx = SSL_CTX_new(SSLv23_client_method());
- SSL_CTX_set_options(ctx,SSL_OP_ALL|0);
- SSL_CTX_set_default_verify_paths(ctx);
- SSL_CTX_set_verify(ctx, SSL_VERIFY_NONE, NULL);
diff --git a/dev-perl/Crypt-SSLeay/metadata.xml b/dev-perl/Crypt-SSLeay/metadata.xml
deleted file mode 100644
index 11be0c7..0000000
--- a/dev-perl/Crypt-SSLeay/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>perl@gentoo.org</email>
- <name>Gentoo Perl Project</name>
- </maintainer>
- <upstream>
- <remote-id type="cpan">Crypt-SSLeay</remote-id>
- <remote-id type="cpan-module">Crypt::SSLeay</remote-id>
- <remote-id type="cpan-module">Crypt::SSLeay::CTX</remote-id>
- <remote-id type="cpan-module">Crypt::SSLeay::Conn</remote-id>
- <remote-id type="cpan-module">Crypt::SSLeay::Err</remote-id>
- <remote-id type="cpan-module">Crypt::SSLeay::MainContext</remote-id>
- <remote-id type="cpan-module">Crypt::SSLeay::X509</remote-id>
- <remote-id type="cpan-module">DB</remote-id>
- <remote-id type="cpan-module">Net::SSL</remote-id>
- </upstream>
-</pkgmetadata>