summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-22 09:14:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-22 09:57:56 +0200
commitf7ec5cc7ea75d548914ea490624ead9c6c664a54 (patch)
tree5d6a207506ca78d088d27cbc71aa5ab1b3929b0e
parentdev-python/identify: Bump to 2.2.5 (diff)
downloadgentoo-f7ec5cc7ea75d548914ea490624ead9c6c664a54.tar.gz
gentoo-f7ec5cc7ea75d548914ea490624ead9c6c664a54.tar.bz2
gentoo-f7ec5cc7ea75d548914ea490624ead9c6c664a54.zip
dev-python/botocore: Bump to 1.20.78
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.78.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 19ba7c100d82..71eb99279f88 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -13,3 +13,4 @@ DIST botocore-1.20.74.tar.gz 7729804 BLAKE2B 0693da2be219ee140c5c00a540756d31651
DIST botocore-1.20.75.tar.gz 7750681 BLAKE2B 4cf5700ccdd43a7d963fc60c7e0db5204947e6d3c63747882fa01856ab4e97bba5f4174a8f4252e3389d6aa6436473f9124f445a53b2cc4233b8d7ed22cb5fef SHA512 736f9d8e4875fd273e73e25ba791117c146c0facdd68970f8d2127245805383119178faa4c91d9dc43ec045e59bf39dbece40d6946013ce9c8ac3c5d1ef9bd84
DIST botocore-1.20.76.tar.gz 7755457 BLAKE2B 26246a4118ce32098676b4933548792a7a5290866c53876053c6f509d1695b467bd7a63d994020ab4b8c85b7beefd9e7b06fa6509787d954c2e0e1d16783b7f3 SHA512 43a74493ce3a69d621c8adef18bb39aece146a83a75745ba79216ab839161095c05ed53c1a00edcfba291e7321d28db107c3baee81ae970d5768c2f6dec79c5b
DIST botocore-1.20.77.tar.gz 7758363 BLAKE2B a441fc84ce0095cbad1df59c26c533c38068574d1a5b3ac68091575d607d0ab5954852a1c82eee1bb394ed8e6789076d9a8ca2afdb02c6e492dbb2f22c8c3e6e SHA512 840b5cd6356ce3d716d8f04ed7a04e5169336444b4f3ad114e1d8122ce999f26ecb57f51c7afec33856ae0f6d68d9a5966a5ee14f1341a144586f0fa2ebfba64
+DIST botocore-1.20.78.tar.gz 7758829 BLAKE2B af13d6c1aa918e2c49c6dc931c9a78e1899c83e62657c063e20ba2a5544c48e4946018628e47d6a56db456a3a8d43fe3b577824bd76bbc339abaef375459932e SHA512 fc96ed8b6b4af05404654e470a4f83419b885fa32d9dc704727f4ffb3d5deeefa752d235b37fd81448b7f3b101bc0f8e7ea09ae8641f8961566f77f6a039cef9
diff --git a/dev-python/botocore/botocore-1.20.78.ebuild b/dev-python/botocore/botocore-1.20.78.ebuild
new file mode 100644
index 000000000000..afca295f8bed
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.78.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}