summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2021-05-19 20:56:52 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-06-09 09:08:33 +0300
commit3987cf30969dab7d8052b88e8b19afed8f5952f2 (patch)
treeee783ee14d53af346a1708d5c3b020d07bcdbdca
parentapp-shells/zsh-completions: fix LICENSE (diff)
downloadgentoo-3987cf30969dab7d8052b88e8b19afed8f5952f2.tar.gz
gentoo-3987cf30969dab7d8052b88e8b19afed8f5952f2.tar.bz2
gentoo-3987cf30969dab7d8052b88e8b19afed8f5952f2.zip
app-crypt/tpm2-tools: Bump to 4.3.1
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-crypt/tpm2-tools/Manifest1
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-4.3.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/Manifest b/app-crypt/tpm2-tools/Manifest
index 23b297edef55..8981e58caac5 100644
--- a/app-crypt/tpm2-tools/Manifest
+++ b/app-crypt/tpm2-tools/Manifest
@@ -1,2 +1,3 @@
DIST tpm2-tools-4.3.0.tar.gz 881544 BLAKE2B 0415f30845658e84e97a964abebc3082e45fb880c10bec405cd89c7bfa373ace10b669c4af78e7e47f2d2bb62fc7cc34b2e54e392a95c8f9b8956b8c92af6aee SHA512 4e622bbc8642ba7fd93a7343900560fe3779cba03e363d16f391fc8929724a11913d238e3986de06982cbced27c3c2ca8c7e73d75796407b8646c101ccf393a8
+DIST tpm2-tools-4.3.1.tar.gz 891993 BLAKE2B d145fd542952ebbf59bb82640b9ac41cc777dcd8f526683447e3a3fd22fd4c46ab59899418ae52382d88e05418b772afd7f10093c5e0ef4cba685470cf7a7c8e SHA512 0104b6bca9e56ee30c033f3ddb2ab75b683b07ff917b800ff8fde49ce5cdc6d42e5fff63ed3ee9700f656dbf34bca76cee7408c256f1e30d92148c506b0032f2
DIST tpm2-tools-5.0.tar.gz 990855 BLAKE2B 5d39bbef0bc6f0d84f37c64c697260343a9f9e134bce015a6b529176195adb907672f35b85382b0a4785e40e368030ac347083086c3799bdfe86dced1ac69848 SHA512 ea57a28a61e28b78cae7067ff58facd8754fafab7a2689fd93f8b3374073b6ac30301a75f8ff5c654800ab469ee6604d0b8a86c310631b9545b816ecaa05968e
diff --git a/app-crypt/tpm2-tools/tpm2-tools-4.3.1.ebuild b/app-crypt/tpm2-tools/tpm2-tools-4.3.1.ebuild
new file mode 100644
index 000000000000..01663f80cd57
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-4.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+fapi"
+
+# Integration test are now run as part of the testing suite, which will fail
+# because none of the supported TPM emulators are in Portage. In a future
+# version of tpm2-tools, swtpm will be supported and the tests can be run.
+RESTRICT="test"
+
+RDEPEND="net-misc/curl:=
+ >=app-crypt/tpm2-tss-2.4.0:=[fapi?]
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/autoconf-archive"
+PATCHES=(
+ "${FILESDIR}/${PN}-4.3.0-Remove-WError.patch"
+)
+
+src_prepare() {
+ sed -i \
+ "s/m4_esyscmd_s(\[git describe --tags --always --dirty\])/${PV}/" \
+ "${S}/configure.ac" || die
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable fapi) \
+ --enable-hardening
+}