summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-01-27 16:52:18 -0500
committerMarc Schiffbauer <mschiff@gentoo.org>2024-01-29 10:50:46 +0100
commitaccb96ccd7e9fb4acc0710eec5abba7a3b0e3c7f (patch)
treed6de00823dfcca84971c37ad7e90f5207ea3e038
parentmedia-libs/netpbm: Stabilize 11.2.7 hppa, #923246 (diff)
downloadgentoo-accb96ccd7e9fb4acc0710eec5abba7a3b0e3c7f.tar.gz
gentoo-accb96ccd7e9fb4acc0710eec5abba7a3b0e3c7f.tar.bz2
gentoo-accb96ccd7e9fb4acc0710eec5abba7a3b0e3c7f.zip
app-backup/bareos: Include <algorithm> for GCC 14
Also moved eapply's to a PATCHES array for app-backup/bareos. https://gcc.gnu.org/gcc-14/porting_to.html Closes: https://bugs.gentoo.org/920489 Signed-off-by: Christopher Fore <csfore@posteo.net> Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
-rw-r--r--app-backup/bareos/bareos-22.1.2-r1.ebuild15
-rw-r--r--app-backup/bareos/files/bareos-22.1.2-include-algorithm.patch41
2 files changed, 50 insertions, 6 deletions
diff --git a/app-backup/bareos/bareos-22.1.2-r1.ebuild b/app-backup/bareos/bareos-22.1.2-r1.ebuild
index 3ec758c53539..d61de65c0fc7 100644
--- a/app-backup/bareos/bareos-22.1.2-r1.ebuild
+++ b/app-backup/bareos/bareos-22.1.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -99,6 +99,14 @@ REQUIRED_USE="
x86? ( !ceph )
"
+PATCHES=(
+ # fix gentoo platform support
+ "${FILESDIR}/${PN}-21-cmake-gentoo.patch"
+ "${FILESDIR}/${PN}-22.0.2-werror.patch"
+ "${FILESDIR}/${PN}-21.1.2-no-automagic-ccache.patch"
+ "${FILESDIR}/${PN}-22.1.2-include-algorithm.patch"
+)
+
pkg_pretend() {
local active_removed_backend=""
if has_version "<app-backup/bareos-21[director,mysql]"; then
@@ -149,11 +157,6 @@ src_test() {
}
src_prepare() {
- # fix gentoo platform support
- eapply -p1 "${FILESDIR}/${PN}-21-cmake-gentoo.patch"
- eapply "${FILESDIR}/${PN}-22.0.2-werror.patch"
- eapply "${FILESDIR}/${PN}-21.1.2-no-automagic-ccache.patch"
-
# fix missing DESTDIR in symlink creation
sed -i '/bareos-symlink-default-db-backend.cmake/d' "${S}/core/src/cats/CMakeLists.txt"
diff --git a/app-backup/bareos/files/bareos-22.1.2-include-algorithm.patch b/app-backup/bareos/files/bareos-22.1.2-include-algorithm.patch
new file mode 100644
index 000000000000..5f71576bc001
--- /dev/null
+++ b/app-backup/bareos/files/bareos-22.1.2-include-algorithm.patch
@@ -0,0 +1,41 @@
+From https://github.com/bareos/bareos/pull/1687/commits/3907be7ff9700d0328198b47c58885f5ec56546c
+https://bugs.gentoo.org/920489
+
+diff --git a/core/src/cats/sql_get.cc b/core/src/cats/sql_get.cc
+index b5d921c..150ebfc 100644
+--- a/core/src/cats/sql_get.cc
++++ b/core/src/cats/sql_get.cc
+@@ -31,6 +31,7 @@
+ */
+
+ #include "include/bareos.h"
++#include <algorithm>
+
+ #if HAVE_SQLITE3 || HAVE_MYSQL || HAVE_POSTGRESQL || HAVE_INGRES || HAVE_DBI
+
+diff --git a/core/src/stored/append.cc b/core/src/stored/append.cc
+index 05f6784..32234d4 100644
+--- a/core/src/stored/append.cc
++++ b/core/src/stored/append.cc
+@@ -41,6 +41,8 @@
+ #include "lib/berrno.h"
+ #include "lib/berrno.h"
+
++#include <algorithm>
++
+ namespace storagedaemon {
+
+ /* Responses sent to the daemon */
+diff --git a/core/src/dird/ua_prune.cc b/core/src/dird/ua_prune.cc
+index 9a0770c..15a0a56 100644
+--- a/core/src/dird/ua_prune.cc
++++ b/core/src/dird/ua_prune.cc
+@@ -40,6 +40,8 @@
+ #include "lib/edit.h"
+ #include "lib/parse_conf.h"
+
++#include <algorithm>
++
+ namespace directordaemon {
+
+ /* Forward referenced functions */