summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-08 17:07:38 +0000
committerSam James <sam@gentoo.org>2021-02-08 17:20:54 +0000
commitf9a7aac84cf9e7c65ac34c1d64a45a1c8d0ed936 (patch)
treeea56e706185cf9037e457b93bc365c4e2acfb552
parentdev-ml/opam-solver: add ml@ (diff)
downloadgentoo-f9a7aac84cf9e7c65ac34c1d64a45a1c8d0ed936.tar.gz
gentoo-f9a7aac84cf9e7c65ac34c1d64a45a1c8d0ed936.tar.bz2
gentoo-f9a7aac84cf9e7c65ac34c1d64a45a1c8d0ed936.zip
dev-ml/opam-installer: bump to 2.0.8
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/opam-installer/Manifest1
-rw-r--r--dev-ml/opam-installer/opam-installer-2.0.8.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/Manifest b/dev-ml/opam-installer/Manifest
index b9416004a3a1..5052fbfcb465 100644
--- a/dev-ml/opam-installer/Manifest
+++ b/dev-ml/opam-installer/Manifest
@@ -1 +1,2 @@
DIST opam-full-2.0.7.tar.gz 7929123 BLAKE2B 100acc2c31e97e47b0b584f3a153283593351d49d5e9cdaca42fdcc025b135d9538bd327927950e7e0972b20f561a0ee3d1d1b5b4b87e1e6af31761e311081e7 SHA512 670af4935bba0679c65f6592b7a52b1d429b604eb261e40b13cf72312aeb0bab0c5a76829a555fc5379a0371c352692cbabc46b460fcd9bf32b3cfebdaeceb81
+DIST opam-full-2.0.8.tar.gz 8006252 BLAKE2B 26348bdbb8bdc2fbf9d736286c1f4134ce065e8c15e34d51c8d2c6e5338fd6db089df38a19b07cde70770724fc4cc3dbd9e7d75628e5435ca8a2f8c0d4d3f2f0 SHA512 f08893ad0c1e124368168f28dcb5c3293e443da712d7b12db432c21ff72f7e1440bcc7156f49661d286360a16dcd166d3d02ecdebf8b1cda7c7df2b22e48f80f
diff --git a/dev-ml/opam-installer/opam-installer-2.0.8.ebuild b/dev-ml/opam-installer/opam-installer-2.0.8.ebuild
new file mode 100644
index 000000000000..fad39a7a5703
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+inherit opam
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-lang/ocaml-4.02.3"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}
+
+src_compile() {
+ sed -e 's/DUNE = .*$/DUNE = /' -i Makefile.config
+ emake lib-ext
+ #passing -jX to the dune build leads to errors
+ #see: https://github.com/ocaml/opam/issues/3585
+ emake DUNE_PROMOTE_ARG="" -j1
+}