summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-04 06:42:51 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-04 06:54:21 +0100
commit21bd92420253959af1727a12540709b6d5bf05e8 (patch)
treeeb21a142196300802e161c9b2986612003ff351d /app-emacs
parentapp-emacs/lv: import of 0.15.0 (diff)
downloadgentoo-21bd92420253959af1727a12540709b6d5bf05e8.tar.gz
gentoo-21bd92420253959af1727a12540709b6d5bf05e8.tar.bz2
gentoo-21bd92420253959af1727a12540709b6d5bf05e8.zip
app-emacs/lsp-mode: import of 8.0.0
Closes: https://bugs.gentoo.org/770142 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/lsp-mode/Manifest1
-rw-r--r--app-emacs/lsp-mode/files/50lsp-mode-gentoo.el35
-rw-r--r--app-emacs/lsp-mode/lsp-mode-8.0.0.ebuild39
-rw-r--r--app-emacs/lsp-mode/metadata.xml12
4 files changed, 87 insertions, 0 deletions
diff --git a/app-emacs/lsp-mode/Manifest b/app-emacs/lsp-mode/Manifest
new file mode 100644
index 000000000000..a66229b89085
--- /dev/null
+++ b/app-emacs/lsp-mode/Manifest
@@ -0,0 +1 @@
+DIST lsp-mode-8.0.0.tar.gz 14703640 BLAKE2B ab7993772cfc127ee94ba4a0af75e8d7f6789ac22c76acce8df250b5579c1dd2f41e353b26cbdcf6e1a2e6a8d1f8a179d4736b67914cdec31c23032f93dffd3c SHA512 2620288142cea7b06ad2725b63e5db945b1d62d0b4c215e8d35d79d6c3f05bcdf2736dab34bd10c2b9f8928caf36ef617182c41c309e62e2ce8ddf45df376cbc
diff --git a/app-emacs/lsp-mode/files/50lsp-mode-gentoo.el b/app-emacs/lsp-mode/files/50lsp-mode-gentoo.el
new file mode 100644
index 000000000000..c7cd4f608612
--- /dev/null
+++ b/app-emacs/lsp-mode/files/50lsp-mode-gentoo.el
@@ -0,0 +1,35 @@
+;;; lsp-mode site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'lsp-completion-at-point "lsp-completion" "Get lsp completions." t)
+(autoload 'lsp-completion--enable "lsp-completion" "Enable LSP completion support.")
+(autoload 'lsp-completion-mode "lsp-completion" "Toggle LSP completion support." t)
+
+(autoload 'lsp-diagnostics--enable "lsp-diagnostics" "Enable LSP checker support.")
+(autoload 'lsp-diagnostics-mode "lsp-diagnostics" "Toggle LSP diagnostics integration." t)
+
+(autoload 'lsp-dired-mode "lsp-dired" "Display `lsp-mode' icons for each file in a dired buffer." t)
+
+(autoload 'lsp-headerline--enable-breadcrumb "lsp-headerline" "Enable breadcrumb on headerline.")
+(autoload 'lsp-headerline-breadcrumb-mode "lsp-headerline" "Toggle breadcrumb on headerline." t)
+
+(autoload 'lsp-ido-workspace-symbol "lsp-ido" "`ido' for lsp workspace/symbol." t)
+
+(autoload 'lsp-iedit-highlights "lsp-iedit" "Start an `iedit' operation on the documentHighlights at point." t)
+
+(autoload 'lsp-lens--enable "lsp-lens" "Enable lens mode.")
+(autoload 'lsp-lens-show "lsp-lens" "Display lenses in the buffer." t)
+(autoload 'lsp-lens-mode "lsp-lens" "Toggle code-lens overlays." t)
+
+(autoload 'lsp "lsp-mode" "Entry point for the server startup." t)
+(autoload 'lsp-deferred "lsp-mode" "Entry point that defers server startup until buffer is visible." t)
+
+(autoload 'lsp-modeline-code-actions-mode "lsp-modeline" "Toggle code actions on modeline." t)
+(autoload 'lsp-modeline-diagnostics-mode "lsp-modeline" "Toggle diagnostics modeline." t)
+(autoload 'lsp-modeline-workspace-status-mode "lsp-modeline" "Toggle workspace status on modeline." t)
+
+(autoload 'lsp--semantic-tokens-initialize-buffer "lsp-semantic-tokens" "Initialize the buffer for semantic tokens.")
+(autoload 'lsp--semantic-tokens-initialize-workspace "lsp-semantic-tokens" "Initialize semantic tokens for WORKSPACE.")
+(autoload 'lsp-semantic-tokens--enable "lsp-semantic-tokens" "Enable semantic tokens mode.")
+(autoload 'lsp-semantic-tokens-mode "lsp-semantic-tokens" "Toggle semantic-tokens support.")
diff --git a/app-emacs/lsp-mode/lsp-mode-8.0.0.ebuild b/app-emacs/lsp-mode/lsp-mode-8.0.0.ebuild
new file mode 100644
index 000000000000..610948576522
--- /dev/null
+++ b/app-emacs/lsp-mode/lsp-mode-8.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Emacs client/library for the Language Server Protocol"
+HOMEPAGE="https://emacs-lsp.github.io/lsp-mode/"
+SRC_URI="https://github.com/emacs-lsp/lsp-mode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+DOCS="CHANGELOG.org README.md"
+
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/dash-2.18.0
+ >=app-emacs/f-0.20.0
+ >=app-emacs/ht-2.3
+ app-emacs/lv
+ >=app-emacs/markdown-mode-2.3
+ >=app-emacs/spinner-1.7.3
+"
+DEPEND=${RDEPEND}
+
+# Requires unpackaged dependencies, e.g. Cask
+RESTRICT="test"
+
+src_install() {
+ elisp_src_install
+
+ elisp-install ${PN}/clients clients/*
+}
diff --git a/app-emacs/lsp-mode/metadata.xml b/app-emacs/lsp-mode/metadata.xml
new file mode 100644
index 000000000000..75a2e5515257
--- /dev/null
+++ b/app-emacs/lsp-mode/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">emacs-lsp/lsp-mode</remote-id>
+</upstream>
+</pkgmetadata>