summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2022-07-10 12:18:34 -0700
committerBrian Dolbec <dolsen@gentoo.org>2022-07-10 12:19:54 -0700
commit96c3a205db773112ed987fa6e3d632febd58092a (patch)
tree6df7bf87c68a26345a21439b3211a54427aade1e /app-portage
parentdev-python/PyPDF2: Remove old (diff)
downloadgentoo-96c3a205db773112ed987fa6e3d632febd58092a.tar.gz
gentoo-96c3a205db773112ed987fa6e3d632febd58092a.tar.bz2
gentoo-96c3a205db773112ed987fa6e3d632febd58092a.zip
app-portage/gentoolkit: Bump to 0.6.1, update 9999
too many bug fixes to list here. See NEWS file or git log. Adds py3.11, removes py3.7 Migrated to setuptools Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/Manifest1
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.6.1.ebuild67
-rw-r--r--app-portage/gentoolkit/gentoolkit-9999.ebuild6
3 files changed, 71 insertions, 3 deletions
diff --git a/app-portage/gentoolkit/Manifest b/app-portage/gentoolkit/Manifest
index 08bf8c5a57b2..492c0d8e388b 100644
--- a/app-portage/gentoolkit/Manifest
+++ b/app-portage/gentoolkit/Manifest
@@ -1,2 +1,3 @@
DIST gentoolkit-0.5.0.tar.gz 3206598 BLAKE2B a379dcbbaba9d52c241fea020b87c458384e44092539947909e14fd6c63fd9cc06d076b8081874edf17fc50e80fe48ceab3400c90046867dc409e7ac39c17231 SHA512 8a5c344f3a17c4c779abbcaa35b5e3f147106dbc61310d0d1a816ec8080914271fa45c311a8feeb1bfe14195af7cf34c0b29142d6e43e2de232dae96fbd00861
DIST gentoolkit-0.5.1.tar.gz 3203805 BLAKE2B de2cd69aec9be79f498b1180a90afb54e77f9d8a47636cd722f2028a906d43874132d55a71bf373b3d10c7c10034f5d8ce0280a35041b0c60a1d5aa2ed6296a1 SHA512 667e464853b17ae297c59fb06e8f4563119a1382470d064c5721ae898e61173e9af5b071c7618d315232e6974fec205e27559785d2816253711de3e83d9e1911
+DIST gentoolkit-0.6.1.tar.gz 3195781 BLAKE2B 27e370de77586b375dc70caa1abba4c2bc4207e8f08e0a7ea2953097135506949db71ff9102a0ead198e4dea425440c57b94ac7a811ca2d5e0016fc7e234bb0d SHA512 1ffc466b69a9c53f1bbd40f6f4d1eb33d5f0f4287bb65ba1a7b1b2675ad61ecffa55ed9fda7c1ae8148744f0a77e224315eb1903dfd61a2a3dab1600fc672d2d
diff --git a/app-portage/gentoolkit/gentoolkit-0.6.1.ebuild b/app-portage/gentoolkit/gentoolkit-0.6.1.ebuild
new file mode 100644
index 000000000000..c9406219f5e3
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.6.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="xml(+),threads(+)"
+
+inherit distutils-r1 tmpfiles
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoolkit.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoolkit.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ virtual/awk
+ sys-apps/gentoo-functions"
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ python_setup
+ echo VERSION="${PVR}" "${PYTHON}" setup.py set_version
+ VERSION="${PVR}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+
+ if use prefix-guest ; then
+ # use correct repo name, bug #632223
+ sed -i \
+ -e "/load_profile_data/s/repo='gentoo'/repo='gentoo_prefix'/" \
+ pym/gentoolkit/profile.py || die
+ fi
+}
+
+pkg_postinst() {
+ tmpfiles_process revdep-rebuild.conf
+
+ # Only show the elog information on a new install
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "For further information on gentoolkit, please read the gentoolkit"
+ elog "guide: https://wiki.gentoo.org/wiki/Gentoolkit"
+ elog
+ elog "Another alternative to equery is app-portage/portage-utils"
+ elog
+ elog "Additional tools that may be of interest:"
+ elog
+ elog " app-admin/eclean-kernel"
+ elog " app-portage/diffmask"
+ elog " app-portage/flaggie"
+ elog " app-portage/portpeek"
+ elog " app-portage/smart-live-rebuild"
+ fi
+}
diff --git a/app-portage/gentoolkit/gentoolkit-9999.ebuild b/app-portage/gentoolkit/gentoolkit-9999.ebuild
index 9c1afefeba26..d030b9327a92 100644
--- a/app-portage/gentoolkit/gentoolkit-9999.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-9999.ebuild
@@ -3,8 +3,8 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="xml(+),threads(+)"
inherit distutils-r1 tmpfiles
@@ -26,7 +26,7 @@ SLOT="0"
DEPEND="
sys-apps/portage[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
- sys-apps/gawk
+ virtual/awk
sys-apps/gentoo-functions"
distutils_enable_tests setup.py