summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-16 08:28:36 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-16 08:28:36 +0100
commit7fed7f023b932f343c8432cfc86204cb9e1b1584 (patch)
tree08ff98b7ff2231d95adf42347dda98b1527556b8 /dev-lang
parentx11-terms/kitty: add 0.38.0 (diff)
downloadgentoo-7fed7f023b932f343c8432cfc86204cb9e1b1584.tar.gz
gentoo-7fed7f023b932f343c8432cfc86204cb9e1b1584.tar.bz2
gentoo-7fed7f023b932f343c8432cfc86204cb9e1b1584.zip
dev-lang/python: Fix VERIFY_SIG_METHOD declaration for deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.14.0_alpha1-r100.ebuild2
-rw-r--r--dev-lang/python/python-3.14.0_alpha1.ebuild2
-rw-r--r--dev-lang/python/python-3.14.0_alpha2-r100.ebuild2
-rw-r--r--dev-lang/python/python-3.14.0_alpha2.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/python/python-3.14.0_alpha1-r100.ebuild b/dev-lang/python/python-3.14.0_alpha1-r100.ebuild
index 6931265fcede..383489c196ee 100644
--- a/dev-lang/python/python-3.14.0_alpha1-r100.ebuild
+++ b/dev-lang/python/python-3.14.0_alpha1-r100.ebuild
@@ -5,6 +5,7 @@ EAPI="8"
LLVM_COMPAT=( 18 )
LLVM_OPTIONAL=1
+VERIFY_SIG_METHOD=sigstore
WANT_LIBTOOL="none"
inherit autotools check-reqs flag-o-matic linux-info llvm-r1
@@ -104,7 +105,6 @@ if [[ ${PV} != *_alpha* ]]; then
fi
# https://www.python.org/downloads/metadata/sigstore/
-VERIFY_SIG_METHOD=sigstore
VERIFY_SIG_CERT_IDENTITY=hugo@python.org
VERIFY_SIG_CERT_OIDC_ISSUER=https://github.com/login/oauth
diff --git a/dev-lang/python/python-3.14.0_alpha1.ebuild b/dev-lang/python/python-3.14.0_alpha1.ebuild
index a50eeaba7c54..5e250f38aca1 100644
--- a/dev-lang/python/python-3.14.0_alpha1.ebuild
+++ b/dev-lang/python/python-3.14.0_alpha1.ebuild
@@ -5,6 +5,7 @@ EAPI="8"
LLVM_COMPAT=( 18 )
LLVM_OPTIONAL=1
+VERIFY_SIG_METHOD=sigstore
WANT_LIBTOOL="none"
inherit autotools check-reqs flag-o-matic linux-info llvm-r1
@@ -104,7 +105,6 @@ if [[ ${PV} != *_alpha* ]]; then
fi
# https://www.python.org/downloads/metadata/sigstore/
-VERIFY_SIG_METHOD=sigstore
VERIFY_SIG_CERT_IDENTITY=hugo@python.org
VERIFY_SIG_CERT_OIDC_ISSUER=https://github.com/login/oauth
diff --git a/dev-lang/python/python-3.14.0_alpha2-r100.ebuild b/dev-lang/python/python-3.14.0_alpha2-r100.ebuild
index f5a238388079..defd21ebb239 100644
--- a/dev-lang/python/python-3.14.0_alpha2-r100.ebuild
+++ b/dev-lang/python/python-3.14.0_alpha2-r100.ebuild
@@ -5,6 +5,7 @@ EAPI="8"
LLVM_COMPAT=( 18 )
LLVM_OPTIONAL=1
+VERIFY_SIG_METHOD=sigstore
WANT_LIBTOOL="none"
inherit autotools check-reqs flag-o-matic linux-info llvm-r1
@@ -104,7 +105,6 @@ if [[ ${PV} != *_alpha* ]]; then
fi
# https://www.python.org/downloads/metadata/sigstore/
-VERIFY_SIG_METHOD=sigstore
VERIFY_SIG_CERT_IDENTITY=hugo@python.org
VERIFY_SIG_CERT_OIDC_ISSUER=https://github.com/login/oauth
diff --git a/dev-lang/python/python-3.14.0_alpha2.ebuild b/dev-lang/python/python-3.14.0_alpha2.ebuild
index fe62a992ea70..8707fa5f11da 100644
--- a/dev-lang/python/python-3.14.0_alpha2.ebuild
+++ b/dev-lang/python/python-3.14.0_alpha2.ebuild
@@ -5,6 +5,7 @@ EAPI="8"
LLVM_COMPAT=( 18 )
LLVM_OPTIONAL=1
+VERIFY_SIG_METHOD=sigstore
WANT_LIBTOOL="none"
inherit autotools check-reqs flag-o-matic linux-info llvm-r1
@@ -104,7 +105,6 @@ if [[ ${PV} != *_alpha* ]]; then
fi
# https://www.python.org/downloads/metadata/sigstore/
-VERIFY_SIG_METHOD=sigstore
VERIFY_SIG_CERT_IDENTITY=hugo@python.org
VERIFY_SIG_CERT_OIDC_ISSUER=https://github.com/login/oauth