summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-09-03 18:19:28 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-10-10 22:25:00 +0200
commitd89ae2eed3daab6a536da3e7d6a91f4bab005314 (patch)
tree85245e794117ec780f2817fff2df54ec810704d8 /dev-libs/cgilib/cgilib-0.7-r2.ebuild
parentnet-libs/libircclient: EAPI8 bump, use https, enable ipv6 unconditional (diff)
downloadgentoo-d89ae2eed3daab6a536da3e7d6a91f4bab005314.tar.gz
gentoo-d89ae2eed3daab6a536da3e7d6a91f4bab005314.tar.bz2
gentoo-d89ae2eed3daab6a536da3e7d6a91f4bab005314.zip
dev-libs/cgilib: EAPI8 bump, delete unused libtool files
Closes: https://bugs.gentoo.org/842870 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/38412 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/cgilib/cgilib-0.7-r2.ebuild')
-rw-r--r--dev-libs/cgilib/cgilib-0.7-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/cgilib/cgilib-0.7-r2.ebuild b/dev-libs/cgilib/cgilib-0.7-r2.ebuild
new file mode 100644
index 000000000000..8c0584ac9a4b
--- /dev/null
+++ b/dev-libs/cgilib/cgilib-0.7-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Simple and lightweight interface to the CGI for C and C++ programs"
+HOMEPAGE="https://www.infodrom.org/projects/cgilib/"
+SRC_URI="https://www.infodrom.org/projects/cgilib/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static-libs"
+
+DOCS=( AUTHORS ChangeLog README cookies.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}