summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-15 17:12:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-15 17:12:24 +0200
commit1b849ab1f01e001073e03427a4f4513b27d3e2ba (patch)
treeab78b06d1bafab7a62661da899c3d308f45900e9 /dev-ml/ocaml-sqlite3
parentnet-libs/tox: use snapshot instead of live ebuild (diff)
downloadgentoo-1b849ab1f01e001073e03427a4f4513b27d3e2ba.tar.gz
gentoo-1b849ab1f01e001073e03427a4f4513b27d3e2ba.tar.bz2
gentoo-1b849ab1f01e001073e03427a4f4513b27d3e2ba.zip
dev-ml/ocaml-sqlite3: bump to 4.0.5
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ml/ocaml-sqlite3')
-rw-r--r--dev-ml/ocaml-sqlite3/Manifest1
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sqlite3/Manifest b/dev-ml/ocaml-sqlite3/Manifest
index 147bdad124af..0a334f560ed9 100644
--- a/dev-ml/ocaml-sqlite3/Manifest
+++ b/dev-ml/ocaml-sqlite3/Manifest
@@ -1,2 +1,3 @@
DIST sqlite3-ocaml-4.0.3.tar.gz 67376 SHA256 390383088b07fde6f775d060e59551ea796334b23b480d9937ad6429cd615d30 SHA512 5304874ac51aba140a4f2d5bbd147092d25a7fdfb006ff89800d54d7351e717b4db28732f0c7acba80d24bc78e198249cd01c1801034040bded8ebd941bfd482 WHIRLPOOL c2ecacd570b06a3ac375cba88b54ccf5de9ae130dcffbc71d25a91f16c5ccbecdb4303e7da8e7addb4027d8b0457798e1858ec2a82866d2b6089a9d6c6243ba0
DIST sqlite3-ocaml-4.0.4.tar.gz 67641 SHA256 f8cfe8c597835c7c5e5f3fbf9e12b9ee882009c0fee956e102bb4a7190c0e3cf SHA512 679eb9b1b2926e8e6e21f0ff3204435faf6855218d087a3881bd6ffd403cc85bd6073fd737200a5c3b0484a80ea139fcd1fc5d6d66bdba99f19df555373d447c WHIRLPOOL c82e99989f7b60d6bd2e721c9146d57d63570a003221e101f517ab377275d5d96abbc36b43fab458724104f75e8175687d0af0992d0e8a22e34fc1ba5c4720b1
+DIST sqlite3-ocaml-4.0.5.tar.gz 67839 SHA256 bf0bdc597533d62b8de2798e9aa46c37570875cb4af4f9f42fba21dd59f3f0cb SHA512 cdb01cddc702e30fdeaf5b7a45223d28abf33f3568850d5dad97926cf1358990edb363c38e199c1f30048e2d79211e6ad84046f8ed5d5ad4f0f6527b19b8e70d WHIRLPOOL ec319097214426e1d94b32c9d788490839bd5cb542a8c0b3354b4dc98028225ee54bdbe4a32ec481d842772730c2625f3bf5c9da4e705dcac99bab1bcbda661d
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.5.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.5.ebuild
new file mode 100644
index 000000000000..c4ac79bc1c30
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_PN="sqlite3-ocaml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases"
+HOMEPAGE="http://mmottl.github.io/sqlite3-ocaml/"
+SRC_URI="https://github.com/mmottl/sqlite3-ocaml/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-db/sqlite-3.3.3
+ >=dev-ml/findlib-1.3.2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" "TODO.md" )