summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-11-19 23:31:12 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-11-19 23:31:12 +0100
commit15fafbc6130cf242e553a1131c5b3e6fed9f286b (patch)
treeee3f4d150ae0af79bdca7678bf72b1fdcfd96297 /dev-ml/ordering
parentdev-ml/pp: new package, add 1.1.2 (diff)
downloadgentoo-15fafbc6130cf242e553a1131c5b3e6fed9f286b.tar.gz
gentoo-15fafbc6130cf242e553a1131c5b3e6fed9f286b.tar.bz2
gentoo-15fafbc6130cf242e553a1131c5b3e6fed9f286b.zip
dev-ml/ordering: new package, add 3.0.3
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ordering')
-rw-r--r--dev-ml/ordering/Manifest1
-rw-r--r--dev-ml/ordering/metadata.xml11
-rw-r--r--dev-ml/ordering/ordering-3.0.3.ebuild32
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ordering/Manifest b/dev-ml/ordering/Manifest
new file mode 100644
index 000000000000..773da28d4eed
--- /dev/null
+++ b/dev-ml/ordering/Manifest
@@ -0,0 +1 @@
+DIST dune-3.0.3.tar.gz 1725788 BLAKE2B 2de93c085f642c8381642a08b18bc21ad48097f32397b3eddab9725deb267b089849b649705e1b72bb1b5b37f7531fd9e0cfb134174f0cb3a8ee2595c7dcf8ce SHA512 839e942bcf8189763d0d9b01614333bb2f036bce68c82959e51d2e9145b57067cb862b66781912391c1a0f531b8dddf2ffeafcee71c626169a437fe40feba155
diff --git a/dev-ml/ordering/metadata.xml b/dev-ml/ordering/metadata.xml
new file mode 100644
index 000000000000..86dc156e664c
--- /dev/null
+++ b/dev-ml/ordering/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/dune</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ordering/ordering-3.0.3.ebuild b/dev-ml/ordering/ordering-3.0.3.ebuild
new file mode 100644
index 000000000000..0c02ad290b06
--- /dev/null
+++ b/dev-ml/ordering/ordering-3.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Element ordering"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND="~dev-ml/dune-${PV}"
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ --libdir="$(ocamlc -where)" \
+ --mandir="/usr/share/man" \
+ || die
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}